Where are the docker volumes on Home Assistant OS?

Yesterday I deployed my first stack (immich) on portainer, running on my HA OS n my Pi4. I created a volume “immich-library”, mounted it to the stack, and deployed it.
It worked. So far, so good.

Then I tried to login via ssh (using “Advanced SSH & Web Terminal” addon) and navigate to “/mnt/data/docker/volumes/immich-library/_data” where Portainer says I should find the data.
To my surprise, the “mnt” directory was empty!
I tried “docker volumes ls”, and sure enough, the volume is there.
I tried “docker volume inspect immich-library” and I got this

        "CreatedAt": "2024-04-17T11:14:22Z",
        "Driver": "local",
        "Labels": null,
        "Mountpoint": "/mnt/data/docker/volumes/immich-library/_data",
        "Name": "immich-library",
        "Options": {},
        "Scope": "local"

But the mnt is empty!
I tried to find / -type d -name volumes, and nothing.

So, where are the docker volumes on my Home Assistant OS?

Make sure you are in the OS file system and not the home assistant docker file system.

And a few posts below that I put a link to setting up SSH into HAOS.

And then you are in the HA Container and not in HA OS. And in the HA Container the “mnt” directory is empty.

Gaining ssh access to the OS file system is described here Debugging the Home Assistant Operating System | Home Assistant Developer Docs (home-assistant.io)

Or you can use this Add-on
:new:[add-on] HassOS SSH port 22222 Configurator - Installation / Home Assistant OS - Home Assistant Community (home-assistant.io)

1 Like

I thought the standard terminal add-on gives me access to the host :slight_smile:
Thanks for the reference links, I ended up using the add-on that injects my pubkey in the host.