Where is supervisor (Hassio) from home assistant installed via docker?


I installed home assistant via docker, on windows 10 PC and on Ubuntu 18.04. PC I cannot see the supervisor choise (old Hassio).

1 Like

same here, any news?

You installed Home Assistant - Core not Home Assistant - Supervised (hassio)
Check Developer Tools > Info > System Health. It will look like this or similar if you have hassio:
image
(ie hassio TRUE - yours will say False)

1 Like

Ok, but how get supervised from docker instalation?
I used this link as reference https://www.home-assistant.io/docs/installation/docker/
running: docker run --init -d --name="home-assistant" -e "TZ=America/New_York" -v /PATH_TO_YOUR_CONFIG:/config --net=host homeassistant/raspberrypi3-homeassistant:stable

Thanks

Try this:

Scroll down the page to the section titled:
“Alternative: install Home Assistant Supervised on a generic Linux host”

haha, just did before I seen your post. Ty a lot :slight_smile:

1 Like

Just moved from ubuntu vm to the vmdk image from hassos on my qnap nas. Installing on a ubuntu lxc container does not work. Generic linux is not supported anymore.

this is not really true, deprecation is on hold.

1 Like

It will drop eventually i gues. Install script already fails on ubuntu lxc container. Switched from own vm to hassio vm to be sure.

when they will i’ll see what to do, why put effort now if i can postpone it?
the important thing is: for now it works.
when they will drop, if ever, i have time meanwhile to search for alternatives.

I already moved platform, just in case. If generic linux is only maintaned by 1 guy you can expect problems.

No solution !!!
No rubrique :“Alternative: install Home Assistant Supervised on a generic Linux host” !!!

Exactly the same issue !

Do you have some information with latest version HA on Docker to add HASSIO ?

With docker-compose only if possible

Thanks :slight_smile:

There is non, docker is without superviser. running vm’s now.

Hi,

I understand it is not recommended anymore to install HA with Docker if we want to access the Supervisor panel (which seems essential to me…). So which method would you recommend under Raspbian?

Thanks

Edit : just found this page. Will try it…

you’ll not have supervisor panel anyway.
The only ways are hassOS or use supervised on linux.
For the second, you have to search a bit because “official” repo is broken, you can use this: [On Hold] Deprecating Home Assistant Supervised on generic Linux

You’re right, Supervisor is not included in the “Manual installation” version, it’s a shame.

So I have to chose between:

  • hassOS which does not support my Respeaker microphone as the drivers are still not implemented
  • Supervised Ha which is deprecated
  • Unsupervised version. I confess I do not know yet how to install add-ons or restore my snapshot with this version

What would you recommend???

i’m using supervised on linux.
If you have enough resources or it’s fine to completely reserve HW to hassOS or you don’t plan to use that HW for anything else than HA/addons, then go to hassOS.
Otherwise go to supervised on linux.

I was fine with hassOS lately, but as the respeaker is not supported I’m trying to find other options. Do you know a way to install the drivers for repseaker on hassOS?

Alternatively, is there a clear tutorial on how to install supervised on Linux?

Thanks

you basically can’t install any drivers and you are very limited in such operations, with hassOS.
If you go to the link i posted, you’ll see the script to launch for installing HA+supervisor ( hassio ) on linux.
Other than that you can read everything posted here: https://github.com/home-assistant/supervised-installer