Which firmware for Sonoff Dongle-E router?

I’m using Z2M with Sonoff Dongle-P as the coordinator.

Which and where should I download a firmware and flashing tool for Sonoff Dongle-E variant that will be used as a router?


1 Like

Do not confuse “Sonoff ZBDongle-P” with “Sonoff ZBDongle-E”! They are based of radio SoC(s)/MCU(s) from different manufacturers so you can not use the same firmware or flashing tools! If you want to flash a “Sonoff ZBDongle-P” then use firmware and tools for it, and the same goes for “Sonoff ZBDongle-E”. It does not matter what other devices you have, it is only the device that will be flashed that matters. So if you want to flash “Sonoff ZBDongle-E” as a Zigbee Router then you only need to concern yourself with it, regardless which Zigbee Coordinator you have. See these threads which have links to firmware (including link to Zigbee Router firmware for “Sonoff ZBDongle-E”) and if you have any further questions about flashing then post in the questions in those respective threads:

1 Like

I read this post and I used the official router firmware for Dongle E with SecureCRT flash unitlity.
Flashing was successfull.

However, once I plug the dongle to a power source, it is not getting picked up by Z2M.


if not, press one of the buttons to set it into pairing mode

“Finally, the dongle LED blinks green, inidicating it is in paring mode. Pair as usual with Z2M”

This is in green color and still doesn’t show in Z2M

Is your Z2M in pairing mode ?

  • try to restart Z2M , and put in pairing mode
  • bring your dongle e closer to the coordinator

Z2M is set to Permit Join All.

As I said, if it still don’t want to pair, restart Z2M and bring the router closer to the coordinator. Also try another power supply.

I have removed a zigbee led I have, and it rejoined automatically.
so I know that Z2M can pair.

I placed the router very close to my coordinator to no avail

1 Like

I am having the exact same issue. I flagged with.gbl file and for some reason the stick doesn’t go into pairing mode. As in the green led stays on. I’ve flashed several times but still the same outcome. I’ve tried pressing reset but still it can’t get picked up on z2m from coordinator or “join all”.
Did you figure this out?

got it working @abulhr. The missing step is.
to put the dongle in pairing mode. Press and hold the boot button for 5 seconds. The green light will flash.

1 Like

You’re a God-send!
Thank you very much

1 Like