Why is it so complex and difficult to install and maintain HomeAssistant?

Did you use Debian 10 that design for RPI? Where do you download your IMG? Cause it works on my end. So not working for you is one strange thing

Good Luck these people don’t care about us dummies!!

if people dont care you will not see any response on the question ask in this forum.

Nevermind you are correct… there are some bugs on Debian making it unusable when you are running update. I’m working on fixed for this issues.

3 years or running Debian with HA and I have no clue what you are referring to.


Debian 10 for RPI will not boot back on SSD upon update. There are bugs on it https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977694#67

Community discussion regarding this bugs Installing Home Assistant Supervised on a Raspberry Pi with Debian 10

Looks fixed to me :slight_smile:

There are guides for literally every item on this list.
Do you need a guide to finding guides? @DominiqueGEORGES

You replied to the wrong person dude. Nick had simply quoted someone else.

I’m pretty sure I just pushed the reply button at the bottom


Or better yet, reply to the person who can’t get HA working… I’m looking at you @DominiqueGEORGES :wink:

In all seriousness though, just install HassOS since your very early post mentioned:

…and clearly the move complicated HA install methods are simply too difficult for you.

Yes, I know you have tried, but… Just follow the official docs. They do work.

1 Like

Unfortunately not fixed for Debian 10 on Raspberry yet. initramfs-tools v0.140 which is fixing the issue got released for sid (unstable) only.

Hi David.

thanks for your hint.
Yes, I did it,

I had to choose the correct version of the boot eeprom to install.

sudo nano /etc/default/rpi-eeprom-update

Jumping from “default”, “stable”, "critical and “beta”

Flashing with :

sudo rpi-eeprom-update -d -a

And I finally succeeded in flashing the boot EEPROM by playing with “critical” or “beta” in place of “stable”, and forcing a specific version.

Here again, it works, but finally, I don’t know why as I made so many attempts, maybe is the latest action that solved the “boot order” problem, or flashing to another version before reflashing to the current.

But thanks for your analyze :slight_smile:


just one guide to simply configure it, and not tons of useless guides explaining part of the job :upside_down_face:

Now that you have figured it out, you can write a guide to helps others.

Because everyone wants to.achieve different things. So there can’t be a one guide for everything. It must be modular

Hi Dave,

Installing HassOS is indeed peace of cake.
The problem comes with all what you have to install to get things working together.

I reinstall it from scratch.

I still have a Raspberry running :

  • MQTT
  • NodeRed
  • RFX used with NodeRed
  • BlueTooth using NodeRed
  • Z-Wave using NodeRed

I would like to use only ONE raspberry, and use its 1TB SSD to store and analyze my router’s activities (in and outging sessions, …), install MariaDB, Grafana, … but all of these have to be accessible from my LAN, even from WAN using a VPN connection in parallel with DuckDNS :slight_smile:

If I use Docker inside HA, how can all the containers communicate with outside world and how can my LAN devices (PC, …) communicate with them ?

Maybe I’ll have to upgrade to a more powerful server (NUC or something else), but I first have to validate all of this infrastructure before :slight_smile:


You need to use a reverse proxy like nginx.
Guess what, there’s a guide for that

1 Like

No shit, really? Inbetween the tons of useless guides explaining only part of the job? :nerd_face:

Maybe we let @ DominiqueGEORGES finish the basic install first before overburdening him with Reverse Proxies, Nginx and so on. He has just mastered the EEPROM updating, still a long way to go :wink:

Might make it easier for him than using a seperate pi for every service he runs :joy::joy::joy: