Why is it so complex and difficult to install and maintain HomeAssistant?

Looks fixed to me :slight_smile:

There are guides for literally every item on this list.
Do you need a guide to finding guides? @DominiqueGEORGES

You replied to the wrong person dude. Nick had simply quoted someone else.

I’m pretty sure I just pushed the reply button at the bottom

image

Or better yet, reply to the person who can’t get HA working… I’m looking at you @DominiqueGEORGES :wink:

In all seriousness though, just install HassOS since your very early post mentioned:

…and clearly the move complicated HA install methods are simply too difficult for you.

Yes, I know you have tried, but… Just follow the official docs. They do work.

1 Like

Unfortunately not fixed for Debian 10 on Raspberry yet. initramfs-tools v0.140 which is fixing the issue got released for sid (unstable) only.

Hi David.

thanks for your hint.
Yes, I did it,

I had to choose the correct version of the boot eeprom to install.

sudo nano /etc/default/rpi-eeprom-update

Jumping from “default”, “stable”, "critical and “beta”

Flashing with :

sudo rpi-eeprom-update -d -a

And I finally succeeded in flashing the boot EEPROM by playing with “critical” or “beta” in place of “stable”, and forcing a specific version.

Here again, it works, but finally, I don’t know why as I made so many attempts, maybe is the latest action that solved the “boot order” problem, or flashing to another version before reflashing to the current.

But thanks for your analyze :slight_smile:

No,

just one guide to simply configure it, and not tons of useless guides explaining part of the job :upside_down_face:

Now that you have figured it out, you can write a guide to helps others.

Because everyone wants to.achieve different things. So there can’t be a one guide for everything. It must be modular

Hi Dave,

Installing HassOS is indeed peace of cake.
The problem comes with all what you have to install to get things working together.

I reinstall it from scratch.

I still have a Raspberry running :

  • MQTT
  • NodeRed
  • RFX used with NodeRed
  • BlueTooth using NodeRed
  • Z-Wave using NodeRed

I would like to use only ONE raspberry, and use its 1TB SSD to store and analyze my router’s activities (in and outging sessions, …), install MariaDB, Grafana, … but all of these have to be accessible from my LAN, even from WAN using a VPN connection in parallel with DuckDNS :slight_smile:

If I use Docker inside HA, how can all the containers communicate with outside world and how can my LAN devices (PC, …) communicate with them ?

OK.
Maybe I’ll have to upgrade to a more powerful server (NUC or something else), but I first have to validate all of this infrastructure before :slight_smile:

Kr,
Dom

You need to use a reverse proxy like nginx.
Guess what, there’s a guide for that

1 Like

No shit, really? Inbetween the tons of useless guides explaining only part of the job? :nerd_face:

Maybe we let @ DominiqueGEORGES finish the basic install first before overburdening him with Reverse Proxies, Nginx and so on. He has just mastered the EEPROM updating, still a long way to go :wink:

Might make it easier for him than using a seperate pi for every service he runs :joy::joy::joy:

Since there are no reply, I’m assuming you are replying to me. Yes, update all my README files. So you should be able to test my scripts again

Actually it was meant for @DominiqueGEORGES and not you. I may have pressed the wrong reply button :laughing:

And thanks for assuming.

1 Like

Hmmm, yes and … no :wink:

  1. There are 4 different ways of installing HA.
    Each of these have different behaviors (that means there are 4 different HA kits to manage) .
    They may evoluate in parallel ways.

  2. Why having to install MQTT and/or NodeRed to integrate and manage RFX devices ?
    Why not simply integrate it behind an interface that would present you the same way of interaction for all the devices, no matter the protocol used.

  3. Everyone offers his solution, it is very nice, powerful, … but, that means a different logic and a different percent of problem coverage for each of the provided solutions.
    This induces lot of ways to cover partially device usage, but difficult to find the good one, the one which is really maintained, the one which covers all the device possibilities …

HA is (at least seems to be) very powerful, but miss a captain to pilot the boat ;), a manager that creates and forces rules to be followed by developers.

Sorry none of that makes any sense to me

1 Like

:wink:

Tamsy, I agree that managing HA on a Raspberry is far more complex than managing … thousands of servers running in a industrial world where up time and reliability should never go behind 99,999 % (which is is my world) and where easy and standard interconnectivity is the basics.

I understand that I put my expectations for too high, as I try to retrieve such an environment and vision in using HA (and add-ons) on a simple Raspberry.

:frowning:

[DurgNomis-drol](https://community.home-assistant.io/u/DurgNomis-drol)

Now that you have figured it out, you can write a guide to helps others.

I’m not good enough in writing reliable and usable documentation as I should for that.

And as I had to make so many different manipulations to succeed in, that I do not remember what has really been required to have it working.

But I agree that, with the experience (which is really a time consuming activity) we can find a way (not THE way) to install some features, from time to time a way to configure it, but more rarely real life examples with the way to interact with that module.

I love humor (which is generally positive and constructive) but far less sarcasms (negative and far more destructive) :wink: