Why is it so complex and difficult to install and maintain HomeAssistant?

Honnestly, I do not remember what the error was.

I restarted everything from scratch.
HassOS based.

I installed HACS, which seems to be very interresting to connect Awox light and remote command.
Except that once HACS is installed, I don’t know how to configure things.

It is highly possible that I’m really stupid.
But I’m looking for a simple documentation, made for stupid dummies like me.

Which simply explains how to :slight_smile:

  • install HassOS
  • configure it
  • add HACS (with examples, this is the most easy way to understand or with screen captures)
  • add ZigBee (ConBiz device) and examples on how to add and configure standard devices
  • Add Bluetooth (Awox, Xiaomi, … devices)
  • Add Z-Wave
  • Add Wifi devices
  • Add MQTT addon, and make it communicating as with HA, as with devices and also with external world (I mean devices on my LAN)
  • Add NodeRed (same requests)
  • Add RFX 433 controler (actually on a dedicated Raspberry with MQTT and NodeRed)
  • Add VPN and DuckDNS to enable external connectivity from outside.
  • Make it communicate with Alexa
  • Use Tuya devices (LEDs, sensors, …)

In summary, I would like to find the way to make HA Plug and Play and not Plug and Pray :wink:

Till now, restarting installation in every way possible make just frustration higher and higher, and nothing else.

I need constructive and simple help, not getting pointer to pointer which point to documentation pointing to other documentation finally pointing to dead link.

IT is there for lazy guys.
I’m an IT, really lazy, unfortunately I’m also a stupid dummy in HA.

If HA can’t help me, please forward me to a valuable solution, even a proprietary one.

Kind regards,

Happy Easter. :bell:

So many requirements hahaha hahaha.

Any way to install HassOS like previously explain how do you want to do it? if you want full control then you should go with Debian with the supervised method. I recommend that you check out my scripts at https://github.com/tirtadji-com/rpi_debian_ha_supervised

If you want the easiest installation then just go to home-assistant.io you should just follow its guide.

HACS on the other hand easily install but for each integration/frontend then you will have to read their setting. There is no other way.

Zigbee, BT, Z-Waze, Wifi Devices MQTT NodeRed, and the rest you will have to read and read each of the documentations. Each installation will be unique and should you hit a problem then come back to the community for help or join the Discord Channel.


I tried with the latest version of Debian, as you suggested, but it was not possible to boot from my SSD.
Reason why I finally tried the Raspbian version and IOTStat, but the docker version of HA is not the same.

A nightmare.

I have plenty of ideas on how to manage all my devices, and I always fall on the setup and configuration of the tool I need to play with my devices.

I’ll try again your solution, on a SD card, maybe I will succeed in :slight_smile:

What is really missing in all the documentation, … are simple examples !

You have such a device ? Here is the way to add it (and also the add-ons required for it), and how to configure it.

For sure, having such documentation, howto, or cookbook would drastically reduce the ton of topics in this forum.


You are unable to read your SSD because your enclosure is not detectable on Linux (maybe) Solution for undetectable SSD enclosure is to read https://jamesachambers.com/raspberry-pi-4-usb-boot-config-guide-for-ssd-flash-drives/ with a clear explanation on how to make it detectable.

I’m running RPI4 with SSD and yes its running Debian 10 without any problem at all. My RPI4 is already running the latest eeprom which allow RPI to boot from SSD, so if you have not update your RPI4 to the latest eeprom you wont be able to boot from SSD. In order to update you just need to run and do eeprom update and thats all (google it).

I already updated my boot firmware, and yes, I can use my SSD with HassOS installed on it.
Just that in that case, I have not found the way to configure all my devices and addons.

I’m installing Debian on another Rapsberry (to follow your advises) :slight_smile:

The Raspberry I try does not accept to boot from USB !

No firmware found while I installed it.
Murphy is not on holiday :’(

Now it boots on the SSD, but …

ALERT! LABEL=RASPIBOOTdoes not exist. Dropping to a shell


And back to square root, same as when I tried earlier.
No way to login or type in anything.


Finally, I fell back on a Raspbian image, and … it works on my Raspberry pi 4 - 4GB

Just on this. When you load new firmware on an RPi it just patches the OS I’d does not ‘flash’ the RPi like you might be expecting so if you didn’t install new firmware in that image you are booting from then it doesn’t have it.

1 Like

I have been using the Raspbian image on a Raspberry PI4 with my original install of the All-In-One-Installation, which I know has been depreciated. Almost all my updates to my system with the changes to my system have been with edits to the .yaml files. My previous requests about my issues have been a reference to upgrades to hass.io and be careful make sure you spell it right, you might be reprimanded. The only recent issue I have is a recent upgrade issue to sudo apt-dist-upgrade which has removed all my mosquito switches and lights from my HA. I know the group seems to be trying to move us on to the next best thing but some of us like to know how the .yaml thing works. Just a opinion from someone trying to understand technology.

You must be the unluckiest HA installer I have discovered. Nothing that works for thousands of other people works for you.


OK so there is no such thing as hass.io for a year now. It is HAOS or you could run a supervised system on Debian. All of the install methods support YAML - not sure why you think any different. YAML is being removed for some integrations but even running an old all-in-one system (I started with that over 3 years ago too) - if you run the latest Home Assistant versions then there is no configuration difference.

Sorry I bothered anyone. My system works for me SO FAR!!

Wow that is a tall order. I suggest you try the official documentation, then the community guides section of the forum.

But perhaps you also need to realise HA is not plug and play. All those things are between easy to a little technical, no more.

1 Like

Did you use Debian 10 that design for RPI? Where do you download your IMG? Cause it works on my end. So not working for you is one strange thing

Good Luck these people don’t care about us dummies!!

if people dont care you will not see any response on the question ask in this forum.

Nevermind you are correct… there are some bugs on Debian making it unusable when you are running update. I’m working on fixed for this issues.

3 years or running Debian with HA and I have no clue what you are referring to.


Debian 10 for RPI will not boot back on SSD upon update. There are bugs on it https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=977694#67

Community discussion regarding this bugs Installing Home Assistant Supervised on a Raspberry Pi with Debian 10