Why is Ubuntu Server Install Reporting as Unsupported?

Client: Docker Engine - Community
 Version:           19.03.13
 API version:       1.40
 Go version:        go1.13.15
 Git commit:        4484c46d9d
 Built:             Wed Sep 16 17:02:36 2020
 OS/Arch:           linux/amd64
 Experimental:      false
Got permission denied while trying to connect to the Docker daemon socket at unix:///var/run/docker.sock: Get http://%2Fvar%2Frun%2Fdocker.sock/v1.40/version: dial unix /var/run/docker.sock: connect: permission denied

Screenshot from 2020-12-20 12-45-29

This linked to here https://www.home-assistant.io/more-info/unsupported/docker_configuration

Screenshot from 2020-12-20 12-46-00

1 Like

Following the information in the link below, with regards to editing /etc/docker/daemon.json fixed it and allowed me to then update to the latest version of HA:



I did have the same problem today when trying to upgrade, running ubuntu. Rebooted the host system (ubuntu), and after reboot it was possible to upgrade without problems.

@Atle_Ravndal, maybe that’s what fixed mine, because after adding the lines to the daemon.json file I performed a reboot.

1 Like

I’m a little concerned that Ubuntu is no longer supported (or maybe it never was?) as that could lead to breakages going forward. I’m reluctant to change to supported Debian server though in case I lose my configurations.

If it help alleviate your concerns any, I was running HA supervised on Ubuntu and last weekend I switched to HA OS without issue.
I created a VM running HA-OS and got it to the point of adding the samba addon, took a HA snapshot of the ubuntu based system, turned it off, restored the snapshot on the HA-OS VM, moved my USB sticks over, set it’s static IP to the same as the old machine, and rebooted.

Everything came back up perfectly without a single hiccup (Almost).
The only thing I lost was the DB stopped working, but I just deleted it and it got re-created. I use influxDB as the long-term historian, so it wasnt an issue for me.

I might have been lucky, but I had no issues at all moving my entire config around using a snapshot.

As nice as running it on my own OS was, it was honestly more of a headache than it’s worth. With more and more changes being needed to keep it “supported” and the recent issue with the new docker version not being compatible, it’s more piece of mind now (and less maintenance) to just use the fully supported HA OS. Not to mention that running it as a VM means I still can use the server for plenty of other uses and I’m not locked into an entire machine only running HA.

@Silicon_Avatar, I was considering VM when looked earlier at supported systems and I might give it a try. I have this nagging feelings that one day something is going to stop working on my Ubuntu server HA install and that would give me headaches!

@Silicon_Avatar, did you follow some instructions on installing HA-OS on VM?

So I’m running it as a VM in ESXi, which is using the VMDK file that HA provides.

I followed the instructions that HA provides, as well as some other details outlined in this guide.
Additionally this story of someone’s successful attempt at it.

The VMDK works right out the box for some people (somehow) but I needed to follow the instructions in that second guide (specifically using vmkfstools to clone the disk) to get it to work for me.

1 Like

As I stated in my first post, Ubuntu was never supported. Debian is the only supported method for running Supervised. And also there you need to have everything configured like HA devs want it otherwise it’s unsupported. That’s probably not worth the headache.

In my experience, when the system is unhealthy, supervisor doesn’t have root. A reboot of the sustem fixes it, for a while :-/

Yes, that’s one of the first links I posted.

@bedfellow I recently added a community guide for how I installed the HassOS VM in Ubuntu Server (LTS 20.04).

One person seems to have some issues getting it running, but it worked well for me. If you feel like it, please give it a try (no harm done if it doesn’t work, I have the VM running, but still have my current setup running on the same machine, waiting to find time to migrate config). And please give feedback, whether it works for you or not.

1 Like

That solution instructs re-running the installation script. The one I used adds a configuration to Docker. Maybe they both achieve the same end goal though?

Could be, didn’t check the installer script thb. I don’t use Supervised in production.

I’m intregued, you have said before (but maybe I’ve misremembered) that you run on a NUC and that you don’t run HassOS. But I thought you had also said that the management of different containers was just a PITA, so from all of that I assumed you ran supervised via a VM or Promox or similar.
But obviously I’m wrong

I don’t use HassOS in any of my environments.
I have a VM running Ubuntu and Supervised, which I originally installed because I thought about migrating to a supervised install. But I have now come to the conclusion that I’m not happy with this (yet another layer, less control, need to wait/depend on add-on developers to update their add-on when a new version of the underlying software is available, need to follow the devs rules too much for a supported, healthy install -> docker update killed all of them Supervised installs xD) and will keep my Home Assistant Container installation for production (maybe even switch back to Home Assistant Core).
I can’t remember having said that managing my own containers is too much of a hassle, because I actually find it extremly easy. But my memory in regards to HA is ‘limited’

Forgive me, I extrapolated from you saying that ‘updating python every year for some installs was a PITA’ and I assumed …
Still it gives you something to do on those loooooong winter evenings, when not managing your 27 backups

1 Like

Thanks. Saved me from having to migrate from my hassio (supervised) on Ubuntu on ESXi set up to hassOS. For now.
To be fair I have already spun up a HASSOS VM on the same hypervisor but not looking forward to move over my configs (even with backup/restore)