With 2022.7.0 my NEST integration fails

This morning after I updated the HA to 2022.7 my NEST integration failed.
I guessed it was the new update doing this.
So at first I tried to correct the credentials, as I thought that was the problem, that didn’t solve it.
So I tried recreating the ‘Device Access’ Project, that didn’t solve it.
Now I’ve started all over, making very sure that the ID’s for the cloud project, the device access project ID, the oauth ID etc. are absolutely correct.

But I still get the " Can’t link to [Project Name]: Please contact [Project Name] if the issue persists" message as mentioned in the docs.

I’ll leave it for now, going to Berlin in 20 mins, and won’t be back until sunday, where I’ll try and configure it in HA again.

Having the same issue with NEST after upgrading to 2022.7.

In case you missed it there is currently an active alert for the NEST integration

Reconfiguring the integration did not work for me so I removed it, deleted the OAuth credentials in my Google project, created new credentials and then updated my Nest Project in the Device Access Console with that new OAuth.

Now when trying to add the NEST integration: I enter my Google Cloud Project ID, then the Device Access Project ID, click on Submit but Home Assistant does not make the connection to complete setup.

Are you guys aware of the breaking changes in relation to Nest?

There is a link to some documentation. Apologies if you have already looked into this…

Issue is resolved now after adding new Application Credentials..
Then The NEST Integration is able to connect to NEST again and complete the setup

What other folks said is the most common reason for this. When the nest integration loaded did it not have a red reconfigure alert? that walks through the steps of resolving this.

What do you pick for integration for application credentials? Google Calendar or something else. I could still not get it to work with Google Calendar. When I try to link to Google account, I get Can’t link to (Project ID)… Thanks

Are you running 2022.7? You need to pick Nest. Or just delete anything that exists and let setup walk you through creating it correctly.

I am running a Docker container on an NAS. This is an alternative install. I cannot find if 2022.7 is supported for this install. When I try to upgrade, it says no upgrades. Running 2022.6.7. I am very new to HA as well, but got all my integrations up and running after a lot of trial and error. Thanks!

Application credentials for nest was added in 2022.7.

I’m not sure what you’re trying to do exactly or where you’re stuck, but i recommend running the latest version of home assistant and following the nest integration instructions on the home assistant site. They have extensive troubleshooting information for all common misconfigurations.

1 Like

I had to create upgrade to 2022.7 via docker as the upgrade process in HA was not working for a core image alternative. I will work on Nest now… Thanks

I have been round and round with this and just keep getting Can’t link to (projectID)
Please contact (projectID) if the issue persists from nestservices.google.com/partnerconnections.

I have been through this 10 times now and it just isn’t working for some reason. I have created new projects and credentials and device projects but i’m just not getting it.

Nest works BUT 2022.7 broke connection to Synology NAS… I will check to see if anyone having issues with NAS integration on 2002.7

See Nest - Home Assistant with the section under Can’t link.
Most likely you need to read the bit about Application Credentials. This morning I updated with an additional screenshot to go along with the existing text about since that is something new that many people see and skip over, or don’t click through, etc. so hopefully that helps.

Deleting the existing credentials and starting over did the trick. Thanks for your support!

Well, as some posted, the integration changed, and I did notice that, so I’ve started all over from the top.
Created new Google project, added API’s, created consent screen, created OAuth, created new device access with the OAuth, but I still get a message that it can’t contact the Device Access Project.
This is very odd.

Check out the troubleshooting section in the docs and if your error isn’t there let me know

1 Like

Ok, so I found out that I had some old stored credentials, I got rid of that.
Then I went through the setup again, and now I just see this popup after entering the Oauth:
Client ID and secret:
billede
I don’t see anything in the logfiles.
I’m configuring it through the Nabu Casa URL, I fear that it gets confused because I also have a local name configured, with a let’s encrypt public certificate on it.

Oh darned, I found some old stuff in the configuration.yaml also, a link to a nest.yaml holding old credentials.
So after removing that as well, it linked up!

The steps are listed here:

Just had to search some more for the old (bad) credentials.

I’m having the exact same problems trying to convert my Nest link from desktop to web auth: specifically, both the blank dialog box and the “Can’t link to Home Assistant - Please contact Home Assistant if the issue persists” error.

I’ve already deleted my credentials from my config files and even deleted and recreated the Oauth creds and device access project. Here’s something really weird about that.

The page where I get the “Can’t link to Home Assistant” error has a URL like this: https://nestservices.google.com/partnerconnections/37df046c-aaaa-bbbb-cccc-9a49e0e8b4cd/auth?response_type=code&client_id=1234567...

I’m 90% sure that that client id is the old Oauth client id that I already deleted and was never associated with the new device access console project. This suggests to me that Home Assistant still has that information cached somewhere, but it’s not in the config files and I’m not sure where else it would be.

Ah, success at last! I was right, there is an application_credentials file in a hidden .storage directory. Deleting that file, restarting HASS, and then restarting the Nest integration finally worked!

I have no idea what that .storage directory is, if it’s supposed to be accessible via the UI, or if it exists by design :man_shrugging:

It seems there’s at least two bugs here:

  1. You should never get a blank dialog box with no error message, even if you’ve misconfigured something it should at least provide an error message
  2. When you remove an integration, it should delete the cached application credentials. And there needs to be broader awareness that credentials like that can be cached.