Wlan0: link is not ready

Ureka!!! for me any way. yesterday i changed the dns servers in my router because i couldnt update docker containers on my unraid server.
so i thought maybe that also works for homeassistant. i tried it yesterdat with the already running install but no go. so today i flashed the latest .img again and i saw :8123 port straight from the first scan. and when i tried to go to it in browser the update messages appeared. so now the thing is running again.

i used the cloudflare dns before but now i have opendns en google put in my router.
maybe this helps for any one else with this problem.

Has anyone been able to truly solve this issue. I just purchased a pi3+ specifically to get into HA and im getting this exact issue. When it first boots on the screen it states no network found. Then goes through the loading of line codes.

Ive tried a config file… I have wifi and hardwired connections i see them both in my router that they are connected. So i know thats working. Its just getting it passed this first part.

Also having this issue. If someone has fixed this, step by step would be great :slight_smile:

Yet another here, having the same issue on a brand new Pi 3B+. Just sits there with this wlan0: link not ready message.

New flash of the 32bit image. No custom network config file. Plugged in via ethernet with a DHCP router on the network.

Tried multiple power supplies, multiple SD Cards, multiple ethernet cables, custom network config files both in WLAN and Ethernet static mode, tried the 64bit image too. Nothing works. Never even hits the DHCP when in ethernet mode.

This sounds like an inherent issue with the B+. Any devs out there care to weigh in?

About to throw this thing in the bin after about 10 hours of troubleshooting! :persevere:

Ok after a number of hours of further mucking around… I’ve got it to start up successfuly.

Here are the steps I took:

  • Rebooted router (DHCP Server)
  • Change to a different ethernet port on the router, and changed patch cable.
  • I’ve reflashed SD Card again with the 32bit image.
  • Did not use any custom network settings. Just using ethernet + DHCP (default mode).
  • Plugged in HDMI and Booted Pi 3 B+

The console scrolled through for 397 seconds before it was contactable on http://ipaddress:8123, the final lines shown in the console were:

[358.571] IPv6: ADDRCONF (NETDEV U_UP): wlan0: link is not ready
[358.578] brcmfmac: power management disabled
[397.048] udevd[7]: starting version 3.2.5
[397.098] udevd[8]: starting endev-3.2.5
[674.588] IPv6: ADDRCONF (NETDEV U_UP): wlan0: link is not ready
[674.598] brcmfmac: power management disabled
[990.590] IPv6: ADDRCONF (NETDEV U_UP): wlan0: link is not ready
[990.592] brcmfmac: power management disabled

It looks like the wlan0: link is not ready lines just repeat over and over when you’re not using wlan. It’s not an error, and the system is operating normally.

I was expecting some kind of final message saying “Hass.io UP/Online”. I was maybe giving up on it too soon.

Anyways, I decided to write this out in detail to help others who might be struggling, and because I wish I had this info myself before I messed around with it for 12 hours! Hope this helps!


I had all these issues also, going around in circles.
Success in the end.

issue was with using not pad to copy and paste the code to the my-network file for the usb stick t get the IV4 wifi enabled.

downloaded and used notepad++ for windows
copied and pasted code as instructed in the hassio instructions
formatted the code to ANCI and line indented for UNIX
all in the menu in note pad ++

remember to remove the TXT extension on the file when saving in the network folder
USB volume name CONFIG

Install the usb stick before powering up the PI

worked first time after 2 days of chasing my tail.


That might be something I’m going to try.

I finally got Hassio working by sticking with the ethernet cable and not doing any custom network config at all. An ethernet cable is more stable anyway.

Of course there needs to be some configuration in the router as well.

  • Port 8123 has to be opened on TCP and point to the internal IP that was given to the RPi.
  • I myself added a custom IP reservation for the RPi, because I didn’t want the IP to change (the port forwarding then won’t work). Reserving IP addresses is easier within a router than using the network file on hassio.
  • For me the local.hassio:8123 link did not work. I was using http://rpi-ipaddress:8123. That worked like a charm.

If you don’t use the network file to connect to wifi and just stick with the ethernet cable, not being able to connect to hassio has to be caused by router settings. You should at least check the assigned internal IP address and port as mentioned above.

By the way. I recommend you all to setup a backup system immediately after installing. I recently lost a lot of work by getting a corrupted installation. Making snapshots stores the backup files on the same SD card as hassio is installed on. I wasn’t able to retrieve them. So, store them online (cloud) or on another harddrive! Reference: Connection refused after restoring backup, no errors, samba working

IPv6: ADDCONF (NETDEV_UP): wlan0: link is not ready
brcmfmac: power management disabled

These are not errors. Both messages are present on a working install.

They continue to be posted by people who aren’t familiar with the logs as a reference to a problem. Then similar minded people search for it and find these threads and this becomes kind of a loop.

IPV6 for wlan0 (wireless connection) is never going to be ready.
Power management for wifi is indeed disabled. Again, you would see these messages on a normal working install.

Your installs may be having a problem pulling down the Home Assistant image from docker hub because of some networking issue. Sometimes DNS is the problem. Sometimes the time (ntp) servers are not being reached or are otherwise blocked and the time is wrong. If the time of the device doesn’t match the time of the server where the images are downloaded from, the request will be rejected.

There is a console.

You hit enter at the os log screen, then enter root to get to the Hassio cli. The Hassio cli has limited custom commands for checking Home Assistant itself. If Home Assistant isn’t running these aren’t going to be much help. So, from the Hassio cli you enter login to reach the host.

From the host ( # ) you can use commands like docker ps to see whether you have both running containers: supervisor and homeassistant. You might be missing the homeassistant container if a connection could not be made.

You can also enter nmcli to check that your ethernet has an ip address. If you see an ip address, you should be good. Enter http://that_ip_address_you_see:8123 in a browser from a device on the same network.

I’m not a dev or even very smart but I’ve set up Hassio many many many times.

My advice:


Done all of the above suggested by moderator - can see that dockers are running, using cli. Can see preparing hass.io page in browser. However ‘wlan0 link is not ready brcmfmac power management disabled’ message keeps on reappearing in host. Have been waiting more than 30 minutes for download to complete. What else can I do to get home assistant running in browser properly?

trying to get hass.io running on RPI3 with 32 bit image, using ethernet. unfortunately, still no luck after 8 hours - same power management disabled message appears. Is this really not indicator for an error? Nothing else happens. ‘preparing hass.io screen’ still in browser. Any help would be appreciated with this.

Finally got it working properly - disabled IPV6 on router and that immediately fixed the problem. Login screen is displayed in browser now.
After getting hass.io running on RPI, configured Z-wave USB key by using /dev/ttys0 as serial port in config file. Now working on getting key to discover z-wave devices …

Can someone please take this feedback, why WIFI configuration is designed to be major pain in the bu**?
Why It has to got though the USB Stick where you need to import something and on the next restart wifi is gone again and you wonder if the import is stored somewhere after reboot or is it wiped … or you are expected to connect with the table every restart to do the import again etc.

Suggestion: Can we design future versions in the way that there is certain config file already present in the image and all you have to do is filling in the blanks for the Wifi network name and password.

P.S. Sorry for bit of frustration, but trying to follow all these guides is very misleading and after spending hours you will get after restart still

wlan0: link is not ready

Thx a lot.
This solved the issue for me when booting over the USB WIFI confic File, with the suggested parameters in the manual.

1 Like

Soved it for me too booting with the USB with WIFI config again!!
…so the wifi config was suddenly lost?

After fighting for almost one week against wifi not working/enabled on my fresh new HA installation on raspberry pi 3+ 64 bit, yesterday I found a workaround that worked for me.

Let me share these few instructions with all Community people that have the same issue from time ago and have to use HA plugged to the ethernet cable instead of using the wifi.

Requirements (I think the workaround may work with any Hassio version and Raspberry Pi type, but let’s see. Below mine):

  1. latest Hassio version (I have HA v0.104.3)
  2. lan cable
  3. SSH & Web Terminal Add-on from Frenk ( :+1:) already installed on Hassio
  4. USB key

a) login in to HA as usual
a1) follow these instructions on how Configure Network for HA
a2) insert your USB key in your Raspberry PI
a3) shutdown or reboot your HA
a4) login again in HA
b) go to Hassio and add SSH & Web Terminal add-on (if not already done). Configure it with “login” and “password”. Save and start the service
c) open up the Terminal window on the HA navigator. If you get an error at the lauch, please reboot HA. Then, try to re-open the Terminal
d) if success, type following commands at the console level. (No root or particular authorization are required):

  • ip a (it gives back the state of your network interfaces). You should see: wlan0:<NO CARRIER, BROADCAST etc…

  • nmcli device wifi list (you should see a list with all wifi networks near/close to you)

  • nmcli device status (it gives you the state of your devices). You should see:
    eth0 ethernet connected Wired connection 1 [note, this line couloured in green]
    wlan0 wifi disconnected – [note, this line couloured in red]

  • nmcli radio wifi on (this should turn your wifi on)

  • nmcli radio all (it reports the status of all your network services). You should see:
    enabled enabled enabled enabled [all these entries are coloured in green]

  • nmcli connection show (reports the status of network connections). You should see:

Wired connection 1 … ethernet eth0
<there’s a name here> … wifi –

  • nmcli device show (provides a long detailed list of all network devices it discovers). You should see:

GENERAL. TYPE: ethernet
[many other raws follow, but you’ll also see the following line]:

[and no more other raws for wlan0 interface, meaning that it is not working yet]

  • nmcli connection up ifname wlan0 ap [pls type your SSID name] --ask (this is the definitive command. It rises the wlan0 iterface and queries to yor modem/router - hopefully password protected :wink: to let your device to authenticate your HA against it
    You should see the following response message from the router:
    Password or encryption keys are required to access the wireless network ‘’
    Password (802-11-wireless-security.psk): - type here your wifi password -
    Then you’ll ge the following message:
    Connection successfully activated (D-bus active path: /org/freedesktop/NetworkManager/Active Connection/6)

ALL DONE! If you can see this message, it means your wlan is now fully working and you should finally see in you router/modem a new ip address of your HA in wifi

  • nmcli device show (now you should see the wlan0 and all full properties related, even the IPV4.ADDRESS field finally showing the assigned IP address

  • nmcli device status (finally the wlan0 STATE is now CONNECTED

  • ip a (you can se all your interfaces, even wlan0 with all data. Take note of the new assigned IP Address and double check it against your modem/router. If you can see it, you’ve have addressed you wlan issue on HA running on Raspberry PI)

For any reference about nmcli commands: https://developer.gnome.org/NetworkManager/stable/nmcli.html

PS: this workaround works even you shutdown/restart Hassio. No extra work is required

I hope this can help




I just got the same issue, after a clean installation. I have checked my router Fix IP List and my Rpi3B+ was not there, i just added it (and issue is solved.
don’t know how it was deleted)

Same problem here even with ethernet connection. It seems HA does not want to address this problem.
I am very turned off of this product after this kind of introduction.
First impressions are very important.

1 Like

Danke! :+1:

Damit ist das Problem gelöst!

Same problem here. A simple reboot to my router was enough to solve the problem.

This has been super helpful, I’m getting enabled after the “radio all” command but when I run the command to connect to the wifi I get either a bad pattern (could be because my SSD has a space in it?) or when I run nmcli device connect “myWifi 2G” password “correctpassword” i get Device ‘myWifi 2g’ not found. But the SSID does show when using the "nmcli device wifi list’ command.

What would keep my from connecting? I was connected before but ran a fresh install of the hassOS. Thanks for your help

UPDATE: Nvm, i’m not sure how but it’s working now. What I think fixed it was adding commands in the NetworkManger.conf file