Wrong date (again)

Hi, I have the exact same issue of [Hassio wrong date and time], but the solution doesn’t apply to me. I tried and searched but none of the solution works for me.

My home assistant is showing the wrong date and time. when i login to the cli and type date i get the below output which is incorrect

~ $ date
Wed Aug 11 18:43:07 CEST 2021

I’ve tried changing the date and time but im getting the below error

date -s 202110011526
date: can’t set date: Operation not permitted
Fri Oct 1 15:26:00 CEST 2021

The installation is Home Assistant OS on raspberry pi 4.
I have set time zone and elevation correctly, my raspberry is connected to internet.
I have set 8.8.8.8 as DNS.
Ping to time1.google.com responds correctly.
I tried to set custom NTP in configuration but nothing changed (I have no file /etc/systemd/timesyncd.conf to see which is the current NTP)
I tried with both ethernet cable and wifi

By now I can’t update supervisor due to date mismatch:
ha supervisor update
Processing… Done.

Error: Update of Supervisor failed: Can't install ... certificate has expired or is not yet valid: current time 2021-08-11T16:40:21Z is before 2021-08-24T00:00:00Z")

Thank you for any advice to solve my issue

I have the same issue. the hassOS has been updated to the last version and the problem is still there. anyone can help.
Rasberry PI 4, Home Assistant OS 6.5 and core-2021.10.4