WTH do we have Energy dashboard and no Water dashboard?

This is my config:

###### MQTT ######
#  broker: http://homeassistant.local

###### Watercount ######
    - name: Wasserzählerstand
      state_topic: Wasser/main/value
      unit_of_measurement: "m³"
      state_class: total_increasing
      device_class: water

    - name: "Wasserdurchsatz"
      state_topic: Wasser/main/rate
      unit_of_measurement: "l/m"

    - name: "Wasser-Wifi"
      state_topic: Wasser/wifiRSSI
      unit_of_measurement: ""

Thank you this helped. I had to add device_class.

please be aware that in Studio Code Server the Value >> device_class: water << will raise an error for now.


I love that water has been added to the Energy Dashboard, but configuration does not make a lot of sense. 1 cubic foot is 7.48052 gallons. My water meter (and I suspect that of most others in the USA) pulses once per gallon.

It might be possible to create a calculated value that multiplies gallons by 0.1337 to support this unit of measurement, but that does not seem like it should be necessary. The dashboard should support gallons for water.


I added a template sensor to my configuration.yaml file this morning to show ft³ as follows:

  - sensor:
      - name: "Water Total ft³"
        state: "{{ states('sensor.water_total_gallons')|float * 0.1336805462721843 }}"
        unit_of_measurement: "ft³"
        state_class: total_increasing
        device_class: water

Interestingly, it showed up right away. But not only did that show up, but my sensor.water_total_gallons value suddenly showed up as well, which is of course the value I was looking for. I’ve not looked, but this suggests there may be a bug in the code that determines if any valid sensors are available.

I am up and running. I hope this helps others as well. Will also report an issue.


I really wish HA supported Culligan Connect for water usage tracking.

I have a system available for probing.
more info in this thread

In the 2022.10 I had a water sensor(actualy manually reading) mapped as gas(m3) and it worked well.

Now in the 2022.11 I passed it to water, but the dashboard seems not using the static cost setup.
It happens the same to you?

Have trouble setting up the water sensor.
Can you please post it here?

You can check this and use what you need for your sensor (is from toonWater)

toonWater setup

Appreciate it.
Seems to be precisely what I’m doing (except in gallons), but don’t see the entity in the water dashboard drop down.

    source: sensor.water_softener_water_current_flow
    name: Water Usage Hourly Utility Config
    cycle: hourly

    - sensor:
        - name: "Water Usage Hourly"
          unique_id: water_usage_hourly
          unit_of_measurement: "gal"
          device_class: water
          state_class: total_increasing
          state: >-

This is what I’ve tried without results

  • change unit_of_measurement to “m³”
  • I notice if I set device_class: water, no matter what unit of measurement I set, the entity unit of measurement defaults to Liters
  • change device_class to energy. This sets the unit of measurement correctly.

P.S. I started the water metering when I saw that now dashboard accepts water tracking - so yes, I have the latest version of HASS. :thinking:

This is similar to my post…

But here is a small fixes which should be implemented…

Hi @nelsonfaria did you get this resolved. Ive entered a static price but the dashboard shows costs as 0.00, it does not seem to use the static price entered to calculate water costs.

just tried that with a sensor for water used today in liters and it can’t find it, the merge request had liters as well as a unit of measurement but the interface only shows m3 and gl…gl

I’m using the water metering integration (HomeWizard Water Meter) in the Energy Dashboard. While using the “compare” toggle I get wrong units/amounts for the measured water consumption in the previous week/day.

Water total: m3 / € / L / €

  1. The first unit now m3, should be L.

  1. The comparison between previous / current day is not showing different water consumption.


  1. Despite that I use the system based units 1.123.456,78 I cannot save the price in this correct format.

System preference:

Price per m3 that can be saved:

Price per m3 according to system preferences, can’t be saved.

/ m4v3r1ck

An issue has already been filed at Github:

Nope. Still gets 0.0 with static price.
Do you have any other insight?

Somehow it started to work after some time. Maybe it need a number of entries to start.

Mince is now working as well.


This is a very welcome feature, love it!

I have a water meter that sometimes gives a totally wrong value (optical reading).
I can correct this manually using Developer Tools / Statistics.
The graphs gets corrected, but the Cost beneath the graphs does not reflect this correction, can this be fixed?


Nice feature!
I have two water meter : one general water meter and a hot water meter.
the hot water meter is a sub meter of the first. Is there a way to make an option
so as not to count twice the hot water consumption in the total water consumption?

Any News on this, some totally wrong readings ruins the cost of day/week/month/year?