WTH is there no option for using the server timezone

Yes please

This has been asked for for years. Might have to dig into this myself. Now that we have solar and batteries on a vacation home, the screens are just wrong. I am surprised this is not one of the most common features required for home automation: Make the timezone home centric! At least give me the option in the frontend. Thank you!


this would be very useful!

Yes Please!
It could either be in server configuration (i.e. ignore browser timezone completely!) or in user profile

As powerful as Home Assistant, this has to be the stupidest ‘bug’ I’ve seen.

Look at Energy Dashboard vs the Utility Meter. Both built-in functions showing different values because Home Assistant is using different start times. One shows 19.1, the other is showing 24.78. Both should be the same; ‘day’s energy use’.

This isn’t a feature request. It’s a bug.


You are correct. Any logic that resets sums on date boundaries becomes incorrect when performed in any other timezone than the home server’s.

+1 from me…actually people have been asking for this for a very long time already.

1 Like

I can’t say this any better then fxstein. (Post Home timezone display in browser - #6 by tom_l) If the developers don’t agree with this statement then please add an option for this.

1 Like

This is a bug, not a FR. See e.g. https://github.com/home-assistant/frontend/issues/12302.

This continues to be a major issue. All screen with daily summarizations and especially the energy dashboard are wrong when away from the home’s TZ.

I workaround that by using a cheapest tablet configured to the desired time zone. A remotely accessible VM would work too.

I have one of my laptops I travel with set to my home time zone specificity because of this issue. it is however not an acceptable solution.


Any solution would be good here. An update to pick the Timezone from the user profile instead of the system would seem on the surface the simplist.

WTH is now over. Vote here instead:

This has been released in 2023.7

1 Like

Noticed, but how do I use it?

Click on your user name in the bottom of the left menu. set time zone to follow system


Excellent! Thanks

Changed the user timezone to server timezone , but the data still showing in my local timezone. Same as before.

What in particular is not showing as server time?