Wyse Thin client

I have been using a RPIv2 for a while and after eating two SD cards (presumably from constant DB access) I decided it’s time to upgrade.

I know that there have been various people who talk about upgrading from a RPI to a NUC with great results. This is a bit of an expensive upgrade though and still a lot more power than I needed, so I decided to look into something else more affordable.

I found some cheap refurb Wyse thin clients on Amazon.

This is the one I jumped on: https://www.amazon.com/gp/product/B078NL4CL3/ref=ppx_yo_dt_b_asin_title_o01_s00?ie=UTF8&psc=1 but there are certainly others too.

As much as I’ve liked Hass.io, since the machine has a little more power than the RPI I figured I would rather go the general linux distro + run Hass.io in docker myself to keep my options open.

There’s a few pain points I hit that I wanted to talk about though.

  1. The machine had a BIOS password set by default. I think it was like this from the factory because the password that I found googling; “Fireport” worked to let me in.
    I had to turn on USB boot in BIOS setup.

  2. I installed Ubuntu server 18.04 on the box, and chose to install docker-ce at that time.

  3. Because docker-ce was installed there, it is installed using a snap rather than deb. Generally this is OK, but it led to some hassio install script expectation mixups. I documented my findings in the open bug here: https://github.com/home-assistant/hassio-installer/issues/9
    With some slight modifications to the install script and jobs I did manage to get it installed though.

  4. I backed up my RPI and imported everything from my RPI into the hassio instance.

  5. Almost everything went well except that importing the SSH addon really messed stuff up with HASS not wanting to start. I ended up nuking the docker containers and redoing them all and just making sure not to import SSH this time. I’m instead using SSH in Ubuntu directly.

  6. Somehow I lost my tokens for Google Assistant in this process (I don’t use HA cloud). I redid them and GH started working again.

In general it’s been an AWESOME upgrade. I can’t believe how much faster the performance is. Hopefully this is helpful to someone else too.

2 Likes

You said you were going to install HASS but filed a bug with Hass.io?
That is confusing. Which did you install??

Sorry for the confusion, I realize I shouldn’t use those two interchangeably. I installed hassio via the instructions that are Alternative: install on generic Linux server located here.

1 Like

For point 2, the instructions specify specifically to install docker community edition, not the packaged one.
Could that have been the source of your issues?

curl -fsSL get.docker.com | sh

That docker is more standardized than the OS vendor’s “customized” version.

Absolutely that’s the cause of challenges mentioned in bullet 3. That script has hardcoded expectations to find docker in certain places and folders in others.

In general I would prefer to keep the snap rather than the deb for proper confinement, automatic updates, etc. That’s why I didn’t install docker-ce from that shell script.

So, that may not be a valid issue for Hassio then.

The docker snap gave me lots of problems with user rights and what not.

You’ll still be able to update docker, even when you install the community edition, as long as add the right info to the repository in ubuntu.

The point of my post was not to complain, it was to talk about my experience so others may learn.

It’s docker-ce running in snap environment. It works exactly like docker, it’s just installed in a different $PATH and that can’t access stuff outside it’s sandbox.

Honestly it’s a very small patch to installer script to adjust /usr/bin to /snap/bin when the snap is detected or to add /snap/bin to the $PATH. If maintainer chooses not to adopt that, it’s their own prerogative.

I do think it’s a much easier install experience if your install is literally just:

  1. Install Ubuntu server
  2. Pick docker during snap selection screen
  3. Run HA install script from curl/wget

Yeah I went through my challenges in that issue I linked. I was able to overcome them all.

When you install the deb you’re going to manually manage the lifecycle of updating the docker-ce package (even from apt). I’d rather that happen for me.

I don’t know if either of you do work on hassio installer, but I did file a PR for everything that I encountered. https://github.com/home-assistant/hassio-installer/pull/14
The script should work with docker-ce from deb or from snap after that.

Are you still using/happy with thin client. I am considering moving to one.

Very much so. It’s silent, performant and stable. When it does eventually die, i’ll replace with another thin client.

Thank you for the fast reply. So would this work and just add SSD? https://www.ebay.com/itm/NEW-Dell-Wyse-DX0Q-5020-Thin-Client-1-5GHz-4GB-RAM-16GB-Flash-Keyboard-Mouse/401886864637?epid=17035045794&hash=item5d9252e4fd:g:yCIAAOSwW3Fdf4-q

I want Home Assistant Supervised so I am hoping I can install Ubuntu and something like VMWare Workstation Player and then install the vmdk?

Yes that looks good.

I’m not sure you can add an SSD though or flash is soldered down.

If you’re using hassio then just install x86 hassio directly. Don’t bother with another virtualization layer. That’s what I did.

Thank you. I will have to study that. I am not sure I am using the right term, but I run Home Assistant supervised that makes managing add-on and HACS easy for me. So are you saying I would install Ubuntu and then just install home assistant? Similar to what I did when I first installed on pi?

I personally used the “Intel NUC” x86 image mentioned here: https://www.home-assistant.io/hassio/installation/
IE: https://github.com/home-assistant/operating-system/releases/download/4.12/hassos_intel-nuc-4.12.img.gz

I booted a Ubuntu USB key and then dd’ed it onto the local flash storage. No need to install Ubuntu onto the box itself.

(Sorry I should mention that I did Ubuntu originally, but moved to this approach with hassio Intel NUC image)

Got it install just like I would be installing on a NUC. Are you using any Z Wave and/or Zigbee hubs? I use a Husbzb-1 and had some trouble with it on reboot when I was using VirtualBox on an old Dell Laptop with Windows 10. I recently switch to VMWare Workstation Player and it solved my reboot problem.

I bought a Dell Wyse DX0Q 5020 Thin Client 1.5GHz 4GB RAM 32GB Flash. which I think is like the one you have. It should be here in a few days so I am trying to study on the installation. I think I found the install method you referred to once I boot a Ubuntu USB key. The command I found is
gunzip -c /media/sdc1/hassos_intel-nuc-2.5.img.gz | dd of=/dev/sda bs=4M conv=fsync

Couple of questions,

Once Home Assistance is installed and configured will it auto boot on Power On
Do you have a Zwave and/or Zigbee hub connected? If so, is it working. I have a Husbzb-1

Thanks for your help.

.

Yep, that matches how I would expect to install it. Take note in my first post of the BIOS password (you’ll probably need to change BIOS settings to boot the USB key).

I think auto power on should be configurable in BIOS setup. Everything has come back for me after power outages, so I think that’s the setting I have.

I do have a Zwave USB stick. Working great. Aetotec I think?

1 Like

Thank you again. I look forward to setting this up and getting my old laptop back.