Wyze v2 cam with rtsp beta firmware

I have setup the new beta firmware on one of my Wyze v2 cams and it now works great in Home Assistant. I’m trying to use automation to grab a snapshot every 5 minutes to use as the background image for the picture glance card. The problem is it gives an error and a 0kb size file in the directory. I have a similar automation working on one of my synology cameras and it works fine to create a file frontporch.jpg.

- id: 'Back_Yard_snapshot'

alias: Snapshot Back Yard

  • platform: time_pattern
    minutes: ‘/5’
  • service: camera.snapshot
    entity_id: camera.backyard_camera
    filename: /config/www/images/backyarda.jpg

If I used the service test section in HA then I also get an error as shown below. The error a bytes-like object is required, not ‘None-Type’


Any ideas on what the cause is and if there is a work-around.

Maybe because a a to much here? filename: /config/www/images/backyarda.jpg

Will try but is it limited to only 8 characters for a filename?

Tried filename back.jpg but same error. If I pick a different camera then it saves a snapshot and creates the file.

I am getting the still pic from motioneye and that works good

Setting up motion and motion eye now to see about that. Working on configuring it now, but still would like to be able to use camera.snapshot as it works for 3 of 4 cameras I have tried.

Can you share your motioneye setup. I am using 0.39.3. Motion 4.0 on Ubuntu 18.04 and having trouble getting stream. Works in HA but want to use motioneye for motion sensing and still images. Seems like authentication issue. Enter username pswd when discovering camera and set to basic authentication and port 554 but no stream.

Can you post your camera.yaml setup? Having probs getting the still image URL for a RTSP enabled Wyze cam.

Seems there is no still service available. I was trying to get it working in motioneye to use that but also no luck as of yet. Stream works ok and I just out a static image for now. Also tried the home assistant snapshot service but errors out.

see this post. Works well for me with picture glance card.

I know this is very old thread. Meanwhile you may able to solve this. I faced similar issue but able to solve after changing camera platform for ffmpeg from generic. My camera set up in configuration.yaml file is

platform: ffmpeg
name: front_cam
input : rtsp://userid:password@ip_address/live