Configure Wyze cam RTSP on dashboard?

Here’s what I have in lovelace:

  • id: 0010
    icon: mdi:cctv
    title: Security
    • id: CameraFrontDoor
      type: picture-glance
      title: Front Door

Make sure your configuration file also has the stream component enabled


But I must admit that the new stream component has been very unreliable for me. It fails to load quite often.

Is this for your Wyze Cam?

deleted this post to edit again: got it working, the entity registry didn’t have the camera but the states had it listed (??)

I have it in Lovelace, doesn’t load still image or the stream, probably because what you said previously, it isn’t very reliable? Thanks for helping with the config

So I’m able to configure it this way, but

  1. after changing the resolution and/or fps it will disconnect the camera permanently, making me delete and reconfigure it, does this happen to you?

  2. Also, there is like a 30 second delay, in which the camera wont update for like ten seconds at a time? is this normal?


I don’t have stream turned on in my configuration because as ppl have already stated, its unreliable and puts a strain anytime its being utilized on the screen (can actually here the Nuc get louder if I load one of those pages lol)… So no stream component on - I use Wyze Pan Cams, as well as regular wyze cam 2.0’s via RTSP using the ffmpeg component. This is what I use, nothing else… (besides adding it to lovelace via normal picture glance card)

  - platform: ffmpeg
    input: rtsp://user:[email protected]/live
    name: Cam 1

and I have 4 cameras set up this way, after following the instructions for installing the beta firmware. ** Obviously change IP to what your camera’s IP address is.

NOTE: I can NOT get VLC to show any stream in any variation of this - (on Mac OS X) – however it does work with ffmpeg and Hassio. I have no idea why vlc doesn’t work. I’ve tried literally a hundred diff ways to get it to work. and the logs don’t really point me in a direction that is helpful (for me anyhow).

Thanks @larsentim - This works very well for me as well.

So the same thing happens to me… Once you enter a possibly wrong configuration for ffmpeg then the camera is basically dead to Hassio. Need to remove it, reload, and start over. I don’t recall how much delay there is… And I don’t even have stream enabled… I’ll try that now. Though it spams my log with tens of thousands of errors it seems (I could be exaggerating quiet a bit). Will let you know how it goes.

I’m having some issues and it freezes my RPI3. Going to try some adjustments

I just noticed that if I remove


from my configuration, I’m able to view the cameras again from lovelace

Where are you putting this?

Man, I feel Iike I read so much, all the documentation… and still I wasn’t able to get this to work.

Finally, someone posted their code and here’s what I was missing to get everyting to work:

in my confguration.yaml
camera: !include camera.yaml

in my newly created camera.yaml file
- platform: ffmpeg
input: rtsp://RTSPuser:[email protected]/live
name: camera1

   - platform: ffmpeg
      input: rtsp://RTSPuser:[email protected]/live
      name: camera2

I have Wyze Cams v2


My HA configuration is broken up into smaller files - I have the following in my configuration.yaml file:
camera: !include_dir_list includes/cameras

Then I have a file named “ffmpeg_frontdoor.yaml” inside this folder:

The contents of the file is now:
platform: ffmpeg
name: frontdoor
input: -rtsp_transport tcp -i rtsp://user:[email protected]/live
extra_arguments: ‘-preset faster -vf “scale=1280:720”’

Notes: the input is actually in the secrets file but I’ve copied here so you can see the format.

I stream the cameras to an Amazon FireHD8 and the resolution on that is lower (1280x720) than what the camera provides so I use the extra arguments to lower the resolution of the camera output as well (to lower the bandwidth and I think more stable).

i got the wyze v2 cam today. after updating the fw to rtsp, this works for me:

  - platform: ffmpeg
    name: wyze
    input: rtsp://tung:[email protected]/live

however, theres a 6 to 8 seconds delay from what i see in HA versus what is happening in real time. anyone figured how to combat the delay?

This was my main issue. I think it is just the latency of the cameras, but I have no source, that was just my best guess. It was pretty delayed and would cut out often, so I just ended up removing the custom RTSP firmware and not using wyze in HA.

The new WYZE app update is pretty nice in that it send a thumbnail of the video it records when it detects motion to your phone, so when you see the notification you can see the camera. Thats good enough for me

How are you getting the streams into Lovelace? I must have missed that. I have added my camera entities to entities card, but there is no stream.

Here’s what worked for me. I have a live view in the dashboard, and I can click on it to make it bigger.

In configuration.yaml:


  - platform: ffmpeg
    input: rtsp://username:[email protected]/live
    name: bedroom

In the Lovelace UI, I created a new tab, and added a new Picture Glance card with this config:

camera_image: camera.bedroom
camera_view: live
  - camera.bedroom
title: Bedroom
type: picture-glance

I recently came to know that wyze have rtsp firmware so did the upgrade, wyze app works fine, able to stream on mac using vlc, all fine but on home assistant i am unable to make it work.

  - platform: ffmpeg
    input: rtsp://username:[email protected]/live
    name: reef

When i go to developer tools->states option I can see the entity created, clicking on it shows the media window and a spinning bar, thats it.

Looked at log and it says:
Connection to tcp:// failed: Operation timed out

This is my setting in configuration.yaml

# CAMERAS ----------------------------------------------------------------------
  - platform: generic
    name: Wyze Cam
    stream_source: rtsp://user:password@camera_ip/live
    verify_ssl: false

Great! Thank you for sharing this.

In the Picture Glance card (Lovelace UI) I also added ‘image’ as the Streaming URL.copied from MotionEye.

image: ‘http://XXX.XXX.X.XX:YYYY’

@Daniel-san in your configuration file.