Xiaomi Aqara Motion Sensor not being detected by ZHA

I’m running Hassio on an RPi4 with a CC2531 USB stick, using ZHA. I’ve had no issues so far however I’m struggling to add a Xiaomi Aqara motion sensor- it’s simply not detecting it when trying to add devices. I’ve successfully added a ST motion sensor, and a few Hue dimmers, but for some reason I’m getting nothing when trying to add this new motion sensor.

Anyone got any ideas? I’m a bit mythed.

I had similar issues and this post helped.


Thanks for the suggestion. I ended up giving up and migrating over to Zigbee2MQTT. Since doing so all my Zigbee devices have been detected flawlessly, including an Osram switch that I’d previously had no luck with under ZHA.

I can confirm just trying again and again and again works. If someone has some explanation for this/why zigbee2mqtt works / a status page from maintainer, I would be interested :slight_smile:

Thanks for this! I was able to make it work after trying it over and over again like you suggested. Thanks.

1 Like

Using a HUSBZB-1 (Nortek GoControl) and Pi4b, I spent hours pulling my hair out trying to figure out why it wouldn’t detect the device. I scoured the internet looking for suggestions and why it wasn’t supported, etc. I was about to give up and then I stumbled upon this post.

It was THIS POST that turned me on to the trick of continuing to press the sensor button every second or so after the initial 3 second hold that finally worked for me. THANK YOU!


I’m having the exact same issue, can’t seem to make it work. And im at a lost triying to make zigbee2mqtt to work.

Is there any guide i can check out? i can’t seem to make the add on start.

Tried it almost 10 times trying to add the sensors. Didn’t work. So pissed off

Sometimes a weak battery will prevent an Aqara device from pairing. The pairing process needs a nearly new battery. Once it is paired then it will continue to work even as the battery gets weaker. I have had sensors that would pair only after I inserted a new battery.


Not sure what to tell ya. I was able to repeat the process a few times. Each time I was inches away from the USB stick. Pressing that button every half second to second was the important part. I had the web page for HA open the entire time in ZHA waiting for it to be recognized.

Perhaps there’s been an update that’s causing this to be different now. I’ve ordered another 20 of these suckers from China and they’ll be here eventually…assuming the waters are calm. The note on AliExpress’s order said to expect them the first week of April. Hopefully, they come sooner. Once they come I’ll revisit this post and confirm if it’s working or not.

1 Like

Thanks for the reply!!

I made it work yesterday, but one of the motion sensors keeps becoming unavailable.
I added them next to the pi (pi4 8gb and ssd) I placed one of them 3mts away and the other, the one that keeps disconnecting, 6mts away
Was to exited to make it work and now this happened.

Any tips on that?

You’re well within communication range. Mine is easily 15 meters away through electrical, hvac ducting, and cement wall. Battery? Easy enough test, just swap batteries with the one that’s working and see if the problem follows the battery.

They are all new batteries. Y was thinking that my Raspberry is in the middle of my home theater instalation. Including router, nas, xbox and so on. I read somewhere using a usb extension cable to place the nortek usb away from the Raspberry radios (WiFi and bluetooth) helps. So the next thing I’ll try is placing the pi away from all my other stuff

I’ve considered the same thing. Interested to know if that makes a difference for you.

I’ve just added two xiaomi zigbee plugs. And as I’m writing all the connection problems went away. One close to te pi (3mts) and one in the second floor. Everything is working just fine…
I’m new and I had no zigbee repeaters un my network
We’ll see in the coming days.

Sorry for bumping this old thread, I have been struggling adding these sensors for a couple days with no success and since I haven’t seen this listed anywhere what finally allowed the P1 series sensors to connect was hard cycling. Remove battery → wait 30s → put battery back in and immediately start the paring process. ZHA found them after that.

1 Like

Similar issue. I can get it to pair but then it doesn’t update / disconnects. Am I missing something to keep it active? I haven’t moved it from where I’ve paired it. Even tried in the same room but always drops off after pairing.

I tried many times, pushing for 3 seconds and then repeated short pushes, nothing helped.

The only way it worked for me was to push the button in for 3 seconds and only then click on serach new devices in HA. It found it immediately.

I am using:
Home Assistant 2022.9.4
Supervisor 2022.08.6
Operating System 9.0

1 Like

For me I have the issue that it does recognise the new device yet it cannot gather any info on it. Unknown manufacturer. Anyone had this issue aswell?

I’m having the same. Pairs quickly but then becomes unresponsive almost immediately, becoming unavailable in HA after about half an hour

Don’t suppose you found a way to fix it?

1 Like