Xiaomi BLE only showing signal strength not temperature

Hi All

I am pretty new to HA. Not sure if i am posting this in the right spot.
I have the lastest HA running on a virtual machine.
I setup an ESP32 to run Bluetooth Proxy (Ready-Made Projects — ESPHome)
That seems to work fine… Shows up in HA, not really many options or things to configure.
I bought some
LYWSD03MMC to monitor temperature.

Power one on. A few minutes later it shows up in Home Assistant.
I didn’t have to configure anything… And honestly don’t see where i would configure anything.

Issue is there is only 1 entity
which is nice, but it would be nice if it showed the temperature as well.

I am googling around, and finding lots of not helpful information…
I enabled logging. Don’t see anything in logs…
Honestly, i’m just not even sure what to do.

Any help appreciated.


You need to flash with alternative firmware

and then choose BTHome as advertising format

There are several topic on the forum, first one I found:

Thanks sooo much. I had seen some of those, but didn’t understand if they were still up to date… etc…
I had no idea i could flash firmware from a webpage… Thats cool.
I think i almost have it… But gotta run to kids basketball!

HI, so the good news is its working.

The bad news is, that i configured 5 of them, got them all setup, where they need to be, but only a couple are working.
I believe its due to range.
I clicked the Low Power option on them all… Not sure how much that impacts things.

Now i want to go back and change the settings on the ones not working. Turn off Low Power Mode and turn up TX / RX power.

Issue is… The Firmware flasher just doesn’t seem to want to connect to any of them… And i cannot really figure out why… One of them did connect, but the others just don’t seem to want to… Any tricks/thoughts? I have tried checking and unchecking Get Advertising Mac… Tried enabling Web Experimental Features… But it just sits…

Also i did maximize the couple times in the settings (trying to reduce frequency of updates…) Forget which settins exactly because i cannot get back in to check…

I did find that simply reloading the Telink Flasher webpage every time i wanted to do a device, tended to make it work once. So i just did that every time.

Yes, either reload, or use the disconnect button before trying again.