Xiaomi Gateway Key

I’ve updated to HA 50.2
added the xiaomi gateway to my wifi and added a few devices.
Downloaded the android Mi Home app.

But for the life of me I can’t find the KEY. Can anyone help me find it?

The instructions at Xiaomi Gateway Integration aren’t helpful. The app options look different to what I have.

I have to change the server location to mainland china to get the app to work properly, from there the instructions worked fine


Just to make it clear: The app looks like the instructions if “mainland china” is selected. All other locations doesn’t work and will lead to a somehow empty and featureless user interface.

Just in case someone else lands here, like @syssi said, you need to choose “Mainland China” as your location.
If you chose a different destination:

  1. Click the Profile down the bottom right,
  2. Scroll down and click Settings
  3. Scroll down and click Locale
  4. Select Mainland China

To enable LAN control, follow this guide

1 Like

Also, if you are using an iPhone you will have problems. You need an Android.

I had to download BlueStacks which is an Android Emulator to get my Xiaomi Gateway working.

well, not too sure about the iphone thing because I did it without any problems… latest ios on an iphone 8+

With IOS its hit and miss, if only have ios, just keep regenerating key till it works

I have a gateway bought in HK. If I use the HK server I get no option to retrieve the key. If I use the China server I cannot connect to the gateway (I get network timeout when going through set up). I’ve tried a dozen times, have deleted and reinstalled the app, tried blocking internet access to the gateway (on the router) etc… no joy. Currently the only option for any use out of the gateway seems to be to set it up on the HK server, but then without the key, I cannot link it to HA. Does anyone have any ideas?

Thanks I’ve seen this project. I love the idea of moving away from the Xiaomi Gateway, but the project seems a little beyond me. I see the set up requires a USB dongle (sniffer), is this then used during usual operation? I’m running HASS on Raspberry.

The project is very well documented and yes, the sniffer takes over the function of the Xiaomi Gateway.

You could block the xiaomi gateways ability to get online and use the xiaomi_aqara.add_device and therefore never need to use the app to add devices(provided they are on the supported list that is)

1 Like

I have location set to mainland china but still dont get the “version” option in the menu, anyone have any tips?

@lendert: I have the same problem.
I have changed to China in the app but the app does not look anything like the instructions at: https://www.home-assistant.io/components/xiaomi_aqara/

Simply do not work.
I am a newbe to Hassio.


Hi, @BrendanMoran, could you please describe the process.
I also have a Xiaomi Gateway v2 device and I dont own an Android device, only iPhone / iPad

I have installed BlueStacks and Mi Home App on it. But I dont know how to proceed.

Thanks in advance

@JBelinchon Do you know this tutorial: https://www.domoticz.com/wiki/Xiaomi_Gateway_(Aqara)#Adding_the_Xiaomi_Gateway_to_Domoticz

I finally got it working installing RaspAnd Pie (an Android Distro for arm) on my RP3 and then running Mi Home apk from there. :wink:

1 Like