Xiaomi HUB packet loss

Dear Team,

My Xiaomi HUB was working very good but recently it has packet loss during 1 hour a couple of times per day. See the picture below:

I have changed the wifi router but same behaviour. I am pinging the Xiaomi HUB and when it stops answering to ping, other wifidevices are working fine, so I am sure it is the HUB.

I have tried to modify the wifi setting limiting it to the most basic protocols 54Mbps, but always the same.

Did someone have the same problem? Any ideas?

Thank you in advance!


Which version of the hub do you have? (Type number or photo is fine).

I notice when my HA instance restarts, it takes up to 5 retries for it to find the hub at its IP address which is always the same. I haven’t noticed any intermittent issues but I don’t have checks like you have in place.

I am using the Xiaomi HUB V2, which I think is pretty common. Software version is the last one: 1.4.1_170.0158.

I see a message in the application now which says that the WiFi connection is poor (18%) and packet loss more than 5%. But it doesn´t make sense because there is 1 meter distance or less to the router and other devices are working fine and I already replaced the router twice.

Maybe the internal antenna of the Xiami HUB is broken?

I am having the same problem.
Have the same firmware, in my case Wifi signal strenght ca. 80%, but still Packet loss rate over 5%, sometimes even > 70% !!!
I don’t think it is antenna or weak Wifi connection, all other Wifi equipment work fine.
Additionally e.g. network radio works without cutting, does it tell data trasfer being ok ?
Could it be some interference to other signals of perhaps crowded Wifi channel ?

I have tested different channels with same results (auto and manual).

I have set up another ping monitor for the WiFi router and it is working fine, only the Xiaomi HUB is failing. See graph below:

It is so frustrating as it doesn’t make sense…

I have another Xiaomi HUB in another flat and it works perfectly. Not sure about version, I will check.

Not sure what else to test or next troubleshooting steps…

Here is discussion about the same problem, but no solution.

1 Like

It says changing the network subnet can help. I will try, but doesn’t make sense.

1 Like

Any update with this? Mine has been saying high packet loss with 100% signal and there are not many devices on the WiFi, so it doesn’t really make any sense to me…

Changing the subnet also makes no sense as a solution to me.

Version: 2.77.1

Nope, I am having the same problem. The Xiaomi lost its connectivity and it is not reachable by ping for some seconds several times during the day as the picture I previously shared. I will try buying a new Xiaomi HUB as I already tried everything else.

I think your hub is switching between 2.4ghz and 5ghz. The encryption must be AES.

Hi Grabber,

Thanks for your answer. Actually the Xiaomy HUB only supports 2.4ghz. On the other hand 5ghz is disabled on the router. I have tried all the encryptions.

Something I noticed now is that I have 3 Xiomi HUB in 3 different houses connected to 3 different routers and all of them do the same. They lose pings in similar pattern. It can be stable for hours and then during one hour or so have a lot of small periods of some seconds in which lose all the packets.

Im pretty sure this is happening to more people. Very anoying.

3 days history period in my father house:

3 days history period in my house:

3 days history period in a friend house:

Same issue here with multiple ac partner gateways. What I’ve found is that some gateways switch to “remote connection” instead of “network connection” and this correlates packet loss.

Any clues on how to force network connection? Maybe blocking some servers in my router?

It looks like same issue is discussed here. I also saw my gateway blinking blue probably when reconnecting:

You may be right. Zigbee channels also collide with wifi. My setup includes multiple aqara hub/relays all connected to different zigbee channels. I think xiaomi needs to upgrade firmware with improvements to multiple gateway scenarios - selection of zigbee channels at the least.

I am getting this issue with only one Gateway at home and also if I tell the router to use always the same channel, don´t matter which one. I am curious on what you described first. Why the gateway changes from network to remote connection? And where do you see that? I would like to explore it.

New update for the Xiaomi HUB has been released. Testing now. So far everything works. I will update my other 2 HUBs in different flats and will monitor the packet loss for 3 days before getting back to you.

I have the same problem.
To which version of Xiaomi HUB did you update ?
I have 1.4.1_175.0220 and it says it’s the latest.

Same here. Hope an update will fix but the problem started a long time ago.

I’m having the same issue, nowhere near as bad as most users on this thread though. I noticed it a couple of weeks ago as certain motion sensors were not triggering lights.

Took a look in to it and the hub was offline for a minute or so a day according to HASS. The hub does not have permission to connect to the internet and I haven’t updated the firmware so i figured maybe it was just dying.

Since I put an automation in to notify me when the hub goes offline everything has been rock solid for over a week.