Xiaomi Mijia 1s Vacuum Integration


Is it possible to add this 1s version of xiaomi vacuum to Hassio? This kind of new product, distributed only in China so mby it is not doable?

There is a link, this is a new version of xiaomi vacuum


The existing integration might work https://www.home-assistant.io/components/vacuum.xiaomi_miio/

But I dont know if this one is tested explicitly…

1 Like

yee i saw that, it should work but mby someone already tested it with 1s.

Bump, can anyone confirm that the 1S, works on the current integration? I’m willing to buy one but with it being the Chinese version, I’m not sure about the integration…

Can confirm it works

1 Like

Tried it too. It works fine.

I recently bought this vacuum based on these last two posts, and I can’t get it appear in HA. It’s always Unavailable. :neutral_face:

I’ve tried the token as lowercase as well as uppercase.

I’m on the latest version of HA Core.

My config

  - platform: xiaomi_miio
    token: cfd17d4dea2f1316092c82519f464d00
    name: XiaomiVacuum

My error log (get these every 20 seconds or so);

2020-02-28 23:03:38 WARNING (SyncWorker_9) [homeassistant.components.xiaomi_miio.vacuum] Got exception while fetching the state: No response from the device
2020-02-28 23:03:49 WARNING (MainThread) [homeassistant.helpers.entity] Update of vacuum.xiaomivacuum is taking over 10 seconds

The token should be correct:

And the IP address of my vacuum (from my vacuum Network settings screen):

Any suggestions much appreciated :smiley:

Hey Tim.
Do you get your vacuum online in HA?

Yes, I did. It turned out the instructions (or my brain) are slightly vague, and I was using the wrong token. shuker set me straight.

how did you get your token?

I used the iOS section of the instructions, instead of the first section (Xiaomi Home App) which is what I was previously doing.