Xiaomi/Roborock Vacuum Firmware update

Does the new software support multiple floors?

Yes it does, you can see it in the Roborock android app as well. Most features of the S6 have been backported to S50 :slight_smile:

Ok, so i will get separate floor drawings?

Yes, you will.

Thank you!

I have an error in Home Assistant (xiaomi_miio integration, S50) after upgrading to version 2008:
The fan speed just displays a number (102 for me).

Is this also the case with your vacuum, or is it just me? Maybe I have to delete a the entity and add it again to function correctly?

Same here… i have turbo in app, in HA i have “102”… But before update the fan speed was not showing same i HA ass i Mi app. I could have Max i HA and Medium in Mi app. So i had never got this working.

I have had the same issue in the fan speed with a Xiaomi Vacuum 1S and manage to work around it with the following configuration:

input_select:
### Vacuum Fan Speed ###
  fan_speed:
    name: 'Fan Speed'
    icon: mdi:fan
    options:
      - Quiet (101)
      - Balanced (102)
      - Turbo (103)
      - Max (104)

sensor:
  - platform: template
    sensors:
### Vacuum Cleaner current fan speed (specific mapping for 1S needed) ###
      fan_speed:
        entity_id: vacuum.oh_my_vacuum
        friendly_name: 'Fan speed'
        icon_template: "{{ 'mdi:fan' }}"
        value_template: >
          {%- if state_attr('vacuum.oh_my_vacuum', 'fan_speed') -%}
            {%- if is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 101) -%}
              Quiet (101)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 102) -%}
              Balanced (102)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 103) -%}
              Turbo (103)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 104) -%}
              Max (104)
            {%- else -%}
              Unknown
            {%- endif -%}
          {%- else -%}
            Unknown
          {%- endif -%}
		  
automation:
### Change Vacuum to selected fan speed ###
  - alias: 'Set fan speed'
    trigger:
      platform: state
      entity_id: input_select.fan_speed
    action:
      - service: vacuum.set_fan_speed
        data_template:
          entity_id: vacuum.oh_my_vacuum
          fan_speed: "{{ states('input_select.fan_speed').split('(')[1][:-1] }}"
		  
### Sync input select value to always be equal to actual vacuum selected fan speed ###
  - alias: 'Sync fan speed'
    trigger:
      - platform: state
        entity_id: sensor.fan_speed
    condition:
      - condition: template
        value_template: "{{ states('input_select.fan_speed').split('(')[1][:-1] != state_attr('vacuum.oh_my_vacuum', 'fan_speed') }}"
    action:
      - service: input_select.select_option
        data_template:
          entity_id: input_select.fan_speed
          option: >-
            {%- if is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 101) -%}
              Quiet (101)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 102) -%}
              Balanced (102)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 103) -%}
              Turbo (103)
            {%- elif is_state_attr('vacuum.oh_my_vacuum', 'fan_speed', 104) -%}
              Max (104)
            {%- endif -%}

You can try it yourself, just by replace entity ID vacuum.oh_my_vacuum, for your own entity ID.

It’s a workaround, but allows not using Mi Home for this purpose. I found a PR in the vacuum python library used by HA, but there was a lot of confusion and discussions before this could be agreed and implemented…

Hope this helps.

1 Like

Most people say map function doesn’t work in FloleVac after upgrade. Can you confirm it still works for you?

1 Like

I discovered something weird: after doing this update, my S5 was no longer available in HA. Thought: buggit, damn! Too fresh to find anything in the forums… now after reading this thread and about the IP change, I tried around a little bit. Mine did not / could not as I gave it a reservation in my router. Also the name still was pingable. In the app, everything was working fine though (cool new features), also the token did not change (checked it). Everything rebooted, twice, thrice even. Then I replaced the dns name in config.yaml by its IP, nothing else. Restart HA —> IT WORKS! Double checked back (not working) and forth again (working again), so it’s reproducibly a problem with dns name, which was working before. Even resetting the lease didn’t fix it. I keep it now as it is fixed. But still that’s very strange to me and I always try to work with DNS names, not IPs. Maybe my information helps anybody!

I updated the firmware. Robot now has problems with navigation, maps. . . More or less totally lost it’s mind. . .

HI, Mine is not avaialble anymore … try to reboot as I’ve fixed IP address and still dont works … unavailable in HA … any idea how to fix it ? … i would hate to reset the robot as it will loose once again the map …
UPDATED : :slight_smile:
somethings , we learn after several hours …
After resetting the Wi-Fi settings of the Xiaomi robot vacuum, a new Access Token will be generated

Had the same problem today, Noticed the Token was changed with the Upgrade,
Obtain your new token and it should work without any issue… (With no need to reset)

I have a Xiaomi robot vacuum V1 with FW 3.3.9_003468. There is an firmware update to 3.5.4_004007.
Can I update it without risking to loose my connection with Home Assistant ?
Has anyone tested this specific FW on this xiaomi vacuum ?

hi,
i’m using 3.5.7_002008 and everything works ok.
only issue is that i’m not able to get the map via flolevac as this app is broken for the new firmwares.

Do you also have a Xiaomi Vacuum V1 ? How come you have 3.5.7 and I am proposed 3.5.4 ?
Can you briefly let me know if there are new features that are worth upgrading the vacuum ?

I’m having the v2 gen. with this latest formware, you are now able to set rooms in the chinese app and just vacuum per room. the visuals also changed for the better

1 Like

Anyone else notice that the fan speed list sensor values have changed and the fan speed sensor reports unknown?

My fan speed list has always been, silent, balanced, turbo, and max in both the app and through the HAss sensor. Now it reports Silent, Standard, Medium, Turbo, Gentle for the HAss fan speed list sensor?

Fan Speed changed some months ago, from:
Quiet
Balanced
Turbo
Max

TO:
101
102
103
104

1 Like

Are you running 110.0? Did you update your vacuum?
HA has been updated to match new speeds from latest firmware