Xiaomi Sherlock Smartlock

how to unbind the S2?

Anyone can help me on this? The ADB command is not working. I am using Redmi 7A phone connected with my ubuntu 18 box.

How you did it? Do you mind to guide me? I have Redmi 7a phone

How you did that? I am using Redmi 7a phone for that but not working

Anyway to improve the torque of the motor on this? Seems it is not powerful enough to unlock my badass door that locks on all sides.

I don’t have sherlock lock yet, but I am sensing lock/unlock state of my classic door lock with modified aqara door sensor, I disconnected reed switch and soldered small endstop micro switch,and I was able to put it in cavity where lock is sticking out to the door frame. Friend of mine used two springs acting as contacts,and since the lock is from steel, when locked it closes the circuit.

1 Like

Hi everbody.
Don’t make it too compliacted, buy 1 Original Aqara ZigBee Window / Door Sensor.
Buy 1 little Neodymium magnets and 1 superglue.
Now open the Sherlock cover and put 1 Magnet with superglue on the down side of the cover.
Remove the Zigbee from the plastic (very easy) and put it as per the picture into the red key holder.!
Thats all, now you have your true and false with zigbee and can control it with iobroker or homematic etc.
cheers sherlock

3 Likes

1 Like

2 Likes

@sherlock, I think @luc3as solution is more robust, as if I understand correctly it monitors for the actual door lock latch engaging. With the Reed switch solution (which I also have), it is possible in some cases that the Sherlock rotates, but doesn’t actually properly engage the latch.

I just made this:
Damage approx 15eur.
1key
1shonoff 5v
1Stepdown modul to 3v
Works fine with assistant.

1 Like

Does anyone knows where I can find the remote key? I tried in AliExpress but it’s out of stock and the only available it’s in Russia and they don’t deliver to Germany any tips?

2 Likes

Hello. I have a problem with Sherlock S2 configuration. When I try to add it in the application, I get a message that it is already bound and I need to delete it first.
Someone knows if you can reset it yourself. Developers do not reply to messages.

Just received my sherlock s2, but can’t get the app to send me any kind of verification code, dutch phone number (+31), outlook.com email. Does someone know what to do?

Hi, maybe it out of topic, but i cannot find the topic for my problem.

My problem is how to share the key management?

I have shared my home for family in MI APP, all device are shown on my family member except sherlock m1, I’ve tried the setting for key management distributions and add my wife MI ID, and successfully added and shown under users management, but i still cannot find the device in my wife MI APP.

Thank you

Sadly I think only the devs can do something about it.

It is weak that it depends on the developers whether you can use the purchased device

Sweet solution, Can you post some photo to understand how its done?

Jep, I just issued a claim at PayPal to return it :sweat_smile:.

I think it’s a good decision