Xiaomi Yeelight E27 bulb component

I have same issue in HA.
I had same issue in [yeelight-homebridge] plugin. but, yeelight-homebridge developer solved this issue.
(yeelight-homebridge developer is Yeelight staff developer)

http://forum.yeelight.com/t/homebridge-plugin/83/118 <<< this is that thread.

I checked yeelight-homebridge log.

new code effect is reconnect between yeelight, homebridge server. (almost every 5sec)

maybe HA must reconnect to yeelight often.

sorry for bad english

Same here… after the upgrade to 0.57. No bluethooth config here. All yeelights come available for some time… and fall back to unavailable

Just got one yeelight-white and wow its a headache to get it to work in HA

all am getting is unavailable

I have tried lots of combination

  • platform: yeelight
    name: ‘testing 1st yeelight’

still no luck it working great on the app. also, the device_tracker says it home and I tested home and not-home and this park I know is true.

Love to see some’s setting where its working

Did you enable LAN Control in yeelight app?

how do I enable LAN Control in yeelight app and enable development mode
I have look all over the app and I don’t see where to do this

I wrote up some detailed instructions here. Not sure if they are still up to date.

In new yeelight app it looks like this.

Development mode is renamed to lan control.

Hmm, I saw the new app and was wondering if I needed to update the instructions. I don’t have rights to edit that post anymore though.

Maybe that should be changed in yeelight component page?

Do you have time to do it? Ill try to get my app updated and submit the pull request this weekend I don’t see a change before then.

I have time. But i don’t have confidence in my english. :slight_smile: i would rather leave that to someone who is more fluent in english. And for this comment google is my friend. :slight_smile:

Gotcha, Ill try to get to it this weekend.

I have version 3.0.03 and it does not have lan control

developement mode is turn on the phone in phone setting if that matters

My app is also 3.0.03. Is your firmware 1.4.1_48? And is your server Mainland China?

the firmware is 1.2.4_18. just I just this from the android market ,
the server is the US

You must update bulb to newer firmware.

I see that… am trying everything to upgrade the firmware but its not allowing me to update it… amusing the US firmware is that a factor?

change it to mainland china

thanks I finally got it working … again thanks switching to china did the trick. again thks