Yamaha YAS-109

Does anyone know if a Yamaha YAS-109 is supported in HA as a media player?

Yes, I have mine setup as one.

How did you config it? Cannot make mine works.

I have YAS-209, which integration did you use?

I tried the yamaha platform as this:

  • platform: yamaha
    name: “YAS-109”

but it doesn’t work.
How did you configured your YAS-209?

All I have in my configuration.yaml is:

  - platform: yamaha

And it detects and sets up the media player as


And you are using a YAS-109?

I have enabled discovery (and verified that it is working for other integrations) and added the stanza to my configuration.yaml:

  - platform: yamaha

Restarted home-assistant, to no success. I also tried to configure the platform manually by adding the key host: 192.168.x.y but it seems as if the underlying module is hardcoded to connect to a http-server, and my YAS-109 is only exposing a https server (which is very broken, I’ve tried using openssl/curl/browser to understand it but it is refusing all connections because of SSL issues no matter how many special params/settings I try).

What FW version is your bar?
System Version: 3.01(3.6.8815)

Yes I have a YAS-109

Firmware version is 3.01(3.6.8815)
Build Date 2020101517

I’ve tried your configuration and it still doesn’t work. What kind of router you use and on what device home assistant is installed? I think it may related to that.

Thanks Roger, appreciate your reply! I must echo BergyDergy’s sentiment, something is different between ours and your setup.

I am running home-assistant inside a docker container with the param --net=host, and my router is capable of WI-FI to wired mDNS proxying since I can see the soundbar is detected over mDNS on the host using avahi-browse -alr.

What’s your home-assistant setup? Daemon straight on host? Hassio?

I’m currently looking at https://github.com/home-assistant/home-assistant.io/issues/14153 https://github.com/home-assistant/docker/issues/23 since they seem somewhat related.

I’ve tried to resolve the mdns name of the soundbar with avahi-resolve inside the container. The answer is: SoundBarSteup_3025.local. Could it be the issue since it doesn’t reply yamaha.local as my Yamaha receiver?

After further troubleshooting, I finally found a solution!

I found a github issue where a contributor suggested running python3 -m netdisco dump (inside the container). The returning output from that command suggested to me that the yamaha device is available under dlna_dmr:

bash-5.0# python3 -m netdisco dump
Discovered devices:
[{'host': '<redacted>',
  'manufacturer': 'Yamaha Corporation',
  'model_name': 'Yamaha soundbar',
  'model_number': 'V01-Oct 15 2020',
  'name': 'YAS_109',
  'port': 49152,
  'serial': '00001',
  'ssdp_description': 'http://<redacted>:49152/description.xml',
  'udn': 'uuid:<redacted>',
  'upnp_device_type': 'urn:schemas-upnp-org:device:MediaRenderer:1'}]


Having read the official docs on discovery before I remembered something specific about dlna_dmr, it has to be explicitly enabled to start operating. As soon as I modified my configuration to enable dlna_dmr discovery and restarted the HA container, the soundbar was detected with the name media_player.yas109.

example from configuration.yaml:

  - platform: yamaha

    - dlna_dmr

It’s working! Can you select the inputs thought? Right now I can only set the volume. ON/OFF doesn’t work neither.

Just took a look and I don’t seem to be able to run any media_player.<operation>, including volume up/down and turning on/off. As a matter of fact it seems as if any changes to my discovered device isn’t being picked up by home assistant. Will double check my setup.

Changes are being picked up and updated when I look at the device in developer tools, but trying any media_player.<operation> yields no changes.

@HA_Rog are you able to control your soundbar? Like increasing volume using media_player.volume_up or shutting it down using media_player.turn_off?

@fisk I’ve just tested changing volume, and yes it did work, although moving it to maximum in the media player component only takes the actual soundbar to 70% volume so not perfect but works.

@HA_Rog thanks for letting us know. Could you also share the version of home-assistant you’re running? Also, can you confirm that you have the same dlna_dmr discovery: configuration?
With that info I should have enough to troubleshoot/create an issue to make sure this integration performs consistently for all of us.

I am running 0.118.5

I currently don’t have dlna_dnr discovery enabled in my configuration.yaml.

Do you want me to enable it, will that help you with anything?

My apologies, I had totally missed your reply.

Your not using the same Discovery metod which might affect how connection to the device is setup (guesswork). Could it be your running home-assistant on bare metal or hassio and not behind a virtualization layer such as a VM or container?

Edit: could you run python3 -m netdisco dump from within your HA installation and paste the output (you can redact or remove everything unrelated to the yas-109)

Many thanks for letting us know!

Wow thank you for this. Just found out that Costco version is rebadged same and this worked for me. Thanks!!!

Only weird thing for me is the last word gets cut off when push tts notifications