Yeelight Homekit issue

I’ve got a question that I can’t seem to find an answer to in Home Assistant forums or the Yeelight forums.

I purchased a Yeelight strip, the LED strip one, back in September of 2018. Recently Yeelight released a software update to the stip, 2.0.6_0063 which added Homekit support.

After applying this update Home Assistant no longer automatically discovers the light as a Yeelight, I have the “Lan Control” on.

Instead what I’m seeing is Home Assistant discovering a new device repeatedly called

The challenge is, my device didn’t come with a Homekit code, so I don’t have the 8 digit code needed to actually try and connect it via Homekit. I’ve tried the default one suggested in the Yeelight forums (111-22-333) but it doesn’t work.

Any ideas on how I restore the functionality where Home Assistant just used the Yeelight LAN control instead of Homekit?

Also, I have discovery disabled for Homekit, but it keeps re-discovering… Is there something I’m missing?


Thanks for your help in advance!

1 Like

Rebooted multiple times, yet it’s still discovering my Yeelight. ??

Same problem here. 2 of my led strip’s (firmware 2.0.6_0063) don’t work in Home Assistant anymore. they still work in the Yeelight app. My other yeelight devices work fine (2 bulb frimware 1.4.2_0076 and one strip firmware 1.4.2_0050).

After I added specific configuration to address them they’re working, but auto discover is still annoying and keeps finding it as a new HomeKit device.

Check out my post, this is what got the strip working for me again after the upgraded firmware.

thanks for the reply. this works also for me

1 Like

Hi @MaikaiLife,

I recently bought a Yeelight Strip (yldd04yl) and tried to add it to home assistant. I got it connected to the Yeelight app, updated, but i can’t seem to get it to home assistant. I can see it being auto-discovered, but having the same issue with not having a homekit pairing code.

My configuration:


    - homekit
    - yeelight

yeelight: !include yeelight.yaml


    name: kitchen_strip

Am i missing something, or any idea why it can’t be added?


I think you’re missing device type after your device name. You won’t be able to use Homekit if it didn’t come with a code, which is fine since it works independently of Homekit with the standard yeelight integration.

Do you mean the model name? I understood it as that was an optional setting according to And the yldd04yl doesn’t have a model name as of yet…

Yes, exactly. My idea was connecting it to home assistant and then use Homekit integration to forward it to homekit.

It’s possible that additional config line is optional, I was just looking at variances between our configurations. However without a Homekit number there is no way to use the Homekit integration. You could try the default Homekit id, which is think was 111-222-333, but it never worked for me.

Same over here: Ignore Homekit Accessory?
Working with manual configuration, but still discovering Yeelight as HomeKit device.

…and “- homekit” doesn´t seem to be a valid ignore option within the discovery integration: :roll_eyes:

For me it’s not working anymore with the latest Yeelight update.

I tried:

  • Restarting the LED Strip
  • Checked that LAN control is enabled
  • Tried to remove and readd the configuration my configuration.yaml (see below)
      name: Lichtleiste Bad
      transition: 1000
      model: strip1
      use_music_mode: False #(defaults to False)
      save_on_change: False #(defaults to True)

Still does not work. I’ve also got the message that I can connect it trough HomeKit but it does not appear anymore. Device shows up as “not available”.

Same here.

When electrically switching off/on the bulbs they re-appear as available in HASS but that doesn’t last long…

I tried to control my yeelights using IFTT but that was a mess.

An update - is scheduled to be deployed next week… I’m just gonna wait for it :-/

My WAF has really decreased since last week, hopefully I’m using yeelight v1 for the toilets and the bathroom !

Hi All,

My lights are still working and have been working since I re-did the config in HA build .99.

Here is what I have in my configuration.yaml

yeelight: !include yeelights.yaml

Then in my yeelights.yaml file

    name: Master Vanity Glow 
    model: strip1

I have the led strip with the following firmware.


I can control the lights fine with Home assistant, however ever time I boot up home assistant the auto-discovery finds it as a “Homekit” device, which I just ignore.


I’ve added " discovery | ignore | -homekit " in my configuration.yaml and I’m not prompted by any discovered homekit yeelight bulbs.

But like I said (I’ve re-tried this morning), after few hours my bulb come “unavailable” and I’ve got to plug them off/on to be able to control them back in HASSIO.

I’m using homeassistant 0.100.3 so maybe the issue come from that…?

I have the ignore also for homekit, but it doesn’t seem to work.


I’m guessing your issue sounds more like a networking problem, considering you have to turn them off/on again.

Do the Yeelights have a fixed IP, you might try that and make sure it’s not conflicting with anything else in your network. I have ha .100.3 and mine seem to be working flawlessly.

I have similar problem since I updated my yeelight bulbs they aren’t recognized by HA anymore. They work flawlessly with the yeelight app. I’ve tried auto config/ manual config/ disabling/enabling Lan for the bulb. I’ve tried unplugging them and replugging them. So far nothing works. I’m on 100.3

Mee too using 0.102.3 on Docker
discovery ignore option ignore “homekit” (its funny hahaha)
Im going crazy with xiaomi lights… on discovery enabled, show one light (of 3) , discovery disabled, put the light manual on configuration, dont work… T_T

If anyone is still having problem with your Yeelight/homekit constantly showing up in persistent notifications panel, I was finally able to fix it by ignoring yeelight. Ignoring Homekit did nothing for me.

    - yeelight

Did you get this sorted? Having the same issue.