YELLOW Multipan Issue

Hi Everyone,

I’m trying to get some help on solving a Yellow Pi issue. I was looking around in settings and found the option to enable multiprotocol. Forgot to look at the note and pressed “submit”. PLEASE DONT USE THIS NOW BECAUSE FOR ME IT BRICKED THE ZIGBEE COORDINATOR.

After restarting I had a new addon and some new integrations as intended. But I noticed that sometimes HA wouldn’t respond and would freeze up on me. Which resulted in restarting HA again and then ZHA started acting up. Seemed like ZHA wanted to start the coordinator but couldn’t and resulted in an error after 3 attempts.

Read to some posts to see that you can flash again the old firmware but this needed to be done manually. Like indicated in link below.

When trying to install the firmware I’m getting block error 0x18 but don’t know what this is.

Since the Yellows have integrated Zigbee (/dev/ttyAMA1) I looked to see what I would get returning on device info but also there i’m not getting info back.

SO does anyone have an idea on how to proceed :p. I’m now running of a skyconnect dongle but would like to get back to the onboard zigbee coordinator.


Boy I have been tempted to click that also. Glad I didn’t! Will be watching this thread.

Not a lot of Yellow people it seems :slight_smile:

I think you should select a different port/device. Something like Silabs… I had the same issue with my SkyConnect and could not flash it too, until I switched the port that listed port/device Silabs…

Forget what the name was. But using that port fixed it for me and was able to flash it with the Zigbee Only firmware again.

Already tried this but no luck. Currenctly running of a Skyconnect stick. Hopefully they make it easier to get back to older firmware. Everytime I restart I also need to check zigbee now because it defaults to the internal one :s

Have ypu tried all of that? If you type it manually, make sure, that you double check spelling!!!l

I have had a whirlwind of issues after doing just the same. I have managed to flash the latest firmware back, but still unable to add any devices. I have also an installed zigbee2mqtt and still the same.

How can you tell if the Zigbee radio is correctly firing, and the logs so no erros (both HA logs and Zigbee2Mqtt)

Still no easy solution for this issue?

Did my check this?