YET another take on an alarm system


#1344

sorry for being slow today, but I read that and I can’t find the configuration settings - where should I be looking? I’m running HA in a docker.

Thanks


#1345


#1346

next to the right to be precise. that one is Activity log :wink:


#1347

ok, maybe I’m not as stupid as I thought as I’ve still got the old GUI.

I followed the instructions from https://github.com/gazoscalvertos/Hass-Custom-Alarm/blob/master/README.md - I thought the master branch was the new UI now?

Thanks for bearing with me


#1348

You probably need to force refresh your browser on the alarm panel.


#1349

Did this break after upgrade to 0.84.0?

2018-12-13 17:31:05 ERROR (MainThread) [homeassistant.config] Invalid config for [alarm_control_panel.bwalarm]: [panel] is an invalid option for [alarm_control_panel.bwalarm]. Check: alarm_control_panel.bwalarm->panel. (See ?, line ?). Please check the docs at https://home-assistant.io/components/alarm_control_panel.bwalarm/


#1350

Are you using the latest version of the alarm?
I am using .84.1 and have no issues with it


#1351

Hi,

Yes I use the latest.


#1352

It works again, after whole reset. :smiley:

Edit: To hot… This shows up; Uncaught TypeError: Cannot read property 'disarmed' of undefined


#1353

I have this error since the last two updates

Whoops!

Something went wrong with your alarm component!

The following errors have been plucked from the Home Assistant log:

Home Assistant: v0.84.1

This Panel: v1.3.4

image


#1354

Same over here :frowning:


#1355

I have not yet updated to .84, still on .83.3, but since a while back I can no longer arm the alarm. It’s complaining about line 770 in the process_event function:
File "/config/custom_components/alarm_control_panel/bwalarm.py", line 770, in process_event if (datetime.timedelta(seconds=int(self._states[STATE_ALARM_ARMED_HOME][CONF_PENDING_TIME])) and override_pending_time == False):

The custom component is the latest version, but didn’t work before updating it either. Have I missed something?


#1356

OK. I upgraded to the newest version of this alarm and homeassistant.
Very good job @gazoscalvertos!! Thank you again for this amazing alarm system!

Here is my feedback:

The settings at the bottom are no longer chopped.
The checkbox is appearing! yay!!
I am not sure if sorting the sensors alphabettically is something I like. Personally I would prefer them to have my own order. eg. sort them in the yaml file and appear in that order. Maybe have an option for this?
Yes the settings are keeping their state even after reboots!
When disarmed I can see the open sensors and ALL sensors. When armed I see them in groups: Open, Delayed and Immediate.

The persistence mode is not working correctly.

Two cases:

  1. Freshly install the alarm. Enable persistence mode and restart HA.
    The bwalarm.py will crash giving an error about persistence in the logs. Didnt keep the error… Sorry…
  2. Freshly install the alarm. Arm and then disarm the alarm so it stores a state. THEN enable persistence mode. The bwalarm will no longer crash but if you arm the alarm and then restart, it will not return to the last state (armed_away) but it will be triggered.

Thank you very much for your efforts on this! It is cool AND effective!


#1357

Same error with the latest update. Anyone have an idea why ?

image


#1358

Check your HA log. It probably is the error I mentioned in my last post:


#1359

ok, i’ll check that tonight


#1360

The crash has been fixed by updating to the latest version of HA 0.84.3
But If I restart HA when the alarm is armed_away, it comes up with the state: triggered and if any sensor is triggered it is doing nothing. So I have to disarm and arm again.


#1361

My error is still here after updating to .84.3. Can someone please help?

Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/helpers/service.py", line 277, in _handle_service_platform_call
    await getattr(entity, func)(**data)
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/config/custom_components/alarm_control_panel/bwalarm.py", line 731, in alarm_arm_away
    self.alarm_arm(code, Events.ArmAway)
  File "/config/custom_components/alarm_control_panel/bwalarm.py", line 723, in alarm_arm
    self.process_event(mode)
  File "/config/custom_components/alarm_control_panel/bwalarm.py", line 777, in process_event
    if (datetime.timedelta(seconds=int(self._states[STATE_ALARM_ARMED_AWAY][CONF_PENDING_TIME])) and override_pending_time == False):
KeyError: 'armed_away'```

#1362

After update to the latest version 1.3.4, you have to reconfigure the alarm.yaml again. Also delete the alarm.json if have in your config folder.


#1363

Thanks. I didn’t realize I couldn’t keep my old alarm.yaml.