YET another take on an alarm system


#1446

I’m having the same issue. It was working yesterday, then I updated today and no bueno. You’d think that a “warning” wouldn’t limit functionality, but so much for that concept. Hoping for a resolution soon!


#1447

It looks like it’s coming from an http call between the alarm panel and the component. But it’s a little out of my league to figure out (but I am looking into it). Hopefully, @gazoscalvertos can jump in with a quick fix:

2019-01-20 21:55:42 DEBUG (MainThread) [homeassistant.components.websocket_api.http.connection.1903579856] Received {'type': 'call_service', 'domain': 'alarm_control_panel', 'service': 'alarm_arm_home', 'service_data': {'code': ''}, 'id': 23}
2019-01-20 21:55:42 DEBUG (MainThread) [homeassistant.core] Bus:Handling <Event call_service[L]: domain=alarm_control_panel, service=alarm_arm_home, service_data=code=>
2019-01-20 21:55:42 WARNING (MainThread) [homeassistant.helpers.service] Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: "all"
2019-01-20 21:55:42 DEBUG (SyncWorker_9) [custom_components.alarm_control_panel.bwalarm] [ALARM] Alarm changing from disarmed to pending
2019-01-20 21:55:42 DEBUG (SyncWorker_9) [custom_components.alarm_control_panel.bwalarm] [ALARM] Pending user leaving house

#1448

I believe it happens when alarm control panel reacts to Away/Home button - it sends an event to the alarm to change state. Needs to be changed in alarm’s code.
However, it’s just became deprecated, and I assume that it does not affect functionality at the moment as it’s only a warning.


#1449

The problem that I’m seeing is that none of my notifications in automation.yaml are being sent. I created a test trigger that works fine, and the only visible indication that something is different is the warning that I’m getting about entity_id; so I am presuming that’s stopping the notifications.

This code works from the switch on the Overview page:

####################
# TEST
####################
- id: test
  alias: 'test'
  trigger:
    platform: sun
    event: sunset
  action:
    - service: notify.ios_tommys_iphone
      data: 
        title: "Alarm Away Mode Armed"
        message: "This stuff isn't working and it's driving me crazy"
    - service: tts.google_say
      entity_id: media_player.living_room
      data:
        message: "This stuff isn't working and it's driving me crazy"s

But this does not, even from manually setting the mode from the Overview page:

####################

Armed - home

####################

  • id: alarm_armed_home
    alias: ‘[Alarm] Home Mode Armed’
    trigger:
    • platform: state
      entity_id: alarm_control_panel.house
      to: ‘armed_home’
      action:
    • service: notify.ios_tommys_iphone
      data:
      title: “Alarm Away Mode Armed”
      message: “The house alarm has been switched on in home mode.”
    • service: tts.google_say
      entity_id: media_player.living_room
      data:
      message: “The house alarm has been switched on in home mode.”

#1450

Well, you didn’t mention it’s not working anymore (mine worked until I rolled Hass.io back).
If that’s the case, it needs to be addressed if the author is still available.


#1451

I’m pretty new to all this, but I just tested again and here’s what I’m finding. Using the code above (with Test and Armed-Home modes), if I 'switch on" test from the Automations section in my Overview page, nothing seems to happen. But if I go into the Logbook page, select the test entity, then choose Trigger from the popup, I’m getting the notifications. But for the alarm, whether I use the Alarm panel, or the Automations section in Overview, or under Logbook - I never get the notifications.

Perhaps I’m an isolated case, and it’s some other issue. But regardless, I’m hoping that someone can help figure out what’s going on !


#1452

Hello,

First off, I love this alarm panel and keeping up with this post has been immensely helpful.

I can arm Home and Away and get pushbullets for both. The siren turns on when the alarm is triggered and I get a pushbullet for that as well. I cannot seem to disarm the alarm when triggered. I see state change to “disarmed” but still, I get no pushbullet, nor am I able to silence the alarm when it’s been triggered. Any advice? My automations are below.

- id: alarm_armed_away
  alias: '[Alarm] Away Mode Armed'
  trigger:
  - platform: state
    entity_id: alarm_control_panel.house
    to: 'armed_away'
  action:
    service: notify.pushbullet
    data:
      message: 'The house alarm has been switched on in away mode. Goodbye'

- id: alarm_armed_home
  alias: '[Alarm] Home Mode Armed'
  trigger:
  - platform: state
    entity_id: alarm_control_panel.house
    to: 'armed_home'
  action:
    service: notify.pushbullet
    data:
      message: 'The house alarm has been switched on in home mode. Goodnight'

- id: alarm_triggered
  alias: '[Alarm] Triggered'
  trigger:
  - platform: state
    entity_id: alarm_control_panel.house
    to: 'triggered'
  action:
  - service: switch.turn_on
    entity_id: switch.siren
  - service: notify.pushbullet
    data:
      message: 'ALARM TRIGGERED!!!'

- id: alarm_disarmed
  alias: '[Alarm] Disarmed'
  trigger:
  - platform: state
    entity_id: alarm_control_panel.house
    to: 'disarmed'
  action:
  - service: switch.turn_off
    entity_id: switch.siren
  - service: notify.pushbullet
    data:
      message: 'The house alarm has been Deactivated'

Thanks so much!


#1453

I figured out my problem. I didn’t understand what the Automations section was for on the Overview page, and they were all turned off.


#1454

just for info, i am also receiving this warning below,
and i am not even using this alarm project, i am using the original mqtt one

[homeassistant.helpers.service] Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: “all”


#1455

Yes - I’m seeing that as well. It’s just a warning, so doesn’t impact functionality or performance. It’s somewhere in the alarm code. (see my previous posts, above).


#1456

I’m having the exact same issue. If either of us find a solution, be sure to post here!


#1457

Interesting… I restarted and everything seems okay now. I’m just getting this all set up, so I’ll test further.


#1458

Seems that it will be fixed in next release:


#1459

Are you still having this issue or did your restart help? I can’t seem to figure it out.


#1460

The restart did the trick. But I haven’t messed with it much since the initial test.


#1461

My temperature on the alarm panel is showing Celcius. Everything else is in Fahrenheit - did I miss a setting somewhere? I have by units set to imperial in configuration.yaml, and also under the darksky component.


#1462

I ended up solving my issue. Apparently 2/4 of my automatons were disabled. Turned them all on and i’m golden now. See attached.

2019-01-22_10-16-23


#1464

I’m running the latest version of this custom component on 0.85.1. I had an alarm trigger yesterday. After the triggered time the alarm went back to away mode and did trigger again the next time the sensor was tripped.

(these were false alarms due to sun on a PIR but that’s not relevant).

You could try updating home assistant.

Also please read the blue banner at the top of the page and format your pasted code accordingly.


#1465

LOL - that was my problem as well. I realized it last night, and just logged in to post my findings. Definitely a “facepalm” moment when I discovered the issue!


#1466

For those who may have updated to 0.85 and the alarm not loading. there was a breaking change in 0.85 that updated ruemal.yaml to to 0.15.81 . The alarm custom component has it hard coded that it must be equal to ruamel.yaml==0.15.42.
For it to work with the new version of ruamel.yaml, open up bwalarm.py in a editor of your choice and change the line that says

REQUIREMENTS = [‘ruamel.yaml==0.15.42’]
to
REQUIREMENTS = [‘ruamel.yaml>=0.15.42’]

save the changes

this allows the component to load the requirements.

Hope this helps till @gazoscalvertos can update componnent