YET another take on an alarm system


#1426

I’m so sorry, i’ve wrongly copy pasted it!

Just swap

- platform: manual 
name: Manual Alarm

with this:

- platform: arlo
  home_mode_name: 'disarmed'
  away_mode_name: 'armed'

For the arlo part, no clue, you have your 2 alarms without your initial error right? Just Arlo not showing up. Thats not on topic for here, i guess your better off in the topic you linked to.


#1427

Agreed - but I still don’t see any entities and I don’t think I can call the service then like this:

  - alias: 'Arlo armed away'
    initial_state: 'on'
    trigger:
      - platform: state
        entity_id: alarm_control_panel.house
        to: armed_away
    action:
      - service: alarm_control_panel.alarm_arm_away
        entity_id: alarm_control_panel.arlo

#1428

You do see the alarm_control_panel.house right?


#1429

That is correct.


#1430

Did you give up on me :smile:?


#1431

Hi guys, I tried changing something in the alarm.css file, but it doesn’t appear to be loading the changes after I restart. Pretty nooby with the whole home-assistant setup… How do I get the changes in alarm.css to propagate?


#1432

No of course not. I just don’t have any experience with arlo. As discussed in the arlo topic you linked, try to remove it and install it again from ground up.

Else try IFTTT: Arlo - not showing anything at all - not even a Control Panel?

I can’t be of any more help, as i don’t have the hardware. We also should keep this topic free of off topic requests.

References:




#1433

Thanks man! Appreciated!


#1434

By updating to 0.85.1, I am getting this error:

Not passing an entity ID to a service to target all entities is deprecated. Use instead: entity_id: “all”

It sounds like a bwalarm thing, since the handling of entities has changed:

Slugify changed, which can impact entity ID creation if the entities had names with either a - or characters outside of A-Z and the integration has no unique IDs. We now better handle the characters and substitute it with an alternative instead of removing that character.

@gazoscalvertos Mind taking a look?


#1435

How exactly did you get it?
I updated to 0.85.1, but didn’t see any errors and alarm worked as expected…


#1436

i’m on 85.1 and even tried with a dev build and dont get any issues

what is the full error message,
Are you using the latest build of the alarm component


#1437

That is changed in 0.85, see the release notes below.


#1438

Hi al, i am also interesed in a new alarm panel , i am now using the MQTT platform and NOT the manual_mqtt platform, because all my logic is my external alam system, i am just sending/receiving mqtt for status and arm/disarm commands, therefore i cant use the manual_mqtt platform
but the mqtt platform now, is verry basic and limited,… so can i use this project instead?

now the onlt thing i can setup is like this below, thats all

alarm_control_panel:
#  - platform: manual_mqtt
  - platform: mqtt
    name: Risco Alarm
    state_topic: "riscopanel/armstatus"
    command_topic: "riscopanel/armstatus/SET"
    payload_disarm: "disarmed" 
    payload_arm_home: "partially"
    payload_arm_away: "armed"

#1439

I see the exact same error. It triggers when I try to arm my alarm. Unfortunately something else also happened after the update. I no longer see the keypad which I also stated in another thread.


#1440

My alarm panel shows the temp info in Celsius, but all my other displays are in Fahrenheit. How do I fix this? I have units set both in configuration.yaml, and under the darksky sensor.

Thank you!


#1441

@AhmadK I am getting it when arming or disarming the alarm.

@aidbish This is the full error

@gerard33 I know… I was on 0.84.6 when it was working fine last time.

@Yoinkz Yes, me too. I have a panel on my lovelace which I am using to arm or disarm the alarm, and I also cant see my keypad. However if I use the default custom panel of this alarm, it works fine, but I still get the same error.

I have this alarm panel and was working fine until 0.84.6 version.
After updating to 0.85.1 it stopped working.
Yesterday I formatted my raspberry and started all over again with new installation of raspbian and HA in virtual environment but still no go…

Two days now, I am trying to figure out what is going on, and I hadnt enabled persistence mode. I just enabled it, and I am now getting this error in addition to the previous one.

3

I have to note that the alarm is working fine. Arming, disarming, triggering and the automations. I am just getting this error and now my panel in lovelace, is useless. I cant disarm the using the default panel unless I open the custom one.


Alarm-panel not showing keypad or Accept input
#1442

Well, all I can say is I updated from 0.83.2 to 0.85.1 and saw some breaking bugs (for example, one cannot have __ in input_boolean, input_datetime, input_number or sensor names) and and plenty of sql-related exceptions in the log. Almost immediately roles it back and waiting patiently for a proper update :wink:


#1443

Did you use the ‘WIPE AND RESTORE’ or the ‘RESTORE SELECTED’?
First time I’m doing this :slight_smile:


#1444

there were breaking changes in .85 regarding entity id’s. have you checked that out in the release notes

post the contents of your alarm config/automations for alarm. this maybe able to help whats going on


#1445

I’m getting the same error about entity_id: “all” however I can’t see anywhere in alarm.yaml or automations.yaml that has a missing entity_id so I’m wondering if it’s in the code code of this alarm system? (ie: bwalarm.py)