YET another take on an alarm system


#1531

Ok, thanks again for your help.


#1532

Hi @AhmadK here is my alarm.yaml
I have changed the disarm codes for both users but the result is still the same
Both users can disarm the alarm and the Activity log is all correct its just in my home assistant long its saying invalid code.

##########################################################
## CUSTOM ALARM COMPONENT ALARM.YAML
## https://github.com/gazoscalvertos/Hass-Custom-Alarm
## VERSION:  1.0.2
## MODIFIED: 18/04/18
## CHANGE LOG:
## Add Multi Codes, names, pics
## optional code to arm alarm
## Default Interface password: HG28!!&dn
##########################################################

platform: bwalarm
name: House
panel:
  cameras: []
  panel_title: SquiggleBear Alarm System
  enable_clock: 'False'
  enable_weather: 'True'
  hide_passcode: 'True'
  hide_sidebar: 'True'
  round_buttons: 'True'
  enable_sensors_panel: 'True'
  shadow_effect: 'True'
  camera_update_interval: ''
  enable_clock_12hr: 'False'
states:
  armed_away:
    immediate:
    - binary_sensor.kitchen_back_door
    - binary_sensor.large_wardrobe_one_motion
    - binary_sensor.large_wardrobe_two_motion
    - binary_sensor.wee_bear_night_light_motion
    - binary_sensor.squiggley_night_light_motion
    - binary_sensor.small_wardrobe_motion
    - binary_sensor.toilet_motion
    - binary_sensor.bathroom_window
    - binary_sensor.bedroom_window_one
    - binary_sensor.bedroom_window_two
    - binary_sensor.kitchen_window
    - binary_sensor.skylight
    - binary_sensor.vestibule_motion
    - binary_sensor.garage_door
    - binary_sensor.garage_motion
    - binary_sensor.office_window_one
    - binary_sensor.office_window_two
    - binary_sensor.front_door
    delayed:
    - binary_sensor.kitchen_back_door
    - binary_sensor.vestibule_motion
    - binary_sensor.toilet_motion
    - binary_sensor.front_door
    override: []
    pending_time: 0
    warning_time: 0
    trigger_time: 600
  armed_home:
    immediate:
    - binary_sensor.kitchen_back_door
    - binary_sensor.front_door
    - binary_sensor.kitchen_window
    - binary_sensor.skylight
    - binary_sensor.office_window_two
    - binary_sensor.office_window_one
    delayed: []
    override: []
    pending_time: 0
    warning_time: 0
    trigger_time: 600
  armed_perimeter:
    immediate: []
    delayed: []
    override: []
    pending_time: 0
    warning_time: 0
    trigger_time: 600
users:
- id: cb8a0d4bbb7d4c23a16bf15c0e8b7580
  name: squiggley woo
  enabled: true
  code: '1234'
  picture: /local/images/smiley_punk.jpg
- id: 62ea6913ba3b417da800e53c8c5ff9a0
  name: Control Panel User
  enabled: false
  code: 62ea6913ba3b417da800e53c8c5ff9a0
  picture: /local/images/ha.png
- id: 58dda8187f21406d87e1a6bd507f9c5c
  name: Claire Valentine
  enabled: false
  code: 58dda8187f21406d87e1a6bd507f9c5c
  picture: /local/images/ha.png
- id: 58dda8187f21406d87e1a6bd507f9c5c
  name: wee bear
  enabled: true
  code: '5678'
  picture: /local/images/bear.jpg
code: '4242'
panic_code: '0000'
enable_persistence: true
passcode_attempts_timeout: '600'
admin_password: DangerAlarm42

Do you see anything wrong with it?


#1533

I can see no obvious problems with your alarm.yaml
Let’s summarise: you have 2 users enabled + admin code.
Could you explain in details what they do so it doesn’t work (I presume it’s about wee bear?)
If it involves any using automation, please post it here. And a bit of the log file that includes and surrounds the message in question (provided it is related to the alarm component) would be useful as well.


#1534

I have stripped out all automations to do with it to try and pair it down to the minimum.
Everything works just fine. I just keep getting a log message saying invalid code…which is causing me to wonder if its working properly. I want to be sure it rock solid afore I connect it up to a siren and possibly annoy my neighbours loads.


#1535

Mate, nobody can help you if you’re not willing to explain what you did and what you got. Easy.


#1536

Ok, I’ve just made 2 PR requests (you need to use both 1 and 2) to display sensor’s name in Activity log.

Feel free to test/report issues if it will make you happier.


#1537

Did you try changing these two codes

  name: Control Panel User
  enabled: false
  code: 62ea6913ba3b417da800e53c8c5ff9a0 ###<———-###
  picture: /local/images/ha.png
- id: 58dda8187f21406d87e1a6bd507f9c5c
  name: Claire Valentine
  enabled: false
  code: 58dda8187f21406d87e1a6bd507f9c5c ###<———-###

#1538

@tom_l Hi Tom no I havent touched them as they are disabled and the alarm system does not use them


#1539

One cosmetic (missing icon) bugfix for HA 0.87.0


#1540

Greetings,
Is anyone else seeing the following errors in the log when arming or disarming?

2019-02-07 14:00:33 WARNING (MainThread) [homeassistant.helpers.service] Not passing an entity ID to a service to target all entities is deprecated. Update your call to alarm_control_panel.alarm_arm_home to be instead: entity_id: all

At HA 0.87.0 the message at least got more verbose. I can arm and disarm through the Lovelace panel and not get the warning. It doesn’t seem to be coming from my scripts or automation’s, but I could be wrong?


#1541

Same here… We are talking about the icon on the left menu right?
Did you just request it to be fixed in the next release?


#1542

Yes, it used to be less detailed (without what’s called).
It’s alarm’s thing, not yours.
Will have a look tomorrow, should be easy to fix.


#1543

Yes, check PR’s comment.
I suggested an edit to the custom-alarm component, but it’s up to author to approve the merge so it’s available.
However, anyone can just edit their own files (or download mine) and have it fixed until they merge.


#1544

Where can it be downloaded and whats the steps?


#1545

Click on the link, you’ll see Files changed: 1 under title.
Click on it.
Then click on a pen symbol under Review changes button and you’ll see content of the modified file.
Copy it and save as panel_custom.yaml


#1546

Perfect! Much appreciated!


#1547

2 @rgregrowe and all: have a look at these fixes.


#1548

Thank you AhmadK, That fixed it. Just a note for anyone applying the change, I had to reboot HassIO for the change to take affect.


#1549

Well, if we’re talking about changes in alarm.html, you only need to clear cache of your browser.
In case of bwalarm.py HA restart is needed as to reload the custom component.

And make sure you clear cache on ALL your devices if you have more than one.
Not doing so might cause the errors/warnings to stay forever.


#1550

Anyone who have updated to 0.87 & has the missing icon in the sidebar, just swap it to one thats working, I chose the ‘home-lock’ icon. To swap it edit your entry in ‘panel_custom.yaml’ to something like this.

  • name: alarm
    sidebar_title: Alarm
    sidebar_icon: mdi:home-lock
    config:
    alarmid: alarm_control_panel.house ## USE THE SAME ID AS USED IN YOUR ALA$