Z-Stick Gen5+ not showing in Hardware in HA (Synology VM)

I run HA on a Synology VMM. I have 2 sticks connected and both are working fine (Sonoff zigbee and an very old Aeon Z-Wave stick S2).
I want to connect the third one Aeon Z-Stick Gen5+.
I mount the stick as usual with VMM ( it shows as Sigma Designs, Inc Aeon Z-Stick Gen5+ (ZW090) - UZB) but I can’t find it in HA/Settings/Hardware where both other sticks are. I have tried to remove one of the old sticks and connect the Z-Stick Gen5+ to the same usb port - nothing changed. Now I can see only one stick in Hardware. Plugged back both old Z-wave S2 and Sonoff - everything works fine.
I connect the stick directly to Synology with no extension cord.

I run latest version of HA.
Any ideea please?


Any help please?

Maybe add to the title it is on a Synology VM. Synology does weird things with USB sticks, so you need some one with Synology knowledge.

Correct. Please search “Synology + usb + passthrough” around here or around the internet.

I am under the impression that Synology has removed a certain type of USB drivers in recent years, as such the USB dongle you plugged in are not fully recognized and thus not being able to passthrough to VM.

The solution is to build the driver and load the driver onto your Synology box manually, and you likely will have to do that after every Synology OS updates.

You should not need drivers when using VMM.

Did you add the new USB device to the VMM config?

I have the same setup and Z-Stick and the following shows the Z-Stick settings in Synology VMM (Action - Edit - Others) and HA (System - Hardware - All Hardware), the first USB shown is obviously a Zigbee stick:

If you make any changes to the USB devices in Synology VMM then you may have to restart HA to see the changes.

I agree with others that you should not require any drivers with Synology VMM.