Z-Wave graph (without the python)

You need to understand how battery powered devices work.

They are always monitoring whatever they are supposed to. Water, door, window, etc. But they do not bother to transmit until they sense a change. This is to save battery as the radios take quite some power.

But most of them are set to push a status update on some interval. Some 3600 seconds, some 14400 seconds. Some you can program. This is to preserve battery and it’s not until this is sent you get all the status updated as to neighbors, battery, etc.

When you wet-finger the sensor you are causing it to wake up and send what it’s made to sense. But you do not get the full status with that update.

So just because they can take time to update initially they are likely all ok and just waiting for the next update time.

When sleeping you can not wake the device from the controller side; as it’s not got the radio powered to hear a request. It’s running radio silent until it has a reason to wake up (due to sensing or due to wakeup interval)

**Note: some Zwave + devices change this somewhat.

Oh sorry. Yes totally understand. I was really just commenting on the comment above about battery devices. Really just kind of saying “relax” that’s how it works. :slight_smile:
Thanks for the good info though

x2 i don’t run hassio either… I run a in a virtual python environment on debian linux.
would like to see a non-hass io method.
thanks for the work!

Zwave is a lesson in patience :wink:

2 Likes

Haha. Absolutely agree. I’ve went from Smartthings to hubitat to Home assistant. Overall I think zwave is great. It’s been the most stable by far. These days the most issues I have is when I mess with it for no good reason. Haha

Using @Buster image as an example here – the tooltip used to be “readable” and somewhere along the long it changed as shown in his screenshot where there’s no line breaks. Anyone have any idea why? Or if it’s fixable?

Would it be possible to add a visual to each box to show ZWave vs ZWave Plus? This would be a big help for those with both type of devices (Yes I am phasing out non plus devices, but the wife only allows so much $$) :slight_smile:

Actually… Bamn I write that then I notice the + sign next to some of the node_id. Perfect that helps :slight_smile:

Just like the python version, how do you go about a massive one? :slight_smile:

A lot of scrolling to the right. Even though i named all rooms too.

Panel seems to load fine, but all my nodes show up as unconnected even hours after being on, using/healing etc. They are all powered mesh devices. Any ideas?

I’m using home assistant via docker if that makes any difference.

Under Configuration -> zwave do the nodes in the dropdown show as complete?

I too noticed the network not updating, think it was 0.91 where it broke? There was a change to not refresh network topology in the background which I suspect is related. Result is everything except the ZWave hub is grey and not connected, but the network is actually working just fine. If you look at a node Node Information in ZWave config, it has no neighbors. Click Refresh Node, then Node Information and now it has neighbors and shows up as linked to the hub in the panel.

My graph shows fine in 0.92.2

Selecting my hub and calling refresh node worked. Thanks! (everything did show as complete before that)

1 Like

I am not sure why. I am running the latest version of chrome and it’s not respecting the br tag. I added

+ “\n” +

To each of the lines under the title property of the entity. In my version of the code that starts on line 450. It produced the correct output of what you and myself were looking for.
Capture

2 Likes

Guys, I am not getting a correct picture of my zwave network.
Some devices seem unconnected

@AdamNaj @NigelL Is there a github repo we can follow to track this script? I’ve found individual posts linking to github gists but not sure if it’d be better to follow a repo

I have this bookmarked.

1 Like

Hello, I have downloaded the raw zwavegraph2.html file and put it in my config/panels directory and added the panel_custom lines to my configuration.yaml file but cannot get anything to show up when I click on the Z-wave Graph link in the sidebar of my HASSio instance in Chrome. It works in firefox. Any ideas?

You need to run a network heal or just wait till all zwave devices report.