Z-wave is frustrating for me, please advice

Tags: #<Tag:0x00007f7392e3bf68>

Hello to everyone,

I have been struggling months with Z-wave, first with wink hub, it didn’t refreshed the states of sensors and didn’t worked well with fibaro hardware, then I went with an Aeotec Z Stick Gen5 and tried OZW Beta and Zwave integrations, nothing seems to work, I’m using Zwave for sensors (Motion, open/close and temperature mainly) Everything is battery operated except for a couple of switches. I don’t have long distances between the stick and the sensor (like 8m) And every time im getting this:

The sensors that are actually reporting are from Insteon.

I have been searching in the community posts and there are people really happy with the integration.

Is there any advice that you can give me? I’ve tried healing, testing, restarting, different platforms (RPI, Proxmox, NUC) nothing seems to change between this tests.

What’s the problem?

What I see in that picture looks pretty normal.

What is the host system? I had an Aeotec stick in a Raspberry pi 3 and it worked well. When I moved onto a Raspberry Pi 4 it was not too good unless the stick as at least about 1m from the Pi. Close to the Pi it got lots of communications errors. It appears that the Pi interferes with the ZWave wireless on this controller.

I don’t have the option to have the Z-Wave controller that far from the pi, it has to be plugged directly into the usb port so I changed the controller.

The problem is that te devices are sleeping or initializing and the state never change, so no reporting if a door is open or if there is motion in any room, my automations and alarm system depend on sensing in real time

Is an Aeotec stick gen5 connected to a core i5 laptop running proxmox, the stick is connected using a 6ft USB extension (the laptop is inside a cabinet ) the stick is near a Hue Hub, Insteon Hub and WiFi mesh device (Luma WiFi)

what entities are you using to look for the sensors? It looks like you have associated zwave.mydevice_whatever and you should be using a “sensor” or “binary_sensor” that was created… if you go to the z-wave configuration page, select a node, and look at “entities of this node”… are there more entities there?

1 Like

Sleeping is normal

Initialising is pretty normal

Sounds like your mesh isn’t healthy. You need more than a couple of switches I suspect.

I’d second the reply from @Bartem, your using the wrong device, you need the

sensor

Or

binary_sensor

If you don’t see the sensor or binary_sensor - i always find it useful to wake the device manually (usually press quickly three times, at least it is for the device I have). The sensor entities tend to show up after you wake the device ones it paired.

I’m using this kind of entities: binary_sensor.linear_nortek_security_control_llc_wapirz_1_motion_sensor_sensor_3,

I’m seeing that every node is in CaheLoad State, when I wake the devices they start sending their status changes but in the morning they are again sleeping and not sending info, also the temperature sensors are stucked in the same value until I wake them, is there any config option like wakeup value that i should look at?

There are generally lots of parameters you can change in each device. The number of which is device specific.

If you are using the normal Z-wave integration, in HA go to Configuration, Integrations, and then in the Z-wave box select ‘configure’.
image

Next to ‘Z-Wave Node Management’ use the drop-down menu to select a node:

Then down the page you will have ‘Node Configuration Options’ where you can select the different parameters that the device lets you change. Change the value you want and hit ‘set configuration parameter’ to send that data to the node. Be aware that the device needs to be ‘awake’ when you send data to it, so make sure your battery devices have been woken first.
image

Look up the manuals for your particular devices to find out what parameters you can change

1 Like

Thanks, I’ve changed the wake time value from 3600 to 1800 (I know the batteries will yell at me), and the trigger wait time, now some of them are waking and reporting. I’ll be testing the automations with this values. Thanks everyone for your help

Device wakeup is a big power suck if set too aggressively. Many sensors also have a “% of change” variable that can be adjusted to get updates on the measurement more or less frequently based on changing conditions.

A 10% change report will update much slower than a 1% change report. Applying this to temperature data could mean the sensor will report it’s value if the temperature goes up or down like 74.3 to 74.4.

Also, wake time has no bearing on the device reporting in. I have devices with a 7 day wake time, and they behave as expected.

The sensors are working now, but my switches aren’t when i switch them in the interface sometimes they change the state immediately, sometimes passed 20-30 sec and sometimes they don’t even know the button was pressed, I’ll be playing with the values in the next days. Thanks everyone

Sounds 100% like a mesh quality issue - more routers, better placed, should improve things

I have had troubles for months with z-wave. There is a windows tool called Zensys. I used it to setup and cleanup my zwave network, there is a clear comm-log and gives an overview of the network, made me enthousiast again.
After that connect the aeotec Gen 5 stick back to home assistant have patience and wait.
It’s stable for weeks now.
I’m running home assistant in a virtual Linux os on a windows server host. Zwave with this stick did not work for me when running ha on Windows.

1 Like

I’ve just ordered 4 zwave plus outlets, hope that helps

Just Found the software!! I’m gonna play a little bit and let you know, again today my switches appeared as Dead :frowning:

Again!! Frustration comes to me!.. Everything was going nice, I restarted HA and now my nodes are marked as Undefined, any advice or experience on this issue?

I haven’t tried it but there looks to be some analysis tools here: