Z-Wave JS Server version is incompatible after 2022.5 update

I had this problem as well. Thinking i am a smart guy i removed the zwave2mqqt addon, thinking reinstalling it would pick up the new version. unfortuatley it didn’t so found myself here. I was able to add the repo and get it installed again however removing it seems to have removed the configuration which has the zwave keys. Is there any way to restore that or am i screwed and need to re pair up my locks?

I believe on HAOS, you should be able to restore (provided “make backup” was ticked) from a backup.

Do you have a backup? If yes, restore to the version where you did not remove zwave2mqqt. Without removing, add the repo and update your add-on.

I feel like this is a bigger issue. Why is this required repository missing? It was missing on my system too. Thank goodness I didn’t I didn’t update yet or the WAF would have gone WAY down. It bothers me that the Add–ons page says “In general, there is no need to install this repository on your Home Assistant instance. It is activated and added by Home Assistant by default.” It was there on my system before, and I didn’t remove it, so there was no reason for it to have disappeared.

I was thinking the same thing, and I cannot confirm how long it has been missing on my system.

However, I have, in the past removed add-ons and integrations, so perhaps in one of those removals it removed ‘repository’ along with it? :man_shrugging:

See CentralCommand’s response here. I’m not sure why they didn’t add it back in with an update if they knew that it was broken. But following the links on that page will add the repositories back in.

1 Like

The only repositories that are considered native are the official add-ons repo and local addons. All others are considered custom repositories which means they can be removed. One could argue that the community and esphome ones should be elevated to native but they are separately maintained and developed so :man_shrugging:

The real bug here is that an addon repository should never be auto-removed if you have installed an addon from it. I put in a PR for that but turns out there were other issues with supervisor’s store API so now that’s being worked on.

I take it you didn’t read this thread as it contains the solution which is extremely easy to fix?

Technically, you bricked your setup by installing a .0 release. I mean I completely get your frustration. But if your entire house depends on HA (which by itself I’d consider a major design flaw), then you should know that .0 releases are basically beta releases and very often exhibit instabilities and weird bugs that will then get subsequently fixed in the .x releases that follow shortly after. If you’re after stability, never install a .0 release. Install the latest .x from the previous major release.

And yes, this is a very weird release concept.

I did the 2022.5.0 update this morning (2022/5/6) and it worked OK on my system.
I run a NUC-i3 with Ubuntu OS and docker. Z-Wave JS

I have a loose install of Home assistant core on an RPI and with that also a loose install (so no docker) version of zwavejsmqtt. I had the same issues with the intergration not loading. What I did to solve this on my install was upgrading the install of the zwavejsmqtt to an candidate version.
sudo snap refresh zwavejs2mqtt --candidate (did a refresh since I already have the server installed)
If u installed it also with snap then this could (hopefully) be a thing that can work for u.

This is the way I did to fix the same problem.
Thank you a lot

Unfortunatly this doesn’t work on my installation. Snap is unknown command on my rpi… is there another way?

I read somewhere, there a bug in the snap version. It’s completely unrelated to this thread.

Is you RPi running HAOS, or Debian and then HA core install?

It is HAOS

Then snap is not for you, since it is for “loose install of Home assistant core”, and you are on HAOS install type, which does not use snap.

For HAOS install type… read maybe the first 10 posts of this thread.

I don’t get why I needed to add a mandatory repository… but that worked thanks!

The community store is not a mandatory repository. It’s an optional one.

If you don’t have Z2M installed, what handles the update to the z-wave-js server?