Z-Wave JS Server version is incompatible after 2022.5 update

This is the way I did to fix the same problem.
Thank you a lot

Unfortunatly this doesn’t work on my installation. Snap is unknown command on my rpi… is there another way?

I read somewhere, there a bug in the snap version. It’s completely unrelated to this thread.

Is you RPi running HAOS, or Debian and then HA core install?

It is HAOS

Then snap is not for you, since it is for “loose install of Home assistant core”, and you are on HAOS install type, which does not use snap.

For HAOS install type… read maybe the first 10 posts of this thread.

I don’t get why I needed to add a mandatory repository… but that worked thanks!

The community store is not a mandatory repository. It’s an optional one.

If you don’t have Z2M installed, what handles the update to the z-wave-js server?

The zwavejs addon

1 Like

This fixed the problem for me… Thanx everyone contributing!!!

Thanks, this fixed the problem for me. Running HA on a virtual box instance on my HP Server.
But, one thing I had to do also was to unplug the Zwave USB stick and plug it back in.

I’m running HAOS in a VM. I found that after adding the repository, updating the zwave2mqtt add-on to 0.39, and updating Core to 2022.5.3, I then had to restart the host in order for zwave2mqtt to find the zwave stick. Simply restarting HA or even the HA VM was insufficient. Others have had success by simply unplugging / replugging the zwave stick, but that did not work for me.

Even after getting it all up and running, I was unable to lock / unlock my locks and much of the additional lock sensor data, like battery life, were unavailable. I’ve since gone back to Core 2022.4.7 and zwave2mqtt add-on 0.37. Everything is working now. There are some really great improvements in the May update, so hopefully these zwave glitches get sorted soon.

Thanks for the help, here. I’ll detail my use case:

Issue Statement:

The default add-on repository was missing from my Home Assistant ESXi VM instance after the recent core update from 2022.4.7 to 2022.5.3.

Resolution:

Step 1) Re-adding the add-on repository https://github.com/hassio-addons/repository then updating my add-ons from it (for Node-RED and zwave2mqtt) only half-resolved my z-wave issues, but was definitely a necessary first step (strangely, about half my devices worked after adding the repository & updating from it, including two devices of the exact same make and model, one working and one not. This includes multiple reboots, including even safely rebooting the ESXi server after shutting down the HASSIO VM).

Step 2) The second step that fixed everything for me was to do a network-wide re-interview of devices. It’s available to do in bulk via the general actions button on the Z-Wave JS to MQTT dashboard. I did NOT reset security classes during the re-interviews (left the checkbox unchecked). Once the devices which weren’t responding were interviewed again, they began working as-intended.

Afterthoughts:

It DOES bother me greatly that this repository just went missing (as I remember it being there while adding zigbee2mqtt on a separate occasion a couple of months ago), but for now I’m glad the devices are functioning as-intended on the latest version, again. Thanks for everyone’s help, here.

I have the same problem, but don’t really understand what the problem is and what fixes are proposed above. I’m running HA on a RPi, with HACS and ZWaveJS2MQTT.

Is there a clear step by step explanation of the fix? Thanks!

You’re really making this seem complicated. It’s not. Click the link and add the repo. It’s a single button click to add it.

I had this same issue but have made things worse and now am stuck. I added the repository back and could see zwave2mqtt again but the old version would not show an update button so I added the newest 0.39 which left me with 2 versions of the addon so deleted the old (working) one which then broke the z-wave js integration.

I now get the following error and am unsure how to fix it.

Retrying setup: Cannot connect to host a0d7b954-zwavejs2mqtt:3000 ssl:default [Name does not resolve]

I did try deleting and re-adding the integration but it won’t connect using port 3000.

What should I do next?

EDIT:
I realized the mqtt needed configured since it was effectively a new install. Once done, things are showing back up and the integration is working.

You should restore to your previous backup, add the repository and wait for the update to appear. You can also click the check for updates button to speed up that process.

Thank you. I found a solution which I added as an edit to my original post. Appreciate your response though.

1 Like

This fixed it for me too! Thanks! Should’ve searched here before I tried anything else.