Z-wave Network Becomes Unresponsive

For probably a little over a month now, I’ve been battling with my z-wave network trying to make it stable again. I’m not sure why, but it all of a sudden started just becoming non-responsive. If I reload the zwave js UI addon, it will start working again, but within an hour or so everything stops again.

Details on my HA setup:
Aeotec Z-Stick 7 (fully upgraded firmware. Did that as part of one of my troubleshooting steps)
FW: v7.19.3
SDK: v7.19.3
Home Assistant 2023.8.4
Supervisor 2023.08.1
Operating System 10.5 – Hosted in a VM on UnRAID
Frontend 20230802.1 - latest
Z-Wave JS UI - 1.15.8

Things I’ve tried…

  • unplugging the z-stick (Aeotec Z-stick 7) and re-plugging it in
  • power cycling the entire UnRAID server
  • Switching usb ports, and eventually adding a powered USB hub
  • Replacing the z-stick with an identical model and doing a restore on it.
  • I’ve updated the zwave js ui plugin a couple times over the month (I don’t have a backup old enough to roll back to a known good time at this point)
  • I had an upgrade for UnRAID that I did today

Log messages I see sometimes:

- Z-Wave error 200: Timeout while waiting for a callback from the controller (ZW0200)
2023-09-04 19:59:12.905 ERROR Z-WAVE-SERVER: Failed to send the message after 3 attempts (ZW0202)
ZWaveError: Failed to send the message after 3 attempts (ZW0202)
    at Driver.sendMessage (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:4842:23)
    at Driver.sendCommandInternal (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:5039:28)
    at Driver.sendSupervisedCommand (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:5084:27)
    at Driver.sendCommand (/opt/node_modules/zwave-js/src/lib/driver/Driver.ts:5132:30)
    at Proxy.set (/opt/node_modules/@zwave-js/cc/src/cc/BinarySwitchCC.ts:132:24)
    at Proxy.<anonymous> (/opt/node_modules/@zwave-js/cc/src/cc/BinarySwitchCC.ts:154:16)
    at ZWaveNode.setValue (/opt/node_modules/zwave-js/src/lib/node/Node.ts:1122:39)
    at NodeMessageHandler.handle (/opt/node_modules/@zwave-js/server/dist/lib/node/message_handler.js:20:43)
    at Object.node (/opt/node_modules/@zwave-js/server/dist/lib/server.js:42:96)
    at Client.receiveMessage (/opt/node_modules/@zwave-js/server/dist/lib/server.js:119:99)

Looking at the controller statistics I see growing numbers of dropped packets in both the messages and commands areas.

I’ve pretty much just gotten to the point where I don’t know what else to try. I’m hoping someone here might have some ideas…


You didn’t mention if the Z-Stick is plugged directly into a USB port on the PC, or is mounted away from it. (Is the powered hub still in close proximity to the PC?) This item was suggested to me early on in my conversion from a Vera Secure to a Z Stick. Works great and I think it would be worth a try. Currently less than $10USD

This should reduce or eliminate RF interference from the PC and may help your situation.
Also, remove any dead nodes. This also helped my stability issues as I was first starting to migrate.
Best of luck!

1 Like

Forgot that part as one of my troubleshooting steps. In it’s normal operation before everything started, it was hooked to a 3ft. usb extension cable. I also tried swapping that cable out as well.

Post / look at the other zwavejs log files - zwavejs_. I think what you posted was the z-ui log file.

This bug seems to be effecting a lot of folks in 2023.8.x, while the bug is fixed, it hasn’t been released yet. With those logs in debug mode - see it you see the “jammed” message.

I pulled the log from yesterday, and it does have many jammed message in there along with the “no longer jammed” as well. So I guess I’ll just have to wait until the next zwave js ui is released, and see if that has a fix.

I was going to put up the log file itself, but I don’t see a way to do that on here. Only thing I can upload are images.

Looks like the fix was just released in, so if you are running zwavejs-ui grab it:

If you are running the HASS add-on, looks like that was just revved to a version that has the fix. Possible it gets released to tomorrow in 2023.9.0.

I grabbed that as soon as I saw it come up. I’m still having the same issues. I’m still seeing the jammed messages in the log as well. I tried restarting the addon which does the same thing where it works for a little bit, then nothing responds. I tried rebooting the whole vm as well and have the same issue.

What version of the add-on does it say you have?

I have exactly the same, problem is there about a month now. (HA 2023.8.4 zwave JS addon 0.1.89)

For what I can tell the fix should be in 0.1.88 and 0.1.89. If you’re still seeing the controller jammed in the zwavejs log files, post them here.

I’m on 1.15.9 currently for zwave js ui. With the new HA update coming out, I figured I’d just give that a try. After upgrading and doing a full reboot of the vm, my system has been up about 2 hours now. So far the z-wave network has been stable. We’ll see how it’s doing a little later.

I spoke too soon apparently. It’s not responding again. How do I post up a log here? Just posting the text from it would be massive.

Anyone have any other ideas?

This behavior is likely related to other problems being discussed in several threads, For more details, watch:

For now, one workaround is to revert your HA to an older version while the bug is still scurrying around in the code…


1 Like

I came across that yesterday. Looks like I’m not alone.

1 Like

Same problem

2023-10-22 12:48:59.245 INFO Z-WAVE: [Node 063] Is dead
2023-10-22 12:48:59.292 INFO Z-WAVE: [Node 054] Is alive
2023-10-22 12:48:59.371 INFO Z-WAVE: [Node 039] Is alive
2023-10-22 12:48:59.499 INFO Z-WAVE: [Node 038] Is alive
2023-10-22 12:48:59.611 INFO Z-WAVE: [Node 053] Is alive
2023-10-22 12:48:59.660 INFO Z-WAVE: [Node 044] Is alive
2023-10-22 12:48:59.807 INFO Z-WAVE: [Node 055] Is alive
2023-10-22 12:48:59.849 INFO Z-WAVE: [Node 065] Is alive
2023-10-22 12:48:59.895 INFO Z-WAVE: [Node 064] Is alive
2023-10-22 12:48:59.943 INFO Z-WAVE: [Node 048] Is alive
2023-10-22 12:49:07.942 INFO Z-WAVE: [Node 026] Is dead
2023-10-22 12:49:20.319 INFO APP: GET /health/zwave 301 2.076 ms - 191
2023-10-22 12:49:38.483 INFO Z-WAVE: Controller status: Controller is unresponsive
2023-10-22 12:49:50.472 INFO APP: GET /health/zwave 301 5.830 ms - 191

I have the same issue. I have two HA instances, both with similar zwave hardware. The one using the ZwaveJS add-on no longer works; the one with the native zwave integration works perfectly.

I’m now confused how to migrate off the add-on to the native integration.

Same issues here with the “Jammed” problem. Running very new / current ZWave JS UI. Getting prompted by Aeotec (vendor of the stick I use) to pull ZWave JS UI and reinstall to clear any data that may be corrupt. Since I manage everything with ZWave JS and only use UI for firmware updates for the stick or to set system level configuration items, I’m wondering how easily I might be able to just install it and move on…