Z-wave network fails after system reboot

I need assistance on how to get my z-wave network running again.

Raspberry Pi4 with SSD
Z-wave stick: UZB by Z-Wave.Me (with USB extension cord)

Home Assistant Core 2021.11.1
Home Assistant OS 6.5
Z-wave js 0.1.149

15 z-wave devices
Fibaro FGD212 (Dimmer 2)
Fibaro FGS223 (Double switch)
Fibaro FGS213 (single switch)
Fibaro FGMS001 (Motion Sensor, battery powered)
Generic wall-plug

Short story:
After reboot of system the z-wave network fails. Most of the Fibaros are dead or unknown.

Long story:
The system has been running stable on a Rpi3 for more than 2 years. After an upgrade to RPi4 with SSD and then also to Z-wave JS using the wizard,
the system ran fine for a couple of weeks. I have also added a few more Fibaros. But suddenly one node did not report state. I rebooted the system and after this
reboot nodes are not getting online again. Some nodes report active but not ready and some reports as ready, but does not work. I have also seen dead nodes but still reporting as ready.
Some nodes do work. For every reboot anything between 5 and 8 nodes report active after a while. If I wait a few hours and try to re-interview a device it tries for a while and the reports “interview failed”

I have tried to:
reboot system
restart core
upgrade z-wave js to 0.1.49
cut power in the building to reboot all nodes
heal node
heal network

But I can simply not get it to work again.

Any advice on how to proceed?
I have created a dump of network and saved some log file using Debug log level, but I could not find a button to upload the files here in the post? How to I post them here?
When exporting the dump file I get a warning saying it is not complete due to dead nodes.

Any suggestions on how to get it working again?
Or suggestions of where to look for more information to figure out what is wrong?
Unfortunately I cannot understand the log files
and have no idea if the reason for this can be found in them.

Thank you in advance

Healing the network shouldn’t be used with Z-Wave plus devices. I know there are posts on the forum that mention having issues with a new introduced setting that soft resets the controller on starting Z-WaveJS, but it cannot be controlled with the normal integration as far as I know. Try disconnecting the controller and reconnecting it after a few seconds, do not restart the Z-WaveJS addon after that and see what happens.

Zwave stopped working after recent upgrade - Configuration / Z-Wave - Home Assistant Community (home-assistant.io)

If you go to the Z-WaveJS addon within HA and choose Logs, you can copy/paste that onto for example Pastebin.com - #1 paste tool since 2002!

Or if it’s short enough, you can paste it in here with the correct formatting
[ ```
``] (be sure to end with 3x ` )

thank you for your suggestion. I tried it, but unfortunately without success. If I understood the link correctly this was affecting Virtual Machines.

I have put the log and dump files on Pastebin


The logging seems clear on bad communication to/from nodes, the most likely causes:

  1. The SSD (USB 3.0) is interfering too much with the Z-Wave controller, you mention having an extension cord, are the SSD and extension cord as far away from each other as possible? Same goes for the UZB controller, bring it as far away as possible from the RPi.
  2. How far apart are the mains powered devices? Battery operated devices do not relay messages (even though a network graph sometimes suggests otherwise). Can you test bringing the wall-plug closer maybe?

Are you using Security on any of the devices? It causes a lot of overhead traffic.

1 Like

Your diagnos was correct! SSD/USB3 is interfering.
I tried some different USB extension cords, the longest about 1.5m without success. But when I restarted the Raspberry with the SSD connected to USB-2 instead, all the nodes were up and running in about 1 minute.
This rises a new question; is there a way to get rid of the interference from USB-3?
Could I wrap the SSD in tinfoil? Would that help? Any other remedies for this?
It is of course not optimal to have the SSD connected via USB-2.

Honestly I don’t know, I have no knowledge of interference and solutions for them, as my HDMI on the RPi 4 suffers from the 5 GHz WiFi even… happy you found the culprit at least!

Okay, I will continue use usb-2 and look for a solution to the other problem.
Thank you very much for your assistance! :slight_smile: