Z-Wave Switches Not Updating Status (Specifically Aeotec Micro Switches/Dimmers) Fixed!

Tags: #<Tag:0x00007f32652eb0a0> #<Tag:0x00007f32652eaf88> #<Tag:0x00007f32652eae98>

I’ve been hunting down the fix to this problem for weeks, and finally figured out what’s going on, and wanted to share in case others have the same issue.

I have a number of Aeotec switches in my setup, and they’re fantastic. Small, decent price, easy to install, hidden in the box so I don’t have to change all of my decor, etc. And, until I started messing with my configuration.yaml file, worked perfectly fine. When I turned my switch off, the HASS front end reflected the change, everything was great.

But then, in the midst of a HASS upgrade and me playing with the configuration.yaml file, the updates stopped happening. When I physically changed the switch state, it didn’t update the system. If I rebooted HASS, it reflected, but that’s not ideal, obviously. The weird thing is that my GE outlets, also zwave, didn’t have the problem. They functioned just fine, leading me to believe it wasn’t my z-stick, it had to be something with the switches themselves.

Either me adding a soft reset automation to my configuration (which I read somewhere is a no-no for some z-wave devices) or a HASS upgrade messed up the notification configuration in the switches. After a long, arduous search for how to fix it (including removing and re-pairing the switches) I found out that there is a config setting in the switch itself for Notification Status, and it can be set to None, Hail, or Basic. (For searchability of this post, I also looked into the command_class_hail setting, but that wasn’t it) I installed ozwcp (see here for installation instructions: Tutorial: compiling open-zwave-control-panel), changed the Notification Status to Basic for all my Aeotec switches, and voilà! problem solved.

Hopefully this helps anyone else searching for how to fix this issue - maybe even myself the next time I break everything, hah

2 Likes

That’s interesting because I mentioned Hail in this post in September 2016:

In my case, setting hail made all the difference to me when I was setting up my SmartSwitches for my Laundry automation because I needed a better response time. I’ve had it set to hail notification since I installed them and never had an issue.

1 Like

I’m not sure if it was set to Hail before, or if it had a messed up setting (in the XML, I had set it to Hail, but in ozwcp it said None, which I thought was strange)

I should try Hail at some point to see if it works or not, for completion’s sake.

I realize that this is an old thread, but does anyone know if this option is available in Leviton VRS15-1LZ switches? OZWCP doesn’t appear to show it and I was wondering if the XML for the device just didn’t have it.

When I toggle a switch, I see something like this:

	2019-01-01 10:26:04.975 Detail, Node011,   Received: 0x01, 0x15, 0x00, 0x49, 0x84, 0x0b, 0x0f, 0x04, 0x10, 0x03, 0x25, 0x27, 0x2b, 0x2c, 0x85, 0x72, 0x86, 0x91, 0x77, 0x73, 0xef, 0x82, 0xb8
2019-01-01 10:26:04.975 Detail, 
2019-01-01 10:26:04.976 Info, Node011, UPDATE_STATE_NODE_INFO_RECEIVED from node 11
2019-01-01 10:26:04.976 Detail, Node011, AdvanceQueries queryPending=0 queryRetries=0 queryStage=Dynamic live=1
2019-01-01 10:26:04.977 Detail, Node011, QueryStage_Dynamic
2019-01-01 10:26:04.977 Detail, Node011, Queuing (Send) SwitchBinaryCmd_Get (Node=11): 0x01, 0x09, 0x00, 0x13, 0x0b, 0x02, 0x25, 0x02, 0x25, 0x0e, 0xe0
2019-01-01 10:26:04.977 Detail, Node011, Queuing (Query) Query Stage Complete (Dynamic)
2019-01-01 10:26:04.978 Detail, 
2019-01-01 10:26:04.978 Info, Node011, Sending (Send) message (Callback ID=0x0e, Expected Reply=0x04) - SwitchBinaryCmd_Get (Node=11): 0x01, 0x09, 0x00, 0x13, 0x0b, 0x02, 0x25, 0x02, 0x25, 0x0e, 0xe0
2019-01-01 10:26:04.986 Detail, Node011,   Received: 0x01, 0x04, 0x01, 0x13, 0x01, 0xe8
2019-01-01 10:26:04.987 Detail, Node011,   ZW_SEND_DATA delivered to Z-Wave stack
2019-01-01 10:26:05.004 Detail, Node011,   Received: 0x01, 0x07, 0x00, 0x13, 0x0e, 0x00, 0x00, 0x02, 0xe7
2019-01-01 10:26:05.004 Detail, Node011,   ZW_SEND_DATA Request with callback ID 0x0e received (expected 0x0e)
2019-01-01 10:26:05.005 Info, Node011, Request RTT 27 Average Request RTT 70
2019-01-01 10:26:05.009 Detail,   Expected callbackId was received
2019-01-01 10:26:05.014 Detail, Node011,   Received: 0x01, 0x0a, 0x00, 0x04, 0x00, 0x0b, 0x04, 0x22, 0x01, 0x00, 0x00, 0xdd
2019-01-01 10:26:05.015 Detail, 
2019-01-01 10:26:05.015 Info, Node011, Response RTT 37 Average Response RTT 212
2019-01-01 10:26:05.946 Detail, Node011,   Received: 0x01, 0x08, 0x00, 0x04, 0x00, 0x0b, 0x02, 0x82, 0x01, 0x79
2019-01-01 10:26:05.946 Detail, 
2019-01-01 10:26:05.946 Info, Node011, Response RTT 968 Average Response RTT 590
2019-01-01 10:26:05.946 Info, Node011, Received Hail command from node 11
2019-01-01 10:26:05.946 Detail, Node011, Queuing (Send) SwitchBinaryCmd_Get (Node=11): 0x01, 0x09, 0x00, 0x13, 0x0b, 0x02, 0x25, 0x02, 0x25, 0x0f, 0xe1
2019-01-01 10:26:14.979 Error, Node011, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-01-01 10:26:14.979 Detail, Node011, Removing current message
2019-01-01 10:26:14.980 Detail, Node011, Notification: Notification - TimeOut
2019-01-01 10:26:14.997 Detail, 

If I could try having the switch not send out the HAIL command, I’m wondering if the UPDATE_STATE_NODE_INFO_RECEIVED is enough to trigger getting the current state.

One of the advantages of the Leviton switches way back when I got them (5+ years ago) is that they did HAIL and therefore had instant status. I realize that the switches are ancient and many switches do instant status these days.

Thanks!