Zanzito - A lightweight bridge between your Android device and your MQTT/home automation system


#121

It looks like that link assumes that you are running the Mosquitto Broker on a windows machine which is not the case for me. I am running hassio on a Raspberry Pi 3. The Mosquitto broker addon is installed on hassio. Other than the raspberry pi running hassio, the only other machine I have is a windows machine.

Am I missing something basic here? I understand the inclination to say “read the manual” or “use google”, but when you are just starting out and don’t have a comprehensive view of how this is supposed to work, that is much easier said than done. I do appreciate you taking the time to help though.


#122

I think that guide will still work as you are just creating the files that you need to transfer over to the PI, you would have to install openssl first tho’ Then follow the guide putting in the correct info for the PI (hostname/country etc), then you transfer the genreated files to the ssl directory on the PI. then you set up mosquitto to point to the ssl directory and load the pem files into zanzito. This why I don’t bother with ssl :stuck_out_tongue: tho’ I probably should do :stuck_out_tongue: If you are not really going to access HA from the internet you don’t really need ssl. I use zanzito quite happily without :slight_smile: , tho’ I’m not a heavy user, most of what I want are usefull when I’m at home and on my local net.

You may be able to use the original post above to generate the files since you have a PI tho’ with Hass.io I’m not sure if it can be done, I don’t use it :slight_smile:


#123

I decided to take a few steps backwards. I followed some Bruh videos to ensure my MQTT was setup correctly and working. I have that verified. Then I setup Owntracks as a proof of concept. I now have that working. I went back to Zanzito, disabled the SSL/TLS and it worked right away. Once I play with it, I’ll look into adding SSL/TLS.


#124

Hi all,

I just followed your suggestions and tried to run zanzito with SSL.

I created a certificate for my subdomain using synology and let’s encrypt (as for other web services running on my nas): mosquitto.domain.com

Then managed a reverse proxy connection from https://mosquitto.domain.com to http://localhost:1883

But i cant run it with ssl activated. No issue without flagging the security flag.

Where is the error?


#126

@scorpio862 can u send me that automation please.


#127

if im buying the full version,
is it possible to ask on demand picture from any of my devices through my admin panel or from ha?

thanks

EDIT: i couldnt wait so i bought it and the answer is Yes


#128

I have two android devices. Mine is connected and works great. I can pull location and battery information.

However my wifes phone Wont connect. I get the “Connection Temporary disabled” in the logs.

I’ve double checked the username and password, and verified the host and port are connect. But it still wont connect to my mqtt server. Is there anything I could look for?


#129

I use the example in from the manual:

  - platform: mqtt_json
    devices:
      my_device: zanzito/<device-name>/location

When I am inside a building the GPS accuracy is terrible with the result that I switch very frequent between home and not_home. So I would like Home Assistant would ignore inaccurate gps updates. Owntracks https://home-assistant.io/components/device_tracker.owntracks/ has the setting: max_gps_accuracy . Exactly what I want.

The manual says: ‘If you are using Home Assistant, starting from Home Assistant vers. 0.43 Owntracks emulation is not necessary anymore;’

So does that mean this works:

  - platform: mqtt_json
    max_gps_accuracy: 200
    devices:
      my_device: zanzito/<device-name>/location

Config validation does not report an error.

Or should I still use:

device_tracker:
  - platform: owntracks
    max_gps_accuracy: 200
    mqtt_topic: zanzito/<device-name>/location

#130

is it possible to add a some kind of automation to HA that after activating will ask all devices for taking pictures?


#131

I’m not a fan of GPS Logger either. Owntracks can do HTTP as well as MQTT. I really like the Owntracks app, but they’ve abandoned the Android version for some reason. I’d say to give that a try, but maybe look into an alternative. I was hoping GPS Logger would be that for me, but It’s just not what I’m looking for. I’ve been watching how Zanzito is developing in hopes that it may be a nice replacement, but I don’t if it is that for me either. Especially because it’s expensive for an app…


#132

Hi all,

I’m using zanzito 1.2. Just bought a license since the app is great. However after using it a bit I cannot get a location fix anymore. GPS is activated in preferences and allowed for the app in android settings. I tried turning off and back on preferences, and re-installing with no luck. I’m running out of ideas and think it might be a bug. Anyone is having this problem?


#133

I’m also using 1.2 full version and it’s working fine for me.


#134

Will you get the fix with other programs?


#135

I am looking for this same functionality (max_gps_accuracy). Zanzito generally gives good GPS location results. Sometimes (I assume when the GPS connection is less than ideal) the accuracy is very poor. I have seen VERY large circles on the map. I would like to be able to filter out these “low accuracy” readings. They make home assistant think I have entered zones when I have not, which triggers undesired automations.


#136

Hi,

I had this issue recently. Haven’t had time to look into it, but since months ago I had a similar issue and reboot fixed it - I tried it again.

Somehow it fixed it again.
Not sure if something in the app stops responding after it has been open for a long time (Zanzito is usually always on on my phone).


#138

Yes I’m getting a fix for all other apps


#139

I had rebooted before and it didn’t fix the problem. I tried again and it now says location fix but I can see my GPS position is not updated.


#140

@alarreur what did you have a xiaomi phone? i have read that some phones xiaomi and other had that issue.


#141

I got a OnePlusX with OxygenOS 3.1.4


#142

I have been using an oukitel 10000 pro for a few months and I have no problems. try to contact the developer zanzito and explain your problem.