Zha.core.channels.base, async_initialize: all attempts have failed

After 2021.11.1 update, see some new WARNINGS logged. Not sure what it is trying to tell me. I’ve identified one zigbee plug that has stopped being recognized (16 other zigbee devices seem OK). Tried multiple restarts, didn’t help.

2021-11-05 19:20:35 WARNING (MainThread) [homeassistant.components.zha.core.channels.base] [0x3963:1:0x0006]: async_initialize: all attempts have failed: [DeliveryError('[0x3963:1:0x0006]: Message send failure'), DeliveryError('[0x3963:1:0x0006]: Message send failure'), DeliveryError('[0x3963:1:0x0006]: Message send failure'), DeliveryError('[0x3963:1:0x0006]: Message send failure')]
2021-11-05 19:20:36 WARNING (MainThread) [homeassistant.components.zha.core.channels.base] [0x3963:1:0x0b04]: async_initialize: all attempts have failed: [DeliveryError('[0x3963:1:0x0b04]: Message send failure'), DeliveryError('[0x3963:1:0x0b04]: Message send failure'), DeliveryError('[0x3963:1:0x0b04]: Message send failure'), DeliveryError('[0x3963:1:0x0b04]: Message send failure')]
2021-11-05 19:20:36 WARNING (MainThread) [homeassistant.components.zha.core.channels.base] [0x3963:1:0x0702]: async_initialize: all attempts have failed: [DeliveryError('[0x3963:1:0x0702]: Message send failure'), DeliveryError('[0x3963:1:0x0702]: Message send failure'), DeliveryError('[0x3963:1:0x0702]: Message send failure'), DeliveryError('[0x3963:1:0x0702]: Message send failure')]
1 Like

All of my Zigbee devices are now unavailable after the Core upgrade. Seriously, why does this seem to happen with some regularity? Sigh.

1 Like

I feel your pain. Had ZHA lose connectivity to all devices several times after upgrades, it holds me back from using too many devices.

However, I can often resolve the issue just by using ZHA [Add Device] and then a 5 second hold on the device’s pairing button to put it back in pairing mode. That’s enough for HA to rediscover the device. It retains the original name and everything. The only thing you need to set is the Area upon re-discovery (no need to delete the device, nor reinstall the integration, no need to move the device closer to the Zigbee bridge, don’t even have to restart HA).

When needed I just walking around with HA on my cell phone to tap [Add Device] and then push the pairing button, eventually all my covers, switches and metrics are functioning again.

I did that to the device which caused the errors above, within seconds it was pulling data and controlling the device again.

1 Like

Good suggestion, but doe snot work for me. I even reverted back to 2021.10.x and still no dice. Zigbee on HA is simply a crap shoot, but I have 16n devices that I rely on. I get that Zigbee is clearly a second class citizen in HA , but I need to find a solution that at least doesn’t break when a Core update is release. The pattern here is pretty bad.

sigh … the sensor I fixed last night by repairing is lost again this morning.

Is there likely to be a fix for this, or do I need to re-pair everything?

A this point, I’m going to bite the bullet and re-pair all 16 devices all over again and then fix all of the related automations. I really just wish something like “this may break you existing Zigbee network” was mentioned in the breaking changes part of these core upgrades. This is the third time I’ve had this happen and is the reason that I don’t jump on the xx.1 releases anymore.

Maybe the developers should just say that Zigbee is no longer supported or at least warn us about how sketchy the support really is. This doesn’t exactly fill me with confidence that my Z-wave network will keep working after the much promoted migration to the new solution. We will see I guess.

Same here, if I press update configuration on the zigbee integration tab most connections are lost for at least a minute. Logs are suppressed, however the cause seems to be clear (never seen this before)

[0x1B4F:1:0x0006]: async_initialize: all attempts have failed: [DeliveryError('[0x1b4f:1:0x0006]: Message send failure'), DeliveryError('[0x1b4f:1:0x0006]: Message send failure'), DeliveryError('[0x1b4f:1:0x0006]: Message send failure'), DeliveryError('[0x1b4f:1:0x0006]: Message send failure')]

(34 occurrences)!

This happens after each reboot of reload. This is very disappointing. Got a lot of Zigbee devices around.

You can always decouple your Zigbee network from HA. Although most people don’t have problems using ZHA.
You have 16 devices, what are they, and what do you use as a coordinator ?

I’m using a Conbee plugged into my HA host (Proxmox on NUC) for my controller. And I have a variety of air vents, flood sensors and motion sensors that use Zigbee.

I’m still baffled that even reverting back several releases does not recover my Zigbee network, which leads me to believe that some aspect of HA core has altered the config on my Conbee which the restore from backup does not overwrite. But that’s total speculation on my part as I’m not an expert on how HA has implemented Zigpy (or whatever) library.

Regardless, this week I get to traverse my house, crawl around on the floor, perch on a ladder, all to restore what got nuked. Fatal? No. Annoying? Very much.

Hi everyone,

I also faced the EXACT same problem after the last update. The same error message in home assistant as the op and lso Conbee II
I tried the suggestion of holding the pair button but that not only did not fix the problem but also made the working devices stop working! lol
The search did not find any device at all.

Before removing everything I tried reconfiguring zigbee devices from the UI. That passed for some devices that worked fine but failed for others that also worked fine and of course for those that experience the problem…

At the end I bit the bullet and removed all my 22 Zigbee devices :-< or better said I tried my best to remove everything related to ZHA

I thought maybe I give other solutions a try but neither deconz nor zigbee2mqtt worked. They both timed out when trying to communicate with the device ( or something similar to that ) I thought maybe the problem is hardware related but when I tried to set up ZHA again ( all 22 devices smh.) it works fine. at least for now.

I learned a painful lesson to not update home assistant without first making a FULL snapshot. As others have said the snapshot it automatically makes before update is more for decoration than actually fixing problem later.

edit: Sorry this wasn’t meant as a reply to francisp but a general reply to the topic X_X

I see these errors too, but does not seem have any impact. My Zigbee devices are working fine.
Also HA on NUC with Proxmox (Debian 11 VM). My ConBee II is running on RPi2 connected using usbip to HA.

Not sure if its much help, but all I tried was a ‘rediscover’ and then after ~20 minutes everything started working again.

The frequency of my devices dropping has increased a bit, it’s no longer around a HA release or a restart. Now each morning I’m finding HA has a device or two off-line (this is new, used to be stable and just HA updates would mess it up).

While I used to use the ZHA integration “Add device” to pair again, I’m finding I just need to press the device’s pair button for 5 seconds, get the LED flash (not doing anything in HA but watch the device entities) and then in HA it switches from unavailable to working fine. These are mains powered devices, shouldn’t need to be waken up like this.

Oddly, I’ve also noticed the Zigbee Coordinator (Sonos bridge) marked as offline and a RSSI of “unknown”, but yet all the devices are reporting in just fine and the “Last Seen” timestamps are increasing. How are they reporting in if the Coordinator is offline?

BTW - The “zha-network-card” has been very helpful giving me at a glance view of all Zigbee devices, state and a “Last Seen” timestamp.

I find it odd no one can figure out the issue that so many are having. Best way I candescrive it is some entities like those that show open close stop working but battery and temp on the same device keep working.

It seems like once ZHA gets a CRC error for a device it is simply unable to communicate with that device again until ZHA is restarted. It does not appear that ZHA can be restarted independently of HA. I was having CRC errors using a Sonoff WiFi Coordinator which is pretty much listed as not recommended to use any more.

As @francisp pointed out, having the Zigbee network decoupled from HA is nice. I decided to redesign my Zigbee network from scratch:

  • I switched to a LAN based Coordinator with decent antenna
  • Switched to a higher Zigbee Channel which seems to have less interference (based on my Ubiquity access point scans)
  • Converted everything over to Zigbee2MQTT and just uninstalled ZHA a few hours ago
  • Made use of Zigbee groups (super easy in Zigbee2MQTT) which now uses a single Zigbee command to work with many lights, (HA light groups send instructions to each light individually).

Yeah, its was a few days of work to get it up and running and move devices over, and fix my dashboards and automations to work with new entity names.

This was stable enough that I was able to migrate over my last reminding items connected to SmartThings Hub and finally turn that off and I’ll be working on migrating my Hue lights off that hub and turn that off as well.

All helps to reduce Zigbee traffic. I’m at 26 devices now. Monitoring to see how things go.

If anyone is tempted to look at Zigbee2MQTT instead, be sure to use the latest dev version not the December stable version. They are doing a lot of work on the HA integration and automatic entity creation via MQTT Discovery. Rename a device in Zigbee2MQTT and it will rename all the related entities in HA to match. The latest dev build fixed issues I had with some sensors not getting created.

It was also interesting to see the same sensors report different attributes now. For example I had no idea all the Aqara contact sensors that I have already include a temperature sensor, My ZHA installation did not expose it, but it is under Zigbee2MQTT.

It also provides OTA firmware updates to many bulbs. Finally got all my IKEA and Phillips bulbs updated to latest firmware.

3 Likes

Just to chime in a final update. I’ve not had a single device drop from the network and I’ve been able to add everything I wanted (35 devices). Everything is INSTANT, there is zero delay now.

I have an automation which increases a Sengled back door light from 10% to 100% when the door is opened. I used to open the door and look at the light and wonder if it was going to get brighter or not. Now the light reacts before the door is fully out of the door jam, its fascinating how fast everything reacts now.

Removing ZHA, Hue, and SmartThings integrations shaved off about 35 seconds of HA restart time (I restart in 5 to 8 seconds now). Everything is just one Zigbee network the way it should be.

I’m certainly not blaming anything on ZHA. You can’t blame the devs for your own bad choices in coordinators, overlapping channels with WiFi, multiple hubs, and not taking the time to understand a bit more than just the basics of Zigbee network. That said, I’m extremely happy with Zigbee2MQTT and its feature set that I don’t plan on switching back to ZHA to see if all the changes I made would make that environment equally enjoyable.

I mistakenly thought you just bought, paired and marvel at the technology. That only worked for a handful of devices.

2 Likes

I’m having the same issue and have been looking at Z2M for a while. Do you run both the mqtt add-on and Z2M in HA or do you have a separate VM for it/them?

I have Home Assistant, Z2M, Mosquitto MQTT (and others) all running under docker as separate containers.

2 Likes

Same issue here after the 2022.3.3 core update. Someone found a solution in the ZHA?

1 Like