Zha light status not updated after power on or off using a light switch

Hi Community,

when my Tradfri light devices using zha are powered off or on, their status change is not correctly reflected to home-assistant. If I control zha devices from ha, all is good.

I also understand if there would only a delay of a a couple of seconds to a minute, but it does not change until I try to power on or off from ha, then the status is right again.

Any idea, how I can fix this? a way to manually poll status? Also the zha device management page shows the device did not send an update when powered on.

let me know how you folks fixed this.


I have the same issue here. Controlling the bulb from an IKEA on/off switch works fine via group binding, but the state of the bulb is not reflected in the UI. I’m using an IKEA of Sweden TRADFRI bulb E14 W op/ch 400lm.

I checked my IKEA bulbs. Connected to Elelabs - ZHA - Node Red. Can’t see any messages when power on/off by manual switch.
Earlier I had the bulbs connected the same way and the small IKEA remote paired with the bulb. Then they reports status so I can control also other bulbs that way.
But now some clever guys made the small IKEA remote work in ZHA in the latest update so I integrated them in ZHA instead.
I guess it’s possible to poll, at least to find out if they are online or not, but I don’t know how to do that.

I noticed that after an hour or so the status is correct again in home-assistant.

I have some automations where I check if lights are on, but that failed because ha status was wrong.

I also had a look into zha config and I could see in some of the settings a poll config element, but I have no idea how to use it.

Anyone an idea, where to find zha configuration details? I have checked here https://www.home-assistant.io/integrations/zha/ but it is missing all details you can find on the zha integration page.

Where donI need to go to read ob those settings? Maybe that‘ll help me.


If I use the ZHA config UI I can ask the bulb for it’s on/off status, and as soon as the command completes the status is reflected in the HA UI. Go to the proper device in the ZHA config UI and issue a “get” on the “on_off” attribute in the “on_off” cluster if you want to test it. I haven’t found a service call for this though that could be used in automations.

tried it, but with a device, where I powered it off using a light switch, I still see the lamp as on.

So does not work that way, but indeed, for a bulb that I power on, it works.


Did you ever find the service call for this?

No never and I also stopped to use any zigbee or zwave because of reliability. Switched fully to knx.

I may be a little late, but just FYI, i had the same problem and managed to solve it. When pairing an ikea bulb to ZHA, pairing an ikea remote to ZHA and manualy pairing the remote to the bulb afterwards through the normal ikea method, i observed the same thing. I could turn the bulb on and off through HA ok, but when turning it on or off with the remote, the bulb status wouldn’t change in HA. The solution to this problem was as simple as going to integrations --> HA --> devices --> (the ikea bulb) and hitting the reconfigure button. After that the bulb blinks a couple of times and works just fine both through HA and the remote, with the correct status reporting in HA :slight_smile:


Thanks Andres - this fix just worked for me too.
the status in HA now reflect an ikea bulb turned off or on via an ikea remote within 1 to 2 seconds.

1 Like

Thank you, fixed it for me as well!

Thank you, also here it is the solution for bticino Legrand devices, too.

Just to add. This worked well for me! My group bindings now work as expected and the bulbs update as expected in home assistant when turned on via the remote.

Hard to argue with the tradfri on/off switch when it’s included for free with the 806lm bulb (or at least it is in Ireland for the last few months).

I have the same problem with remote controlled outlets.

I discovered the Reconfigure trick a while back and I think it works fine for bulbs but it doesn’t work for these devices. When I click Reconfigure on such a device, it’s as if something locks up - the back button on the top doesn’t bring me back to the list of devices, and the Reconfigure button stays “clicked”. I can click on Configuration->Integrations->ZHA to get back to where I was so no real problem, but it feels as if ZHA is waiting for some confirmation from the network or something.