ZHA - Lutron Aurora Dimmer Blueprint

Yep I am using the HUSBZB-1 so maybe thats the issue. Luckily I had already ordered something else and will be returning this when it gets here. Hopfully I have success with the other coordinator, I’ll report back…

VERY likely it is. Many have seen this issue and I had 2 sticks that both had the problem. I even worked with Walt (zigbee dev) and tried updating the firmware and scanning zigbee packets with wireshark. He concluded that it was a limitation of the zigbee stack on the Nortek devices.
No problems whatsoever with the Conbee 2.

I got a new coordinator from TubeZB based of EFR32 chipset, still has the same problem :frowning:

Working now with conbee2 but if anyone knows a controller with a bigger radio this works with let me know! Also I altered the blueprint to take over control of dimming from the adaptive lights integration.

blueprint:
  name: ZHA - Lutron Aurora Dimmer v1.3 Adaptive
  description: 'Control lights with a Lutron Aurora Dimmer Pressing in the dimmer
    button will toggle between turning lights on to full brightness, and turning the
    lights off. Rotating the dimmer will increase and decrease the light brightness.

    Adjust the sensitivity if updates from the dimmer are being sent too quickly '
  domain: automation
  input:
    remote:
      name: Lutron Aurora Dimmer Switch
      description: Lutron Aurora Z3-1BRL
      selector:
        device:
          integration: zha
          manufacturer: Lutron
          model: Z3-1BRL
          entity:
            domain: sensor
            device_class: battery
    light:
      name: Light(s)
      description: The light(s) to control
      selector:
        target:
          entity:
            domain: light
    sensitivity:
      name: Sensitivity
      description: Reducing sensitivity will reduce rate of changes being sent to
        lights
      default: 3
      selector:
        number:
          min: 1.0
          max: 3.0
          mode: slider
          step: 1.0
    adaptive_switch:
      name: Adaptive Switch
      description: Adaptive light brightness switch for zone
      selector:
        target:
          entity:
            integration: adaptive_lighting
            domain: switch
  source_url: https://community.home-assistant.io/t/zha-lutron-aurora-dimmer-blueprint/292421
mode: restart
max_exceeded: silent
trigger:
- platform: event
  event_type: zha_event
  event_data:
    device_id: !input 'remote'
action:
- variables:
    sensitivity_input: !input 'sensitivity'
    selected_light: !input 'light'
    selected_switch: !input 'adaptive_switch'
    sensitivity: "{% if sensitivity_input == \"3\" %}\n  1\n{% elif sensitivity_input\
      \ == \"2\" %}\n  5\n{% else %}\n  15\n{% endif %}  \n"
    prior_brightness: '{{ brightness | default }}'
    command: '{{ trigger.event.data.command }}'
    brightness: '{{ (trigger.event.data.args[0]|int) / (sensitivity|int) * (sensitivity|int)
      }}'
- choose:
  - conditions:
    - '{{ command == ''move_to_level_with_on_off'' }}'
    - '{{ brightness != prior_brightness }}'
    sequence:
    - service: light.turn_on
      target: '{{ selected_light }}'
      data:
        brightness: '{{ brightness }}'
    - service: >
        {% if brightness == 0 or brightness == 255 %}
          switch.turn_on
        {% else %}
          switch.turn_off
        {% endif %}
      target: '{{ selected_switch }}'

1 Like

I’ve been using that blueprint for a few months now. Works weel, there is only one problem.

If you use the home assistant app to turn on a light (or if you turn on the light through an automation), using the Lutron switch will not work, you have to press it twice, e.g.:

  1. Turn on light in HA app
  2. Press Lutron Aurora
  3. Nothing happens
  4. Press Lutron Aurora a second time
  5. Light turns off

Is there any way this can be fixed? (I wouldn’t mind changing my automations…)

I’ve been experimenting with the Aurora myself, albeit through zigbee2mqtt instead of ZHA. The reason you’re experiencing this behavior is that the Aurora has its own idea of whether or not your lights are on. At least with my setup, if you have just turned your lights off with the Aurora, and then turned your lights back on with HA, and then press the Aurora, the Aurora will send a brightness of 255 with group 45187 and transition time of 0.07 because it thinks it needs to turn the lights on. This automation will respond by making sure the lights are at maximum brightness.

This is unavoidable without making the automation significantly more complicated, which is what I am working on. The combination of the brightness, group, and transition time is enough to distinguish button clicks from knob turns, but the more elegant way to solve the issue would be to send a Zigbee message to the Aurora to update its internal state whenever you interact through HA. This must be possible, as you can use two Aurora’s for the same room using the Hue hub, and certainly they don’t have this problem. I’m new to Zigbee, so I haven’t figured out how to do that yet.

This is fantastic. I learned so much from your blueprint (I didn’t even know blueprints were a thing), and it “just worked” for light dimming (and on off). I’m using it to control a light zone that’s configured through the Hue gateway.

One issue I was having was orthogonal but felt related to some of the comments above. Thank you for mentioning how to subscribe to events in the developer tools. I saw that I was testing a device a bit too far away from my radio, so the button presses were not detected, and the dimming events were only occasionally being received. Moving closer to the radio made things work as expected.

I’ve been playing with this. Is there any way to tell if the button was pressed? I see the events coming from button pressing as identical to when you twist the dial. The difference is just in the args[0] value. Is there a way to interpret the args[1] value? Thanks again.

@deaton.dg - where do you see transition time and group? It would really help if you can share your automation.

Sorry to take so long here, just seeing this now.

My blueprint is for Zigbee2MQTT and not ZHA, but here it is:

blueprint:
  name: "Aurora Broker v0.1"
  description: 'Create lutron_aurora events from the state_changed of an Aurora.'
  domain: automation
  input:
    dimmer:
      name: Aurora
      selector:
        entity:
          domain: sensor
trigger:
- platform: event
  event_type: state_changed
  event_data:
    entity_id: !input dimmer
condition:
- condition: template
  value_template: >-
    {{
      trigger.event.data.new_state.state == "brightness_move_to_level" and
      trigger.event.data.new_state.attributes.action == "brightness_move_to_level"
    }}
action:
- choose:
  - conditions:
    - condition: template
      value_template: >-
        {{
          trigger.event.data.new_state.attributes.action_level > 0 and
          trigger.event.data.new_state.attributes.action_transition_time == 0.02
        }}
    sequence:
    - event: lutron_aurora
      event_data:
        entity_id: !input dimmer
        type: "level"
        level: '{{ trigger.event.data.new_state.attributes.action_level }}'
        attributes: '{{ trigger.event.data.new_state.attributes }}'
  default:
  - event: lutron_aurora
    event_data:
      entity_id: !input dimmer
      type: "toggle"
      attributes: '{{ trigger.event.data.new_state.attributes }}'
mode: queued
max: 10

In my experience, this is able to correctly distinguish between a press and a twist 100% of the time.

2 Likes

I was excited to give this Blueprint a go, but the Blueprint isn’t even allowing me to select the Aurora. I’ve got it paired directly to HA through ZHA, but I can’t create an automation with that switch. Any help would be appreciated!

@padlocked17 there are a couple of attributes that the blueprint looks for in order to select devices. Would you be able to look at the device page for this dimmer in HA and verify the Manufacturer is Lurton and Model is Z3-1BRL. Also, there should be one entity for their device, the battery.
Just want to make sure the there isn’t a slightly different model out there.
Thanks.

1 Like

@sorrygofish I missed this conversation earlier. My notifications weren’t making to my mailbox.
I haven’t found a real good description for what the second arg in the event is. But it appears to be set to 2 or 7 depending whether the button was pushed or the knob was turned. Sounds like that maps to the transition_time in @deaton.dg ‘s blueprint.

The value switching between 2 and 7 is the thing that zigbee2mqtt refers to as transition_time, and I believe that’s what it is intended to be. In my observations, the Aurora sends a transition time of 2ms any time that it thinks its sending something subtle, but a 7ms whenever it thinks dramatically changing the state of the light.

In particular: a knob turn always results in 2ms, a button press when the Aurora thinks the light is off always results in 7ms, and a button press when the Aurora thinks the light is on results 2ms if it thinks the brightness is around 15ish or below and 7ms otherwise.

Turning the knob always make the Aurora think the light is on, so you can test this by twisting the knob to the left for a bit, and then pushing the button. Since the Aurora thinks the light is on with brightness 2, it will send a 2ms transition time with the button press.

1 Like

Hi, with this bluprint I can use the Aurora with any light? Or just Hue brand? I have some Wiz Connected light that work with Wifi integrated in to HA. Thanks!

Hi @arielo61
This blueprint does not require hue lights. It works with other light brands and integrations and I would expect Wiz to work.

Thanks @deaton.dg (and @bjpetit !)

@bjpetit : your blueprint works just as many have said here - dimming works great, but button presses for power are rarely successful.

@deaton.dg : I’ve tried your code but it seems while creating an automation, I can only select the battery power entity of the Aurora; I can’t assign automation to it to handle any actual dimming or toggling of power. As you mentioned, It may be due to the fact I don’t use Zigbee2MQTT - just ZHA via the Nortek stick.

Is there some mashup of your codes that might yield a blueprint that handles the proper dimming and toggling on/off via ZHA? Pulling my hair out over here.

Thanks!

The issue is definitely the Nortek stick. I spent hours researching and troubleshooting this same issue. I added a Conbee II to my configuration and this blueprint now works flawlessly with ZHA.

1 Like

Did you find a solution to this issue? The automation works great, but I have the same sort of issue.

Another example is turning the light on via a motion automation. If you then press on the Lutron switch nothing happens, but if you press it again lights go off.
This may be more like pressing it once leaves the lights on permanently vs the motion activated timeout the first press, and then off the 2nd press.

I switched to a Conbee II, using zha instead of deCONZ. While the Aurora works with the blueprint…it’s inconsistent at best. Regardless of sensitivity settings (1-3), there is often a delay in the lights responding…if at all.

All lights are Hue (6 downlights) and most are within 10 feet of the Conbee II dongle, which is already on a USB extension cable.

2021.12.x (tried with various 2021.12.x revs). Conbee II firmware is current (can’t check version since deCONZ was uninstalled, but I did flash it before moving to zha)