ZHA stopped adding devices?


I’m running Home Asssitant on a NUC using a Conbee II USb-stick for my Zigbee devices. I recently switched from deCONZ and Phoscon to the ZHA integration.

I managed to add 20 devices without any issues but now suddenly I can’t add any more battery powered devices!

I have tried several devices, some of the same type I already have added. The LED lights on the devices do not indicate a pairing has been made. I CAN add mains powered devices like an outlet.

The logs do not give any information.

I have tried restart HASS, reboot the NUC and unplug och re-install the USB-stick. Nothing help.

I would like to keep using ZHA instead of deCONZ but why isn’t it possible to add more devices suddenly? What can I do?

Do ZHA have a limit on the number of battery powered devices? When I used the same hardware (Conbee II) using deCONZ and Phoscon I didn’t have this issue even when I synced more devices.

Check out this thread. It mentions the limit number of each kind of Zigbee device:

Are all of your Zigbee devices battery powered? If so, you may be bumping up against a limit of the number of directly paired devices to the controller. Do you have any mains-powered Zigbee devices that act as Zigbee repeaters/routers? Adding those will drastically increase the number of Zigbee devices that can be paired.

1 Like

You definitely need some extenders. GE zigbee are great. Sylvania smart switches are also very good.

In theory, the number of end-point devices is around 30. In practice, this number is a little lower. I found with the conbee stick you max out around 24 or so.

For more information google how to create a zigbee mesh.

OK, I think I figured it out.

I had several mains powered devices (acting as routers) but when I tried adding another battery powered device the usual way it didn’t work.

However, when I tried adding another device using one of the mains powered devices (“Add device via this device”) it worked!

I have never had to choose a specific node using deCONZ (or when adding Z-Wave devices for that matter). The software have always sorted this out automatically and configured the mesh network optimally.

I don’t know if the software will re-configure these new devices depending on the best routes. A Z-Wave mesh network will “heal” itself and optimize the different routes. Is this the same for Zigbee mesh networks?


I’m glad it’s working. What might have happened is that there wasn’t enough time between adding the router devices to establish a good mesh. This has happened to me at least once.

1 Like