ZHA stopped working after update

Hey all. I added a hub to plug in both bluetooth and Zigbee sticks. Everything seemed to be working fine until the update to 10.5 Now, neither the Bluetooth or the zigbee stick is not working. Here are logs for
Error setting up entry HubZ Smart Home Controller - /dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_11600383-if01-port0, s/n: 11600383 - Silicon Labs - 10C4:8A2A for zha
Traceback (most recent call last):
File “/usr/local/lib/python3.10/site-packages/serial/serialposix.py”, line 322, in open
self.fd = os.open(self.portstr, os.O_RDWR | os.O_NOCTTY | os.O_NONBLOCK)
OSError: [Errno 5] I/O error: ‘/dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_11600383-if01-port0’

Any help would be appreciated.

Please provide us with a bit more info on your setup.
Have you tried changing usb-port for your sticks? Use an extension cord (>1m) when using zigbee sticks.

Hi, same with me.

I have HA (current version) installed on an old MacBook with Virtualbox (6.1.4 and current extension pack). The Sonoff stick is connected directly to the MacBook.

Does anyone have any ideas?

thank you for your reply and questions. Sorry, Still “new” to this. I am running on a RPI4 with SSD Drive. Extention cable and USB hub. I just ordered a powered hub based on some research. I am hoping that will work but I am more than open to any help or advice. In my efforts to try to fix, I am now not able to connect my zwave either. Hoping the powered USB hub works

Step 1. Get an extension cord, >1m. zigbee controllers are prone to interference.
Step 2. Check that your instance of HA identifies the USB device;
Settings\System\Hardware"Three dots"\All Hardware

Get used to making backups, and store at least four of them over time (daily backups, removed the oldest). On every major update or addition to your setup, do a new additional backup.
Get a separate Google account for your HA, so there will be no issue with storage.

I run this addon and it has saved my setup three four times during the last year.

will do when I return home. Thank you very much

would the usb bluetooth dongle cause interference?

Wrote some more in my post by edit.

Shouldn’t. But could. Anything can create interference.

Thank your for your reply.

I checked the hardware settings. The sonoff USB dongle is not identified!

Do you know what to do? Sometimes the USB dongle is identified and after a while it seems to disappear…

Of course the standard “did you try to reboot” is mandatory.
Then; Some zigbee controllers tend to work sub optimally with USB 3.0 usb-ports. Such ports are sometimes blue-colored. See if you can find a USB 2x port, change your controller to that, then
Developer tools\Check Configuration. If green, hit Restart.

If not working, try a restart of entire HA

Thank you for your quick reply.

I have shut down VB and restarted it. Now HA finds the Zonoff dongle again. The question is for how long?

As you recommended, I searched for USB Devices in the Hardware menu item. Strangely, Zonoff is not displayed, although I was able to activate the USB dongle under Devices.

I installed HA on a VM running on an old MacBook Air, which means USB 2 is already running. Rebooting on the virtual machine and unfortunately not on Home Assistant makes the difference for me. I suspect over time the information about the Zonoff USB dongle is lost between VM and HA. I don’t understand why yet, unfortunately.

I will now buy the USB extension cable and see if that solves the problem.

you can restart (Developer\Restart) by automation once every night. It should not matter. Just dont do it during the time when your backup is running.

Extension cord, 1.5 meters is the trick.
And don’t apply every update that arrives at Settings. Always wait two or three weeks first :wink:

1 Like

One question for the USB extension cord. Is it useful to take USB 2.0 or 3.0?

As far as I know, and please google this before actually buying one, the controllers I have read up on use primarily USB 2x. I have also read forums posts that claim that it is better to use USB 2-ports over USB 3-ports. I don’t why this is, but I myself have swapped to using only USB 2x peripherals (ports and cables) together with my Conbee 2 Zigbee controller.

Thank you for your advise. I will buy one and give an update…

1 Like

Tip is to use a USB 3.0 cable for the Zigbee Coordiantor because thick such cables are usually better shielded (see electromagnetic shielding), but only connect it to a USB 2.0 port or via a powered USB 2.0 hub, as the reason for that is because it is the USB 3.0 port/traffic that generates interference. Read and follow (which contains external link that explain about USB 3.0 specifically) → https://github.com/zigpy/zigpy/wiki/Generic-best-practice-tips-on-improving-Zigbee-network-range-and-general-stability

So it is not the USB 3.0 cables itself that is the problem but the USB 3.0 traffic if connected to a USB 3.0 port. In comparison USB 2.0 cables are usually thin and have little to no EMF/RF shielding whatsoever. Again see → https://en.wikipedia.org/wiki/Electromagnetic_shielding#Example_applications

1 Like

Andrew, I am back home and plugged in my new powered USB hub. I have the Nortek dual zigbee and zwave dongle plugged as well as the bluetooth dongle. I have checked the “three dots” and all hardware. Its a bit overwhelming. I selected usb1 and usb2 as I assume this is where I would see the hub and dongles, but frankly, I do not know what I am looking at or what I am looking for. Again, any assistance would be greatly appreciated as all was working well prior to this update. Thank you so much

When viewing all hardware, use the search box att the top
Try searching for the product name, or the integration that you use to connect to zha

1 Like

I believe I made big mistake. I attempted to restore to prior to the update. when that didnt work, I deleted the integrations, assuming I would be able to easily set up again. Now, this is where I am.

I did try to search the “all hardware” for product name but that didnt seem to work. I am currently trying to set up the zigbee through ZHA. I see the silicon labs (Nortek) when I select the device,
2022-10-25 - Screen Shot 2022-10-25 at 3.37.14 PM

i get the “serial Port Settings” window.
2022-10-25 - Screen Shot 2022-10-25 at 3.39.57 PM

When I select submit I get this error message.

So, I am stuck.

Also, when I attmpt to reinstall ZWAVE JS, i get an error as well.

here is the log error I get after restoring and ZHA failing to set up:
Logger: homeassistant.components.zha.core.gateway
Source: components/zha/core/gateway.py:172
Integration: Zigbee Home Automation (documentation, issues)
First occurred: 3:49:47 PM (3 occurrences)
Last logged: 3:49:54 PM

Couldn’t start EZSP = Silicon Labs EmberZNet protocol: Elelabs, HUSBZB-1, Telegesis coordinator (attempt 1 of 3)
Couldn’t start EZSP = Silicon Labs EmberZNet protocol: Elelabs, HUSBZB-1, Telegesis coordinator (attempt 2 of 3)
Couldn’t start EZSP = Silicon Labs EmberZNet protocol: Elelabs, HUSBZB-1, Telegesis coordinator (attempt 3 of 3)
Traceback (most recent call last):
File “/usr/local/lib/python3.10/site-packages/serial/serialposix.py”, line 322, in open
self.fd = os.open(self.portstr, os.O_RDWR | os.O_NOCTTY | os.O_NONBLOCK)
FileNotFoundError: [Errno 2] No such file or directory: ‘/dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_11600383-if01-port0’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/src/homeassistant/homeassistant/components/zha/core/gateway.py”, line 172, in async_initialize
self.application_controller = await app_controller_cls.new(
File “/usr/local/lib/python3.10/site-packages/zigpy/application.py”, line 144, in new
await app.startup(auto_form=auto_form)
File “/usr/local/lib/python3.10/site-packages/zigpy/application.py”, line 124, in startup
await self.connect()
File “/usr/local/lib/python3.10/site-packages/bellows/zigbee/application.py”, line 124, in connect
self._ezsp = await bellows.ezsp.EZSP.initialize(self.config)
File “/usr/local/lib/python3.10/site-packages/bellows/ezsp/init.py”, line 103, in initialize
await ezsp.connect()
File “/usr/local/lib/python3.10/site-packages/bellows/ezsp/init.py”, line 120, in connect
self._gw = await bellows.uart.connect(self._config, self)
File “/usr/local/lib/python3.10/site-packages/bellows/uart.py”, line 382, in connect
protocol, connection_done = await thread.run_coroutine_threadsafe(
File “/usr/local/lib/python3.10/site-packages/bellows/uart.py”, line 361, in _connect
transport, protocol = await zigpy.serial.create_serial_connection(
File “/usr/local/lib/python3.10/site-packages/zigpy/serial.py”, line 37, in create_serial_connection
transport, protocol = await pyserial_asyncio.create_serial_connection(
File “/usr/local/lib/python3.10/site-packages/serial_asyncio/init.py”, line 448, in create_serial_connection
serial_instance = serial.serial_for_url(*args, **kwargs)
File “/usr/local/lib/python3.10/site-packages/serial/init.py”, line 90, in serial_for_url
File “/usr/local/lib/python3.10/site-packages/serial/serialposix.py”, line 325, in open
raise SerialException(msg.errno, “could not open port {}: {}”.format(self._port, msg))
serial.serialutil.SerialException: [Errno 2] could not open port /dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_11600383-if01-port0: [Errno 2] No such file or directory: ‘/dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_11600383-if01-port0’