ZHA - Xiaomi Mijia Wireless Button (WXKG01LM) Pairing issues


I am having issues pairing two round Xiaomi buttons, WXKG01LM.
I am using ZHA, the coordinator is an Sonoff ZBBrigdge, and i already have 3 Xiaomi WXKG11LM buttons connected, no issues pairing, and have been working fine without interruptions for a few months.

Basically what happens, is that when i try to pair them, and using the new ZHA “feature”, the Zigbee logs, this is what happens:

  1. I press “Add Device”, and go into the “Searching for Zigbee devices”
  2. At this time, i press the pairing button on the Xiaomi device, and this soon appears:


  1. The device doesn’t get connected, these are the logs:

Apparently, the device tries is found, but fails to pair. Anyone had the same issue?

Thanks in advance :wink:


I had the same thing last Friday.

I have arrived. you must press the pairing button for more or less 3 seconds until the led flashes 3x.

Then, you have to press the same pairing button every 2-3 seconds for 1 condés to stimulate it. after a few attempts the button ended up being recognized.

I Tested on 3 buttons and it worked.

Have a good day


Hello @BarTouZ!

Thanks a lot for your fast response, especially because it worked at the first try!

I had indeed read something online about “keeping the button alive” by pressing the button, but i was trying to do that by pressing the actually button, instead of the pairing button!

Thanks again! :smiley:

1 Like

I love almost love you!
You are the first person clearly stating to use the pairing button to keep the device alive!

So many thanks!

1 Like

just to confirm that pressing pairing button worked for me too, thanks

1 Like

Hi! Unfortunately, it doesn’t work that way for me either. It recognizes and adds, but only adds one battery entity. I also tried with two devices.

Do you have any ideas? Thanks for the help!

Hello @ahorvathkaroly!

This is indeed the expected behaviour! The only entity added is in fact the Battery entity.
In order to use the button presses, you can either head over to Automations, and on the Triggers, after selecting your WXKG01LM, you can see there are multiple different triggers for the device.

You can also import this Blueprint, and when creating an Automation based on it, you will see all the button presses you can you!

1 Like

It really does and works perfectly. Thank you very much for your help. :smiley:

1 Like

Did i tell you that I love you for this!!
I was about to pull all my hair out and your post saved me from going bald!

Thanks you mate!

1 Like

That was basically what was happening to me, before @BarTouZ came to the rescue hehe
Nice to hear this has been helpful.

I’ve the same problem. I’ve followed method of BarTouZ Joan but without success.
This is my button, known by ZHA (witch CC2531 USB ZHA coordinator)

You have to assign it to an area. And looks like the device is already added

1 Like

Hi, I am struggling with the same issue and I get an error message after successful initialization. Anything I select or add as Area, I get the same. Has anyone else encountered this?

Update: After I restarted HA, it’s working fine (for now).