ZHA Zigbee Tested Devices...Please add your device results

Yep, you are right. Doesn’t turn off when reaches 0. This is broken.
The dimming is linear and it does feel slow. You could change the “MOVING_STEP” which is currently at 15, but perhaps we should implement “exponential” progression instead of linear one. Stay tuned…

I don’t have experience with docker based installs. If I understand it correctly you really can’t “hack” those setups, which I was doing with my venv based setups.
I need to rewrite these as a custom_component. I started to explore that option, but I wish i had more time to spare :slight_smile: I think as a short term this could be an option, but it really makes sense to get this into Yoda-x’s zha_new custom component.

I just added the husbzb-1 to my home-assistant setup. The first device attempt is the old smartthings motion (original). It is able to pair/join, but I don’t see it as an available entity in hass. I haven’t had a chance to my other devices as my venture from smartthings to just purely hass.

2018-04-29 09:01:01 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=91 command=256 args=b’\xc5’
2018-04-29 09:01:01 WARNING (MainThread) [zigpy.endpoint] [0xa291:2] Message on unknown cluster 0xfc04
2018-04-29 09:01:01 INFO (MainThread) [homeassistant.core] Bus:Handling <Event system_log_event[L]: timestamp=1525017661.8279727, level=WARNING, message=Unexpected response TSN=91 command=256 args=b’\xc5’, exception=, source=core.py>
2018-04-29 09:01:01 INFO (MainThread) [homeassistant.core] Bus:Handling <Event system_log_event[L]: timestamp=1525017661.8951173, level=WARNING, message=[0xa291:2] Message on unknown cluster 0xfc04, exception=, source=core.py>

NWK: 0xa291
IEEE: d0:52:a8:00:2e:75:00:04
1: profile=0x104, device_type=314
Input Clusters:
Basic (0)
Output Clusters:
Ota (25)
2: profile=0xfc01, device_type=314

Still having issues adding new zigbee devices. Turned off zwave and was able to add back a previously added iris open close sensor but unable to add anything new. Any recommendations, I’ve delete the db a couple times, but that did not help.

I do have a lot of errors like this in my log

Message on unknown device

Trying to pair a door sensor I get this:

2018-05-04 12:59:32 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=19 command=1 args=[[]] 2018-05-04 12:59:32 WARNING (MainThread) [zigpy.endpoint] [0x7f1c:1] Message on unknown cluster 0x0500 2018-05-04 12:59:42 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=20 command=1 args=[[]] 

2018-05-04 12:59:42 WARNING (MainThread) [zigpy.endpoint] [0x0aba:1] Message on unknown cluster 0x0500 2018-05-04 12:59:53 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=21 command=1 args=[[]] 

2018-05-04 12:59:53 WARNING (MainThread) [zigpy.endpoint] [0x3140:1] Message on unknown cluster 0x0500 2018-05-04 13:00:03 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=22 command=1 args=[[]] 

2018-05-04 13:00:03 WARNING (MainThread) [zigpy.endpoint] [0xb6cd:1] Message on unknown cluster 0x0500 2018-05-04 13:00:14 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=23 command=1 args=[[]] 

2018-05-04 13:00:14 WARNING (MainThread) [zigpy.endpoint] [0x2e99:1] Message on unknown cluster 0x0500 2018-05-04 13:00:24 WARNING (MainThread) [bellows.zigbee.application] Unexpected response TSN=24 command=1 args=[[]] 

2018-05-04 13:00:24 WARNING (MainThread) [zigpy.endpoint] [0xa70a:1] Message on unknown cluster 0x0500

What does that mean ?

Updated code for SmartThings arrival sensor including 2015 and 2017 models. Its a hack but works for me!

Anyone ever get the SmartThings water sensor to work with HA. I’ve been able to get an older ST motion sensor and ST Open close sensor to work, but no luck with the water/leak detector.

These sensors were quite stable for me on ST, and they are currently on sale for $25, which is a good value, if they could work directly with HA

@ptdalen @pitchdarkice

Fairly certain that when you see messages along the lines of Message on unknown device 0x1af6 you need to perform a reset on the device in question, then join the device with a zha.permit and whatever the device needs. Might help @Argoson also?

I am getting these TSN messages constantly as well for my lightify dimmer switch I paired. I also notice I need to reboot at least daily or that switch stops functioning.

Any ideas?

Unexpected response TSN=79 command=1 args=[[<ReadAttributeRecord attrid=0 status=134>]] 10:27 AM deps/lib/python3.6/site-packages/bellows/zigbee/application.py (WARNING) Unexpected response TSN=78 command=1 args=[[<ReadAttributeRecord attrid=0 status=134>]] 10:27 AM deps/lib/python3.6/site-packages/bellows/zigbee/application.py (WARNING) Unexpected response TSN=77 command=1 args=[[<ReadAttributeRecord attrid=0 status=134>]] 10:26 AM deps/lib/python3.6/site-packages/bellows/zigbee/application.py (WARNING) Unexpected response TSN=71 command=1 args=[[<ReadAttributeRecord attrid=0 status=134>]] 10:23 AM deps/lib/python3.6/site-packages/bellows/zigbee/application.py (WARNING)

I have 4 iris motion sensors (centralite_3326l) and three iris open/close sensors (.centralite_3320l).

I also have one smartthings open close and one smartthings motion sensor.

Overall my experience with the Linear HUSBZB-1 stick has been barely accecptable with these.

When they work, they work great. Fast reporting. I also get temp readings from all of them.

My issue is that they often just stop reporting. usually a quick pull of the battery gets them working again, but I’d say I have to do that at least one time a day with at least one sensor.

What’s mostly annoying is that they often get “Stuck” on.

Where this becomes a big issue is that I have a group with several motion sensors. I have a few automations that rely on the state going from OFF to ON or visa versa. If they are stuck the state of the group never changes, and the automations never trigger.

I bought an Iris zigbee plug to act as a repeater and it has helped a little bit. but not much. I dont have a giant house, these sensors are withing 50 feet of the USB stick, and they are all within probably 15-20 feet of each other in general.

The smartthings sensors seem to be rock solid.

I just really liked the size of the iris sensors. I have not seen a zwave motion sensor anywhere as small as these.

1 Like

I have 14 iris sensors and none of them have this issue. I also have several zigbee plugs around the house too. The range on the USB stick is not that great. None of my sensors get stuck. I have one iris motion sensors that died in 3 days of use so I may disconnect that one. Have you tried to replace the batteries to rule out low batteries?

I have replaced the batteries. Maybe I need more plugs, but at some point that becomes a nusance as too. I will say adding the one plug did seem to help a bit.

Thanks for the info

yea you only need a few of them really, you can use the iris smart plugs second gen. It may sound like a nuisance but its all about building your mesh properly. ST probably has a strong radio than these usb sticks but stuff still works.

What bellows version are you running? I thought without the ZDO Management Join permit broadcast the zigbee “end” devices can only join the network by using the coordinator as their parent.

whatever is in 0.69 you can still pair devices directly to the controller and them work via the powered nodes.

hmm, I know the battery powered devices were not working for me reliably, unless being in vicinity of the controller. The “routers” (line powered) could pair to controller directly and then I could move them, but ran into the problems with “wall switches” as those I couldn’t move easily.

I bought another iris gen 2 plug today. I have what I believe is a pretty dumb question, but figure I’ll ask anyway. The device does not have to be powered on to be a repeater, just plugged, in right. :slight_smile:

correct it doesnt need to be on just plugged in

BTW I didn’t have any luck with Sylvania Smart+ plug
For whatever reason bellows could get even manufacturer and model name. Have anyone tried these?

I want to report back that after adding just one iris 2nd gen plug centrally in my home, that my sensors have been very stable. I have not had any stuck or unresponsive devices.

Another quick question, now that I have these more stable, I’m considering going back and “renaming” them. Not a huge rush, as I’ve already just used the very long names in my groups and automations, but might be nice in the future.

My question is - Is this done in the entitiy registry.yaml same as zwave devices? Anything else? Was not sure since zigbee also has the .db file.