ZHA Zigbee Tested Devices...Please add your device results

Looks like this PR is resolved, does that mean if I upgrade to the latest git I will get battery?

Nope, I closed that one… I was waiting for 2 others to get merged. I’ll probably open a new one this weekend with my changes.


now i am confused. Ikea’s own website says that Ikea tradfri light bulb uses “light link” profile.

so, which one does ikea tradfri uses?

They release a firmware update for the bulbs a while ago.

If you grab one with the new firmware you are good to go - but if you got an old firmware you need to ikea gateway to update it.

For the Tradfri bulbs it works to pair remotes and bulb and HASS. You need to pair the remote with HASS first and then pair the bulb with HASS and then the remote with the bulb. Or other way round. The important part was, that remote and bulb are in the same zigbee network to pair successful.
Even if the remote not show up in HASS you should see it in the zigbee.db.
I don’t have hue remote, but maybe they work similar.

1 Like

So in your case the bulbs and the remote are Tradfri brand?

So you have to dig through the DB to learn the entity name? That’s messy.

I’ve went back to using my Hue hub, and Hue-Sensors custom component and managing rules and flows in Node Red. All entities and config options show up easily - no fuss.

I’m sure this will all get better with more time and maturity.

What does the new firmware provide? I’m thinking I have the older firmware.

Looking forward to it!

I wanted to report that the OSRAM LIGHTIFY Gardenspot RGB lights work just fine. These were the last of my devices to port from SmartThings. :slight_smile:

1 Like

Hi @philip, I know I’m replying to an old message, but I’m having the same experience using 0.62.1 - my Tradfri 980lm tunable white bulb was added via zha.permit without any problems, but it shows up as a switch. The switch works to turn it on and off, but I can’t dim the bulb or change the color temperature.

Do you know of a bug submission for this? If not I’ll make one.

1 Like

I reported it: https://github.com/home-assistant/home-assistant/issues/12213

Bosch ISW-ZPR1-WP13
These motion temp sensors connect using zha pair but then the sensor just flashes 3 times
and never shows motion or the temp in the frontend.

2 sensors show up on the homepage and a binary sensor and sensor are listed in Current Entities

Setup a short automation to test but does not trigger

Test Bosh Motion Sensor

  • id: testbosh
    alias: “Test Bosh Motion Sensor”
    • platform: state
      entity_id: binary_sensor.bosch_iswzpr1wp13_b44cb2ca_5
      to: ‘on’
    • service: tts.google_say
      entity_id: media_player.ccaudio_media
      message: >
      Motion Sensor On. I see you

Running Hass.io
0.62.1 Version
Using HUSBZB-1 as Zigbee Hub

Any ideas or help would be great.


I’ve been waiting on support for these motion sensors for a long time now. :slightly_frowning_face:

I bought four of them since they were so cheap only to find out afterwards they don’t work with HA.

I tried to return them but the guy at the online store where I got them tried to make me sign a return agreement that basically made me give up any refund i should have gotten.

It was a “sure you can return them but I’m not giving your money back” kind of thing.

What I was seeing was that they would pair with HA and everything would show up in the devices page then after a short time they would unpair themselves disappear. I never could figure out how to stop it from happening.

If you can get working I’d love to know how to do it.


I eventually gave up and returned the bulbs. Never reported the bug but I see you just did. I’ll be keeping an eye on it!

I still have these exact Bosch motion sensors too and each release I pray they begin to work, but alas, no dice!

It’s quite obvious many many people are attempting to use them, I’m surprised they aren’t getting any attention!

Hello out there, anybody listening?

1 Like

Can no longer pair my Iris motion sensor. Used to work, now when it pairs, it flashing green and then goes red. Log has errors. I think this is related to the update, release note say bellows is now updated to 0.5.0.

zigbee bug

2018-02-11 21:56:47 ERROR (MainThread) [homeassistant.core] Error doing job: Task exception was never retrieved
Traceback (most recent call last):
File “/usr/lib/python3.4/asyncio/tasks.py”, line 233, in _step
result = coro.throw(exc)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zha/init.py”, line 163, in async_device_initialized
discovered_info = yield from _discover_endpoint_info(endpoint)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zha/init.py”, line 307, in _discover_endpoint_info
yield from read([‘manufacturer’, ‘model’])
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/zha/init.py”, line 303, in read
File “/srv/homeassistant/lib/python3.4/site-packages/zigpy/zcl/init.py”, line 212, in read_attributes
result = yield from self.read_attributes_raw(to_read)
File “/srv/homeassistant/lib/python3.4/site-packages/zigpy/zcl/init.py”, line 179, in read_attributes_raw
v = yield from self.request(True, 0x00, schema, attributes)
File “/srv/homeassistant/lib/python3.4/site-packages/bellows/zigbee/application.py”, line 246, in request
v = yield from send_fut
File “/usr/lib/python3.4/asyncio/futures.py”, line 388, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.4/asyncio/tasks.py”, line 286, in _wakeup
value = future.result()
File “/usr/lib/python3.4/asyncio/futures.py”, line 277, in result
raise self._exception
zigpy.exceptions.DeliveryError: Message send failure: EmberStatus.DELIVERY_FAILED

Got the same thing with Iris motion sensor, used to pair, now it start and then fails

Is there anyone in the dev community working on these?

I posted because when you look for motion sensors this looks to be one
of the better ones for the price and this community has always been
awesome at getting things like this to work.

The sensor shows up and is recognized as a motion sensor, I would have thought that was the hard part.

These are the times I wish I had more dev skills would love to fix it
for everyone.

And since they say they work with Zigbee hubs it’s at least implied that they work with ALL zigbee hubs.

Only after researching did I find that they only work with smartthings with a special setup procedure that the vendor is more than happy to give you. But they manage to leave that detail out of the sales page.

I’m having issues getting a third 3326-L motion sensor to pair in HA 0.54/0.55. I have two previous 3326-L motion sensors I had no issues pairing, and continue to work fine in HA to this day. I’m using the GoControl HUSBZB-1 stick. Any ideas?

Hey @Paul_M did you ever get this figured out.
Im running into the same problem.

I actually already have 5 of the 3326-L’s paired and working, but the last two I have just wont work.
They seem to pair and then drop off right away, never updating.