ZHA Zigbee Tested Devices...Please add your device results


#685

Yes, I believe they will present a problem – if path selection changes and one of those devices becomes the parent/router for the xiaomi sensor then they will eventually be dropped from the network.


#686

That sucks… I have a couple Smartthings Outlets and I like them because they provide current power draw which is how I determine if my Fireplaces are on or off.


#687

I have found Smartthings to be ROCK solid for Xiaom Aqua sensors, all of them, Hubitat not bad so far, so long as signal is good…therefore…

The NUMBER ONE (1) thing to ensure. Your Zigbee Channel is not overlapping a WiFi signal. If you are in a city, you may have lots of issues with that :frowning: due to neighbours.

Once I moved my WiFi channels away from the Zigbee ones, i’ve had no issues.

HA support on the other hand :wink:
Currently have a Motion and Door sensor working fine. Motion timeout on the occupancy seems rather long 15min, but you can also watch the switch with is like 1-2 minutes (i believe signaled from the device)
Motion dropped once after a day… time will tell if that was just flaky whatever, or HA issue.
[EDIT] Motion sensors die after restart of HA :frowning: thats whats happening to me.


#688

Good point on the zigbee RF interference. Do you have and info on this that you can share? E.g. I know what channels my WiFi is running on but how do I confirm what zigbee is on? Additionally, can I change my zigbee channel? FYI I’m running the HUSBZB usb stick on a pi.


#689

I believe ZHA uses Zigbee channel 15 by default.


#690

Zigbee channels vs WiFi channels https://support.metageek.com/hc/en-us/article_attachments/115017048148/ZigBee_Channels.pdf

HA ZHA/Bellows are hardcoded to use Zigbee channel #15 I’m running 3 access points on channels 1, 6 & 11, but I’m using 20MHz bands and not 40MHz allowing greater speeds on 802.11n 40MHz on channel 1 will interfere more with zigbee


#691

can the ZHA/Bellows be changed? I have my Zigbee on other hubs setup in the 19-24 range, so all my wifi is setup at Channel 1’ish. maybe part of my issue with HA and Zigbee (although testing i’m doing is like 5’ away from my HA test hub, so shouldn’t be)


#692

Good question… I don’t know if it is possible to steer an existing network to the new channel. If not, then pretty much you need to reset EZSP, modify bellows channel and form new network, read as – rejoin each device.

Edit: there’s setRadioChannel EZSP command, I just don’t know if you are allowed to change radio channel after the network was formed. Per docs: “Care should be taken when using this API, as all devices on a network must use the same channel.”, which may mean: you need to rejoin the devices after changing the network.


#693

I have the same problem with the Mijia motion sensor. The Aqara ones work fine. Did you find a resolution to this problem?


#694

This is because there is no zha quirks for the Mijia sensors. I am hoping that they can be added soon.


#695

I have the same problem. I do not get a zha_events entry in the log file. I can’t figure out how to detect a double click in my automation. Did you find out how to do this?
thx


#696

Thanks for the reply. Is there a condensed list of supported sensors? I cannot seem to find one.


#697

#698

Thanks for the list!
Agreed, I hope that the Mijia motion sensor is added soon.


#699

at least the channel can be changed… should put in docs so people know to set it before setting up devices.


#700

No :frowning: i’m going to keep using Smartthings with MQTT bridge as its been rock solid… would like to remove Smartthings, but doesn’t seem like Zigbee is a priority here (which is unfortunate, as they have made some great strides). I have order a system to try the zigbee2mqtt which could run on the same machine as HA to reduce any potential for lag.


#701

I’m refering to the Centralite 3210-L (Iris device listed in this thread.)
Did you ever get this to pair as a Z wave repeater? I am using the HUSBZB-1 stick, but have not had much luck. I have two of these, one seemed to show up once, but now just shows dead. The Zigbee works fine. I Googled, but could not find any solution, this worked fine with my SmartThings.

Thanks,
Rob


#702

IRIS / Centralite Zigee Switch / Z-Wave Outlet

Call zha.permit, plug in switch. For Z-Wave, unplug, hold button in, plug in outlet, wait until blue led start to blink and then repeatedly press button.


#703

This is what I was going to basically say as well. I think that you have to push the button 5 times in 5 (maybe 10) seconds. But it was easy to pair the zwave part.

My only issue is, I have two of these, and one shows up as a light.xxx and the other as a switch.xxx

I bought them the same day from the same place. I’ve removed and readded them a few times, but eventually gave up. Not a huge deal, just annoying. I only use these for the zigbee/zwave repeater functionality, so it’s not a huge deal


#704

Thanks guys I’ll try again tonight.

I got them to work, thanks again.