Zigbee Firmware Update Failed

Light Firmware Update failed. It shows:

Installed version: 0x00102100
Latest version: 0x00102428

I click on INSTALL and get:

Failed to call service update/install. Update was not successful - result: <Status.FAILURE: 1>

Screenshot from 2024-02-09 12:33:40

Note: As I was creating this post the update is disapeared.

Note2: I think I accidentally clicked on SKIP

Note3: The update has reappeared in settings and still the same failure.

7 Likes

I’m having the same issue with all my Sonoff ZBMINIL2 devices. All are showing a firmware update is available but clicking install results in the failed error after a few seconds. One device did start to update once, but only got to 1% at 18 hours then stopped.

1 Like

Same thing here. ZBMINIL2 and SNZB-06P. Available update, but firmware fails to install.
Update was not successful - result: <Status.FAILURE: 1>

Same problem with sonoff SNZB-06P and TRADFRI bulb E27 opal 1000lm

Same for me - replying to track status

I tried to update by bringing the devices to be updated close to my Sonoff zbdongle-e and the update was successful. Perhaps the update is not possible with other device-“routers” acting as intermediaries, or if there is a weak signal.

1 Like

All of my battery devices get the same error as the OP, but I have devices sitting just feet away that get to a certain point and stick. Like my Bar fridge has been at 23% for 27 minutes:

image

I like the thought of the router being the issue. I was finally able to take a look at the visualization.

Both devices are connected to a router, the one that worked his highlighted green, the other is grey. Tomorrow I’ll try unplugging the one router and see what happens.

Unlike others mine are in the wall so I can’t just move it closer or to a different location.

1 Like

Same experience with an Ikea Shortcut Button.

I have tried pulling the battery out, repairing, and moving it closer to the radio.

Here are my logs if that helps:

Log details (ERROR)
Logger: homeassistant.components.websocket_api.http.connection
Source: components/websocket_api/commands.py:240
Integration: Home Assistant WebSocket API (documentation, issues)
First occurred: February 11, 2024 at 1:15:13 PM (8 occurrences)
Last logged: 8:47:54 PM

[140535163889344] Update was not successful - result: <Status.FAILURE: 1>
[140535151824320] Update was not successful - result: <Status.FAILURE: 1>
[140535786167488] Update was not successful - result: <Status.FAILURE: 1>
[140535069587264] Update was not successful - result: <Status.FAILURE: 1>
[140535122710848] Update was not successful - result: <Status.FAILURE: 1>
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 240, in handle_call_service
    response = await hass.services.async_call(
               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/core.py", line 2279, in async_call
    response_data = await coro
                    ^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/core.py", line 2316, in _execute_service
    return await target(service_call)
           ^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 892, in entity_service_call
    single_response = await _handle_entity_call(
                      ^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 962, in _handle_entity_call
    result = await task
             ^^^^^^^^^^
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 161, in async_install
    await entity.async_install_with_progress(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/update/__init__.py", line 465, in async_install_with_progress
    await self.async_install(version, backup)
  File "/usr/src/homeassistant/homeassistant/components/zha/update.py", line 177, in async_install
    raise HomeAssistantError(f"Update was not successful - result: {results}")
homeassistant.exceptions.HomeAssistantError: Update was not successful - result: <Status.FAILURE: 1>

Screenshot 2024-02-13 205204

Exact same issue on my side with a IKEA Plug. Currently installed is 0x20024623, newer release would be 0x23089631

Same issue here. Using SkyConnect as ZHA controller and seeing issue across all devices. Most current is a set of Third reality plugs trying to update to 0x1001304b from 0x10013042.

Interestingly, I have managed to get 1 Ledvance bulb to finish updating, but I needed to kick/restart the install every day over a week to make it happen.

That sounds like a plausible explanation.

1 Like

Same issue here with SNZB-06P, does it need raising directly on Github as it seems this feature doesn’t really work well for everyone?

Same Problem here for my IKEA Motion Sensors