Zigbee Firmware Update Failed

I had the same issue with the IKEA Vallhorn and have now at least solved it for myself. I found that the device was connected to the coordinator (SkyConnect) via an IKEA light bulb. I brought the Vallhorn motion sensor close to the coordinator and reconnected it; afterward, the update process started but aborted relatively quickly. Then, I placed the motion sensor right next to the coordinator and repeated the steps — this time the update was successfully completed.

So it seems that some devices in your mesh path and/or the distance can cause problems.

@devosthomas

Same here with a Tradfri shortcut button

1 Like

Oh wait. After many install attempts, I just clicked the Skip option and then, a second question appear. I don’t remember the first option (it was something to remember the skip) and the second was Install (again). I clicked install and it worked. What the…

1 Like

After updating to the latest beta-version of HA, I do not get any update-notification from my affected devices anymore.

I’ve updated a bunch of ThirdReality smart plugs from 0x10013042 to 0x1001304b and fingers crossed, all the updates have gone well so far.

The switches reset (turn on and off again) once the update applies, but otherwise it’s uneventful.

It’s odd, when I upgraded to the version 2024.2 that allowed for Zigbee firmware updates, I got one or two devices. After a couple days I had dozens (I have a lot of ThirdReality stuff), now I have none whatsoever and haven’t since I downgraded to 2024.2.2 because 2.3 broke some of my integrations (known issue, likely resolved now). And, yes, I did first check for skipped updates.

I know the ThirdReality plugs needed updated and I have about 20+ of them, but they don’t show any longer.

I didn’t tell HA to update them, but I pulled one up randomly and it’s got a firmware of 0x10013038 which I think is older firmware. Is there a way to force a re-check?

Same Here with Sonoff

After updating to 2024.3.1 the plugs started to come back and they all upgraded fine. Anything wireless fails, I’m not quite sure how to keep those awake long enough to update since the updates take quite a while.

Yup this is annoying,

Came back home to find all my plugs have upgraded and nothing works :man_facepalming:

Anyone know how to ensure ZHA doesn’t automatically upgrade my devices ?

Thanks

I had to repair all the plugs to get things back up and running… Not amused :confused:

Yes EMF/EMI/RMI interference or not having enough Zigbee Router devices can cause problems with all communication including with updates so do follow these tips and best practices before performing any other troubleshooting → Zigbee networks: how to guide for avoiding interference + optimizing using Zigbee Router devices (repeaters/extenders) to get best possible range and coverage

New version should not do automatic updates unless you explicitly set zha to do so manually via editing configuration.yaml

So chance is that you at one time done so and forgot to remove it by again editing configuration.yaml

Nope, never done this but thanks for pointing me to the configuration

I think the upgrades were initialised by myself manually but that was weeks ago but nothing appeared to happen as I understand the upgrades take hours if not days to complete. Maybe upgrading recently to 2024.3.1 pushed them through ?

Anyway, thanks for your help, I wasn’t aware that there’s a wealth of configuration options for ZHA

I have the same problem with a number of ikea devices… Any solution?

I also updated a couple of my ThirdReality smart plugs to 0x1001304b, but it’s been buggy for me.

Both my plugs start acting weird after several hours - switching them on/off is inconsistent, and power readings are spotty.

I’m not sure if this is related, but I’ve also been having with this exact same smart plug. I use Z2M, but after a firmware update I’ve been having horribly inconsistent results. Z2M appears to use something different for OTA version numbers. I’m seeing 268513355 or v1.00.74. If we’re both running the same firmware, then it seems likely that Third Reality introduced a new bug in v1.00.74 (or possibly v1.00.71, where they fixed the on-off cycling issue).

Seems like it might have been related to my dongle. updating it to the latest firmware seems to have solved the problem.